1 |
slords |
1.1 |
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}} |
2 |
slords |
1.6 |
%global pear_name Log |
3 |
slords |
1.1 |
|
4 |
|
|
Summary: Abstracted logging facility for PHP |
5 |
|
|
Summary(fr): Abstraction des outils d'enregistrement de traces pour PHP |
6 |
|
|
Name: php-pear-Log |
7 |
slords |
1.6 |
Version: 1.12.7 |
8 |
|
|
Release: 1%{?dist} |
9 |
slords |
1.3 |
License: MIT |
10 |
slords |
1.1 |
Group: Development/Libraries |
11 |
|
|
Source: http://pear.php.net/get/Log-%{version}.tgz |
12 |
|
|
Source2: xml2changelog |
13 |
slords |
1.6 |
|
14 |
|
|
# http://pear.php.net/bugs/18864 |
15 |
|
|
Patch0: Log-tests.patch |
16 |
slords |
1.3 |
|
17 |
slords |
1.1 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
18 |
|
|
URL: http://pear.php.net/package/Log |
19 |
|
|
|
20 |
|
|
BuildArch: noarch |
21 |
|
|
BuildRequires: php-pear >= 1:1.4.9-1.2 |
22 |
|
|
Requires: php-pear(PEAR) >= 1.4.9 |
23 |
|
|
Requires: php-pear(DB) >= 1.3 |
24 |
|
|
Requires: php-pear(MDB2) >= 2.0.0 |
25 |
slords |
1.3 |
Requires: php-pear(Mail) |
26 |
slords |
1.1 |
Requires(post): %{__pear} |
27 |
|
|
Requires(postun): %{__pear} |
28 |
|
|
Provides: php-pear(Log) = %{version} |
29 |
|
|
|
30 |
|
|
|
31 |
|
|
%description |
32 |
|
|
The Log framework provides an abstracted logging system. |
33 |
|
|
It supports logging to console, file, syslog, SQL, Sqlite, mail, and mcal |
34 |
|
|
targets. It also provides a subject - observer mechanism. |
35 |
|
|
|
36 |
|
|
php-pear-Log can optionally use package "php-pear-DB" (version >= 1.3) |
37 |
|
|
and "php-pear-MDB2" (version >= 2.0.0RC1). |
38 |
|
|
|
39 |
|
|
|
40 |
|
|
%description -l fr |
41 |
slords |
1.6 |
L'extension "log" fournit un système d'abstraction des enregistrements |
42 |
slords |
1.1 |
de traces. Il gère l'affichage sur la console, l'enregistrement dans un |
43 |
|
|
fichier, dans le "syslog", dans une base SQL ou Sqlite, l'envoi de mails |
44 |
slords |
1.6 |
ou la création d'évènements dans un calendrier "mcal". |
45 |
slords |
1.1 |
|
46 |
slords |
1.6 |
php-pear-Log peut optionnellement utiliser les extensions |
47 |
slords |
1.1 |
"php-pear-DB" (version >= 1.3) et "php-pear-MDB2" (version >= 2.0.0RC1). |
48 |
|
|
|
49 |
|
|
|
50 |
|
|
%prep |
51 |
|
|
%setup -c -q |
52 |
slords |
1.6 |
%{_bindir}/php -n %{SOURCE2} package.xml | tee CHANGELOG | head -n 10 |
53 |
|
|
|
54 |
|
|
cd %{pear_name}-%{version} |
55 |
|
|
# package.xml is V2 |
56 |
|
|
mv ../package.xml %{name}.xml |
57 |
|
|
|
58 |
|
|
%patch0 -p1 -b .orig |
59 |
|
|
|
60 |
slords |
1.1 |
|
61 |
|
|
%build |
62 |
|
|
# Empty build section |
63 |
|
|
|
64 |
|
|
|
65 |
|
|
%install |
66 |
slords |
1.6 |
rm -rf %{buildroot} |
67 |
slords |
1.1 |
|
68 |
|
|
pushd Log-%{version} |
69 |
slords |
1.3 |
%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml |
70 |
slords |
1.1 |
|
71 |
|
|
# Clean up unnecessary files |
72 |
|
|
rm -rf %{buildroot}%{pear_phpdir}/.??* |
73 |
|
|
|
74 |
|
|
# Install XML package description |
75 |
slords |
1.6 |
install -D -p -m 644 %{name}.xml %{buildroot}%{pear_xmldir}/%{name}.xml |
76 |
slords |
1.1 |
|
77 |
|
|
popd |
78 |
|
|
|
79 |
|
|
|
80 |
|
|
%clean |
81 |
|
|
rm -rf %{buildroot} |
82 |
|
|
|
83 |
|
|
|
84 |
|
|
%check |
85 |
slords |
1.6 |
# under EL-5 run-test -i option doesn't work |
86 |
|
|
# so build a temporay ini to set include_path |
87 |
|
|
( |
88 |
|
|
cat /etc/php.ini |
89 |
|
|
echo include_path=.:%{buildroot}%{pear_phpdir}:%{pear_phpdir} |
90 |
|
|
) >php.ini |
91 |
|
|
|
92 |
|
|
cd %{pear_name}-%{version} |
93 |
|
|
PHPRC=../php.ini %{__pear} \ |
94 |
|
|
run-tests \ |
95 |
|
|
tests | tee ../tests.log |
96 |
|
|
grep "FAILED TESTS" ../tests.log && exit 1 |
97 |
slords |
1.1 |
|
98 |
|
|
|
99 |
|
|
%post |
100 |
slords |
1.3 |
%{__pear} install --nodeps --soft --force --register-only %{pear_xmldir}/%{name}.xml >/dev/null || : |
101 |
slords |
1.1 |
|
102 |
|
|
|
103 |
|
|
%postun |
104 |
|
|
if [ "$1" -eq "0" ]; then |
105 |
|
|
%{__pear} uninstall --nodeps --ignore-errors --register-only %{pear_name} >/dev/null || : |
106 |
|
|
fi |
107 |
|
|
|
108 |
|
|
|
109 |
|
|
%files |
110 |
|
|
%defattr(-,root,root,-) |
111 |
slords |
1.6 |
%doc CHANGELOG |
112 |
|
|
%doc %{pear_docdir}/%{pear_name} |
113 |
slords |
1.1 |
%{pear_phpdir}/Log |
114 |
|
|
%{pear_phpdir}/Log.php |
115 |
|
|
%{pear_testdir}/Log |
116 |
|
|
%{pear_datadir}/Log |
117 |
slords |
1.3 |
%{pear_xmldir}/%{name}.xml |
118 |
slords |
1.1 |
|
119 |
|
|
|
120 |
|
|
%changelog |
121 |
slords |
1.6 |
* Thu Sep 22 2011 Remi Collet <Fedora@FamilleCollet.com> 1.12.7-1 |
122 |
|
|
- Version 1.12.7 (stable) - API 1.0.0 (stable) |
123 |
|
|
- minor spec cleanups |
124 |
snetram |
1.4 |
|
125 |
slords |
1.3 |
* Sat Dec 26 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.6-1 |
126 |
|
|
- update to 1.11.6 |
127 |
|
|
|
128 |
|
|
* Sat Aug 08 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.5-1 |
129 |
|
|
- update to 1.11.5 |
130 |
|
|
- rename Log.xml to php-pear-Log.xml |
131 |
|
|
|
132 |
|
|
* Sat Nov 22 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.3-1 |
133 |
|
|
- update to 1.11.3 |
134 |
|
|
|
135 |
|
|
* Fri Sep 05 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.2-1 |
136 |
|
|
- update to 1.11.2 |
137 |
|
|
|
138 |
|
|
* Wed Aug 06 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.1-1 |
139 |
|
|
- update to 1.11.1 |
140 |
|
|
|
141 |
|
|
* Sat Jun 28 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.0-1 |
142 |
|
|
- update to 1.11.0 : switch from PHP to MIT license |
143 |
|
|
|
144 |
|
|
* Thu May 08 2008 Remi Collet <Fedora@FamilleCollet.com> 1.10.1-1 |
145 |
|
|
- update to 1.10.1 |
146 |
|
|
|
147 |
|
|
* Sat Jan 26 2008 Remi Collet <Fedora@FamilleCollet.com> 1.10.0-1 |
148 |
|
|
- update to 1.10.0 |
149 |
|
|
- add Requires php-pear(Mail) (new handler) |
150 |
|
|
- remove levels.patch (merged upstream) |
151 |
|
|
|
152 |
|
|
* Sat Jan 26 2008 Remi Collet <Fedora@FamilleCollet.com> 1.9.16-1 |
153 |
|
|
- update to 1.9.16 |
154 |
|
|
- add examples in documentation |
155 |
|
|
- add levels.patch http://pear.php.net/bugs/bug.php?id=12933 |
156 |
|
|
|
157 |
|
|
* Wed Jan 02 2008 Remi Collet <Fedora@FamilleCollet.com> 1.9.14-1 |
158 |
|
|
- update to 1.9.14 |
159 |
snetram |
1.2 |
|
160 |
slords |
1.1 |
* Thu Dec 13 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.13-1 |
161 |
|
|
- update to 1.9.13 |
162 |
|
|
- add documentation in %%check (post install only) |
163 |
|
|
|
164 |
|
|
* Wed Dec 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.12-1 |
165 |
|
|
- update to 1.9.12 |
166 |
|
|
|
167 |
|
|
* Fri Aug 24 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-2 |
168 |
|
|
- Fix License |
169 |
|
|
|
170 |
|
|
* Sat May 02 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-1 |
171 |
|
|
- update to 1.9.11 |
172 |
|
|
|
173 |
|
|
* Mon Feb 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.10-1 |
174 |
|
|
- update to 1.9.10 |
175 |
|
|
- All tests succeed with php-5.2.x : http://pear.php.net/bugs/bug.php?id=9023 |
176 |
|
|
|
177 |
|
|
* Sat Oct 28 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.9-1 |
178 |
|
|
- update to 1.9.9 |
179 |
|
|
|
180 |
|
|
* Sat Sep 16 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-6 |
181 |
|
|
- add CHANGELOG to %%doc |
182 |
|
|
|
183 |
|
|
* Fri Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5.fc5.1 |
184 |
|
|
- rebuild for FC5 |
185 |
|
|
|
186 |
|
|
* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5 |
187 |
|
|
- BR php-pear >= 1:1.4.9-1.2 |
188 |
|
|
|
189 |
|
|
* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-4 |
190 |
|
|
- last template.spec |
191 |
|
|
|
192 |
|
|
* Mon Sep 04 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-3 |
193 |
|
|
- new and simpler %%prep and %%install |
194 |
|
|
|
195 |
|
|
* Sat Sep 02 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-2 |
196 |
|
|
- failsafe scriplet |
197 |
|
|
|
198 |
|
|
* Tue Aug 01 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-1 |
199 |
|
|
- update to 1.9.8 |
200 |
|
|
|
201 |
|
|
* Tue Jul 11 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.7-1 |
202 |
|
|
- update to 1.9.7 |
203 |
|
|
- use new macros from /etc/rpm/macros.pear |
204 |
|
|
|
205 |
|
|
* Tue May 30 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.6-1 |
206 |
|
|
- install Licence in prep |
207 |
|
|
- update to 1.9.6 |
208 |
|
|
|
209 |
|
|
* Mon May 15 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-3 |
210 |
|
|
- Require pear >= 1.4.9 |
211 |
|
|
- Requires(hint): (only comment actually) + description |
212 |
|
|
- bundle the v3.01 PHP LICENSE file (as in php-pear) |
213 |
|
|
- use --packagingroot (instead of -R) |
214 |
|
|
- check from install to check (as in php-pear) |
215 |
|
|
|
216 |
|
|
* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-2 |
217 |
|
|
- cleanning (description-line-too-long) |
218 |
|
|
|
219 |
|
|
* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-1 |
220 |
|
|
- use %%{_datadir}/pear/.pkgxml for XML (Bug #190252) |
221 |
|
|
- update to 1.9.5 |
222 |
|
|
- workaround for buggy pear 1.4.6 installer |
223 |
|
|
|
224 |
|
|
* Thu Apr 27 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.4-1 |
225 |
|
|
- spec for extras |
226 |
|
|
- add french summary & description |
227 |
|
|
|
228 |
|
|
* Wed Apr 26 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.4-1.fc{3,4,5}.remi |
229 |
|
|
- update to 1.9.4 |
230 |
|
|
|
231 |
|
|
* Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.3-1.fc{3,4,5}.remi |
232 |
|
|
- initial RPM |