1 |
BuildArch: noarch |
2 |
|
3 |
Summary: Distributed build system for RPMs |
4 |
Name: plague |
5 |
Version: 0.4.5.8 |
6 |
Release: 2%{?dist} |
7 |
License: GPLv2+ |
8 |
Group: Development/Tools |
9 |
#Source: http://fedoraproject.org/projects/plague/releases/%{name}-%{version}.tar.bz2 |
10 |
Source: %{name}-%{version}.tar.bz2 |
11 |
Patch0: plague-0.4.5.8-pushscript-extras.patch |
12 |
Patch1: plague-0.4.5.8-keepjobs.patch |
13 |
Patch2: plague-0.4.5.8-scm-updates.patch |
14 |
URL: http://www.fedoraproject.org/wiki/Projects/Plague |
15 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
16 |
BuildRequires: python |
17 |
Requires: createrepo >= 0.4.7 |
18 |
# get the version of the sqlite api thats available to us |
19 |
%if 0%{?rhel} |
20 |
Requires: python-sqlite |
21 |
%else |
22 |
Requires: python-sqlite2 |
23 |
%endif |
24 |
|
25 |
Requires: %{name}-common = %{version}-%{release} |
26 |
Requires(post): /sbin/chkconfig |
27 |
Requires(post): /sbin/service |
28 |
Requires(preun): /sbin/chkconfig |
29 |
Requires(preun): /sbin/service |
30 |
|
31 |
|
32 |
%description |
33 |
The Plague build system is a client/server distributed build system for |
34 |
building RPM packages. This package provides the plague server. |
35 |
|
36 |
|
37 |
%package common |
38 |
Summary: Common resources for the Plague build system |
39 |
Group: Development/Tools |
40 |
Requires: pyOpenSSL |
41 |
|
42 |
%description common |
43 |
This package includes the common Python module that all Plague services |
44 |
require. |
45 |
|
46 |
|
47 |
%package builder |
48 |
Summary: Builder daemon for Plague builder slaves |
49 |
Group: Development/Tools |
50 |
Requires: %{name}-common = %{version}-%{release} |
51 |
Requires: yum >= 2.2.1 |
52 |
Requires: mock >= 0.8 |
53 |
Requires(post): /sbin/chkconfig |
54 |
Requires(post): /sbin/service |
55 |
Requires(preun): /sbin/chkconfig |
56 |
Requires(preun): /sbin/service |
57 |
Requires(pre): /usr/sbin/useradd |
58 |
|
59 |
%description builder |
60 |
The Plague builder does the actual RPM package building on slave machines. |
61 |
|
62 |
%package client |
63 |
Summary: Package queueing client for the Plague build system |
64 |
Group: Development/Tools |
65 |
Requires: %{name}-common = %{version}-%{release} |
66 |
|
67 |
%description client |
68 |
Client program for enqueueing package builds and interrogating the build |
69 |
system. |
70 |
|
71 |
|
72 |
%package utils |
73 |
Summary: Utility programs for the Plague build system |
74 |
Group: Development/Tools |
75 |
Requires: %{name}-common = %{version}-%{release} |
76 |
Requires: %{name} = %{version}-%{release} |
77 |
|
78 |
%description utils |
79 |
This package includes user utilities for the Plague build system, including |
80 |
the interface to the build server. |
81 |
|
82 |
|
83 |
%prep |
84 |
%setup -q |
85 |
%patch0 -p1 |
86 |
%patch1 -p1 |
87 |
%patch2 -p1 |
88 |
|
89 |
|
90 |
%build |
91 |
make |
92 |
|
93 |
|
94 |
%install |
95 |
rm -rf $RPM_BUILD_ROOT |
96 |
make DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p" install |
97 |
chmod +x $RPM_BUILD_ROOT%{_bindir}/* |
98 |
install -p -D -m 0644 etc/plague-builder.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-builder |
99 |
install -p -D -m 0755 etc/plague-builder.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-builder |
100 |
install -p -D -m 0644 etc/plague-server.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-server |
101 |
install -p -D -m 0755 etc/plague-server.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-server |
102 |
mkdir -p $RPM_BUILD_ROOT/var/lib/plague/builder |
103 |
|
104 |
|
105 |
%clean |
106 |
rm -rf $RPM_BUILD_ROOT |
107 |
|
108 |
|
109 |
%post |
110 |
/sbin/chkconfig --add plague-server |
111 |
/sbin/service plague-server condrestart >> /dev/null || : |
112 |
|
113 |
%preun |
114 |
if [ $1 = 0 ]; then |
115 |
/sbin/service plague-server stop &> /dev/null |
116 |
/sbin/chkconfig --del plague-server |
117 |
fi |
118 |
|
119 |
%pre builder |
120 |
/usr/sbin/useradd -G mock -s /sbin/nologin -M -r -d /var/lib/plague/builder plague-builder 2>/dev/null || : |
121 |
|
122 |
%post builder |
123 |
/sbin/chkconfig --add plague-builder |
124 |
/sbin/service plague-builder condrestart >> /dev/null || : |
125 |
|
126 |
%preun builder |
127 |
if [ $1 = 0 ]; then |
128 |
/sbin/service plague-builder stop &> /dev/null |
129 |
/sbin/chkconfig --del plague-builder |
130 |
fi |
131 |
|
132 |
%files |
133 |
%defattr(-, root, root) |
134 |
%{_bindir}/%{name}-server |
135 |
%dir %{_datadir}/%{name}/server |
136 |
%{_datadir}/%{name}/server/*.py* |
137 |
%dir %{_sysconfdir}/%{name}/server |
138 |
%dir %{_sysconfdir}/%{name}/server/certs |
139 |
%config(noreplace) %{_sysconfdir}/sysconfig/%{name}-server |
140 |
%{_initrddir}/%{name}-server |
141 |
%doc www |
142 |
|
143 |
%files common |
144 |
%defattr(-, root, root) |
145 |
%doc README ChangeLog |
146 |
%dir %{_sysconfdir}/%{name} |
147 |
%dir %{_datadir}/%{name} |
148 |
%dir /usr/lib/python?.?/site-packages/%{name} |
149 |
/usr/lib/python?.?/site-packages/%{name}/*.py* |
150 |
|
151 |
%files builder |
152 |
%defattr(-, root, root) |
153 |
%{_bindir}/%{name}-builder |
154 |
%dir %{_datadir}/%{name}/builder |
155 |
%{_datadir}/%{name}/builder/*.py* |
156 |
%dir %{_sysconfdir}/%{name}/builder |
157 |
%dir %{_sysconfdir}/%{name}/builder/certs |
158 |
%config(noreplace) %{_sysconfdir}/sysconfig/%{name}-builder |
159 |
%{_initrddir}/%{name}-builder |
160 |
%dir /var/lib/plague |
161 |
%attr(0755, plague-builder, plague-builder) /var/lib/plague/builder |
162 |
|
163 |
%files client |
164 |
%defattr(-, root, root) |
165 |
%{_bindir}/%{name}-client |
166 |
|
167 |
%files utils |
168 |
%defattr(-, root, root) |
169 |
%{_bindir}/%{name}-user-manager |
170 |
%{_bindir}/%{name}-certhelper |
171 |
|
172 |
|
173 |
%changelog |
174 |
* Sat Apr 9 2011 Shad L. Lords <slords@mail.com> - 0.4.5.8-2 |
175 |
- Apply patches to detect pushed packages, keep packages around, add git as a checkout method |
176 |
|
177 |
* Sat Apr 9 2011 Shad L. Lords <slords@mail.com> - 0.4.5.8-1 |
178 |
- Update to 0.4.5.8 |
179 |
|
180 |
* Wed May 5 2010 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.7-7.20100505cvs |
181 |
- patch with fix from cvs (file download with Mock createrepo_on_rpms). |
182 |
|
183 |
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.5.7-6.20090612cvs |
184 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
185 |
|
186 |
* Fri Jul 17 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.7-5.20090612cvs |
187 |
- patch with fix from cvs (SSLConnection.py shutdown) |
188 |
|
189 |
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.5.7-4.20081216cvs |
190 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
191 |
|
192 |
* Tue Dec 16 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.7-3.20081216cvs |
193 |
- patch with fixes from cvs, also to make work with Python 2.6 |
194 |
|
195 |
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.4.5.7-2 |
196 |
- Rebuild for Python 2.6 |
197 |
|
198 |
* Wed Nov 5 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.7-1 |
199 |
- update to 0.4.5.7 (Python 2.4 fix and optional POSIX lockfile support) |
200 |
|
201 |
* Sun Sep 21 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.6-1 |
202 |
- update to 0.4.5.6 |
203 |
|
204 |
* Sat Sep 20 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.5-2 |
205 |
- add fix for sqlite's limited ALTER TABLE |
206 |
|
207 |
* Mon Sep 8 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.5-1 |
208 |
- update to 0.4.5.5 |
209 |
|
210 |
* Sun Sep 07 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.4-1 |
211 |
- update to 0.4.5.4 to make it work with MySQL 5 |
212 |
|
213 |
* Sun Sep 7 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.3-2 |
214 |
- fix mod_user in plague-user-manager for sqlite2/3 |
215 |
|
216 |
* Fri Sep 5 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.3-1 |
217 |
- update to 0.4.5.3 for sqlite2 compatibility fixes for Fedora |
218 |
- merge fedora pkg spec changes |
219 |
- include the www tree as server pkg docs |
220 |
|
221 |
* Thu Sep 04 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.2-1 |
222 |
- fix bug in find option to plague-user-manager |
223 |
|
224 |
* Wed Sep 03 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.1-1 |
225 |
- update to 0.4.5.1 applying Michael schwendt's logging and mock patches |
226 |
- using pysqlite2 on fedora and python-sqlite on RHEL |
227 |
- requires mock > 0.8 |
228 |
- requires createrepo >= 0.4.7 |
229 |
|
230 |
* Wed Sep 3 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5-2 |
231 |
- add the patches from 0.4.5-0.4 (sqlite3, mock08, logtail) |
232 |
- merge more spec changes |
233 |
|
234 |
* Tue Sep 02 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5-1 |
235 |
- update to 0.4.5 lots of fixes |
236 |
|
237 |
* Thu May 22 2008 Seth Vidal <skvidal at fedoraproject.org> - 0.4.4.1-6 |
238 |
- licensing tag fix |
239 |
|
240 |
* Tue Sep 18 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.4.1-5 |
241 |
- Add dirs /etc/plague and /usr/share/plague to plague-common |
242 |
since "plague-builder" and "plague" use them (#233904). |
243 |
|
244 |
* Fri Dec 15 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.4.1-4 |
245 |
- Small fix for a change in python 2.5's xmlrpc library. The patch has been |
246 |
upstreamed. |
247 |
|
248 |
* Thu Dec 14 2006 Jason L Tibbitts III <tibbs@math.uh.edu> - 0.4.4.1-3 |
249 |
- Rebuild for new Python |
250 |
|
251 |
* Thu Sep 14 2006 Dennis Gilmore <dennis@ausil.us> 0.4.4.0-2 |
252 |
- add patch for bad umask setting |
253 |
|
254 |
* Mon Mar 13 2006 Dan Williams <dcbw@redhat.com> 0.4.4.1-1 |
255 |
- Update to 0.4.4.1 |
256 |
- Fix createrepo dep to >= 0.4.3 (#rh170531) |
257 |
|
258 |
* Sun Mar 12 2006 Dan Williams <dcbw@redhat.com> 0.4.4-1 |
259 |
- Update to 0.4.4 release |
260 |
- Don't use pyOpenSSL's sendall() call, but simulate it to achieve |
261 |
timeouts, better error handling, and more efficient CPU usage |
262 |
- Fix up initscripts and lifecycle management |
263 |
- Implement a TERM handler in server & builder for clean shutdown |
264 |
- Ensure jobs don't hang around on builders if they get left there for |
265 |
some reason (ie, server didn't unlock repo for the job) |
266 |
- Make Additional Package Arches really work (kmod support) |
267 |
- Own /usr/lib/python?.?/site-packages/plague (#rh172794#) |
268 |
- Require createrepo >= 4.3 (#rh170531#) |
269 |
|
270 |
* Tue Jan 24 2006 Dan Williams <dcbw@redhat.com> 0.4.3-6 |
271 |
- Increase build server builder thread sleep time to work around SSL issues |
272 |
- Spawn mock in a new process group, and when killing jobs kill the entire |
273 |
process group. Hopefully fix orphaned rpmbuild processes on job kill |
274 |
|
275 |
* Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-5 |
276 |
- Restore builder connection timeout |
277 |
|
278 |
* Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-4 |
279 |
- Revert SSL fixes from last build |
280 |
|
281 |
* Sun Jan 22 2006 Dan Williams <dcbw@redhat.com> 0.4.3-3 |
282 |
- Don't traceback when killing jobs on builders |
283 |
- Work around SSL hanging issues |
284 |
|
285 |
* Tue Nov 29 2005 Dan Williams <dcbw@redhat.com> 0.4.3-2 |
286 |
- Move README and ChangeLog to -common package |
287 |
- Traceback/debug functionality added in server, depends on |
288 |
threadframe module from elsewhere. Disabled by default. |
289 |
|
290 |
* Thu Nov 24 2005 Dan Williams <dcbw@redhat.com> 0.4.3-1 |
291 |
- Add socket timeouts for fileserver and xmlrpc bits |
292 |
|
293 |
* Fri Nov 18 2005 Dan Williams <dcbw@redhat.com> 0.4.2-7 |
294 |
- Suspend builders on hard errors such as running out of disk space |
295 |
- Retry downloads from server/builder 5 times, not 3 |
296 |
- Log retried downloads on the server |
297 |
- Add socket timeouts to downloads to work around hanging issues |
298 |
when downloading from the builder (the downloading/done issue) |
299 |
|
300 |
* Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> 0.4.2-5 |
301 |
- Log kill requests on the server |
302 |
|
303 |
* Mon Nov 14 2005 Dan Williams <dcbw@redhat.com> 0.4.2-4 |
304 |
- In the builder, close files we open before exec-ing the |
305 |
child process. Fixes massive file descriptor leaks. |
306 |
|
307 |
* Sun Nov 13 2005 Dan Williams <dcbw@redhat.com> 0.4.2-3 |
308 |
- Hopefully fix builds not moving past downloading/done |
309 |
- Immediately kill jobs in the 'waiting' state when requested |
310 |
- Utilize pthread_sigmask python module, if present, on Python |
311 |
2.3 and earlier to work around signal blocking issues in |
312 |
Python |
313 |
|
314 |
* Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-2 |
315 |
- Make builders retry downloads from the server up to 3 times |
316 |
|
317 |
* Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-1 |
318 |
- Fix job download from the builders |
319 |
- Fix RPM copy to the repository on the server |
320 |
|
321 |
* Mon Oct 31 2005 Dan Williams <dcbw@redhat.com> 0.4.1-1 |
322 |
- Fail jobs on restart if we can't access the original SRPM |
323 |
- For the server, honor config file location passed in on |
324 |
the command line (Jeff Sheltren) |
325 |
- Catch another mock failure case (Alexandr Kanevskiy) |
326 |
|
327 |
* Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-6 |
328 |
- Retry downloads from builders up to 3 times before failing |
329 |
the job |
330 |
|
331 |
* Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-5 |
332 |
- Add a MySQL database backend (Jeff Sheltren) |
333 |
- Trap repo copy errors rather than doing a traceback |
334 |
- On the builder, deal correctly with jobs in 'downloaded' state |
335 |
that have been killed |
336 |
|
337 |
* Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-4 |
338 |
- Really fix client's "allow_uploads" problem |
339 |
|
340 |
* Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-3 |
341 |
- Fix errors in client's 'job detail' function |
342 |
- Ignore missing "allow_uploads" option in client config file |
343 |
- Fix server when the Additional Package Arches section is missing |
344 |
from a target config file |
345 |
- Make server more robust against random builder SSL issues |
346 |
|
347 |
* Mon Oct 17 2005 Dan Williams <dcbw@redhat.com> 0.4-2 |
348 |
- Increase field size of 'username' and 'status' fields when |
349 |
we initially create them on the server. Server ops will |
350 |
need to increase manually or blow away their jobdb. |
351 |
|
352 |
* Sun Oct 16 2005 Dan Williams <dcbw@redhat.com> 0.4-1 |
353 |
- Version 0.4 |
354 |
o Server: |
355 |
- Per-target config files, new format |
356 |
- Support PostgreSQL as a database backend |
357 |
|
358 |
o Builder: |
359 |
- Multiple concurrent builds with one builder process |
360 |
- Better tracking of mock child processes |
361 |
- Autodetect supported architectures and number of |
362 |
concurrent build processes |
363 |
- Per-target config files, new format |
364 |
|
365 |
o Client: |
366 |
- Ability to upload packages to server |
367 |
|
368 |
o Utilities: |
369 |
- New distro-rebuild.py utility |
370 |
- Fixes for certhelper.py |
371 |
|
372 |
* Tue Aug 23 2005 Dan Williams <dcbw@redhat.com> 0.3.4-1 |
373 |
- Version 0.3.4 |
374 |
o Make repo scripts actually work |
375 |
o Don't traceback when cleaning up job files if we have none |
376 |
|
377 |
* Mon Aug 19 2005 Dan Williams <dcbw@redhat.com> 0.3.3-1 |
378 |
- Version 0.3.3 |
379 |
o Add repo script support |
380 |
o Fix double-slashes in log URL (Ignacio Vazquez-Abrams) |
381 |
o Clear out old job info when requeueing jobs |
382 |
|
383 |
* Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-3 |
384 |
- Clear out old job info when requeueing jobs |
385 |
|
386 |
* Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-2 |
387 |
- Append %{?dist} to Releases to get correct precedence on FC3, FC4, and Rawhide |
388 |
|
389 |
* Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-1 |
390 |
- Version 0.3.2 |
391 |
o Fix errors in enqueue and enqueue_srpm return values |
392 |
o Implement client/server API versioning |
393 |
|
394 |
* Thu Aug 11 2005 Dan Williams <dcbw@redhat.com> 0.3.1-1 |
395 |
- Version 0.3.1 |
396 |
o Clean up web interface error handling, catches more errors |
397 |
o Clean up builder code, hopefully deal with block mock processes waiting |
398 |
to write to stderr |
399 |
o Use HTTP GET rather than POST for web forms, more back/forward/reload |
400 |
friendly (Ville Skyttä) |
401 |
|
402 |
* Mon Aug 8 2005 Dan Williams <dcbw@redhat.com> 0.3-1 |
403 |
- Version 0.3 |
404 |
|
405 |
* Sat Jul 16 2005 Dan Williams <dcbw@redhat.com> |
406 |
- Bump version to 0.2 |
407 |
- Grab python files from /usr/lib, not %%{_libdir} until the |
408 |
multiarch issues get worked out |
409 |
|
410 |
* Sun Jun 26 2005 Dan Williams <dcbw@redhat.com> |
411 |
- first version/packaging |