/[smeserver]/rpms/plague/sme8/plague.spec
ViewVC logotype

Annotation of /rpms/plague/sme8/plague.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jun 12 20:30:25 2007 UTC (17 years ago) by slords
Branch: MAIN
CVS Tags: plague-0_5_0-0_1_cvs_el5_sme
Import on branch sme8 of package plague-0.5.0-0.1.cvs.el5.sme.src.rpm

1 slords 1.1 BuildArch: noarch
2    
3     Summary: Distributed build system for RPMs
4     Name: plague
5     Version: 0.5.0
6     Release: 0.1.%{?CVSDATE}cvs%{?dist}
7     License: GPL
8     Group: Development/Tools
9     Source: http://fedoraproject.org/projects/plague/releases/%{name}-%{version}.tar.bz2
10     URL: http://www.fedoraproject.org/wiki/Projects/Plague
11     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12     Requires: python-sqlite, createrepo
13     Requires: %{name}-common = %{version}-%{release}
14     Requires(post): /sbin/chkconfig
15     Requires(post): /sbin/service
16     Requires(preun): /sbin/chkconfig
17     Requires(preun): /sbin/service
18    
19     %description
20     The Plague build system is a client/server distributed build system for
21     building RPM packages. This package provides the plague server.
22    
23    
24     %package common
25     Summary: Common resources for the Plague build system
26     Group: Development/Tools
27     Requires: pyOpenSSL
28    
29     %description common
30     This package includes the common Python module that all Plague services require.
31    
32    
33     %package builder
34     Summary: Builder daemon for Plague builder slaves
35     Group: Development/Tools
36     Requires: %{name}-common = %{version}-%{release}
37     Requires: yum >= 2.2.1, mock >= 0.3
38     Requires(post): /sbin/chkconfig
39     Requires(post): /sbin/service
40     Requires(preun): /sbin/chkconfig
41     Requires(preun): /sbin/service
42     Requires(pre): /usr/sbin/useradd
43    
44     %description builder
45     The Plague builder does the actual RPM package building on slave machines.
46    
47     %package client
48     Summary: Package queueing client for the Plague build system
49     Group: Development/Tools
50     Requires: %{name}-common = %{version}-%{release}
51    
52     %description client
53     Client program for enqueueing package builds and interrogating the build system.
54    
55    
56     %package utils
57     Summary: Utility programs for the Plague build system
58     Group: Development/Tools
59     Requires: %{name}-common = %{version}-%{release}
60    
61     %description utils
62     This package includes user utilities for the Plague build system, including
63     the interface to the build server.
64    
65    
66     %prep
67     %setup -q
68    
69     %build
70     make
71    
72    
73     %install
74     rm -rf $RPM_BUILD_ROOT
75     make DESTDIR=$RPM_BUILD_ROOT install
76     install -D -m 0644 etc/plague-builder.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-builder
77     install -D -m 0755 etc/plague-builder.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-builder
78     install -D -m 0644 etc/plague-server.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-server
79     install -D -m 0755 etc/plague-server.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-server
80     mkdir -p $RPM_BUILD_ROOT/srv/plague_builder
81    
82    
83     %clean
84     rm -rf $RPM_BUILD_ROOT
85    
86    
87     %post
88     /sbin/chkconfig --add plague-server
89     /sbin/service plague-server condrestart >> /dev/null || :
90    
91     %preun
92     if [ $1 = 0 ]; then
93     /sbin/service plague-server stop &> /dev/null
94     /sbin/chkconfig --del plague-server
95     fi
96    
97     %pre builder
98     /usr/sbin/useradd -G mock -s /sbin/nologin -M -r -d /srv/plague_builder plague-builder 2>/dev/null || :
99    
100     %post builder
101     /sbin/chkconfig --add plague-builder
102     /sbin/service plague-builder condrestart >> /dev/null || :
103    
104     %preun builder
105     if [ $1 = 0 ]; then
106     /sbin/service plague-builder stop &> /dev/null
107     /sbin/chkconfig --del plague-builder
108     fi
109    
110     %files
111     %defattr(-, root, root)
112     %doc README ChangeLog
113     %{_bindir}/%{name}-server
114     %dir %{_datadir}/%{name}/server
115     %{_datadir}/%{name}/server/*.py*
116     %dir %{_sysconfdir}/%{name}/server
117     %dir %{_sysconfdir}/%{name}/server/certs
118     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}-server
119     %{_initrddir}/%{name}-server
120    
121     %files common
122     %defattr(-, root, root)
123     /usr/lib/python?.?/site-packages/plague/*.py*
124    
125     %files builder
126     %defattr(-, root, root)
127     %{_bindir}/%{name}-builder
128     %dir %{_datadir}/%{name}/builder
129     %{_datadir}/%{name}/builder/*.py*
130     %dir %{_sysconfdir}/%{name}/builder
131     %dir %{_sysconfdir}/%{name}/builder/certs
132     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}-builder
133     %{_initrddir}/%{name}-builder
134     %attr(0755, plague-builder, plague-builder) /srv/plague_builder
135    
136     %files client
137     %defattr(-, root, root)
138     %{_bindir}/%{name}-client
139    
140     %files utils
141     %defattr(-, root, root)
142     %{_bindir}/%{name}-user-manager.py*
143     %{_bindir}/%{name}-certhelper.py*
144    
145    
146     %changelog
147     * Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> 0.4.2-5
148     - Log kill requests on the server
149    
150     * Mon Nov 14 2005 Dan Williams <dcbw@redhat.com> 0.4.2-4
151     - In the builder, close files we open before exec-ing the
152     child process. Fixes massive file descriptor leaks.
153    
154     * Sun Nov 13 2005 Dan Williams <dcbw@redhat.com> 0.4.2-3
155     - Hopefully fix builds not moving past downloading/done
156     - Immediately kill jobs in the 'waiting' state when requested
157     - Utilize pthread_sigmask python module, if present, on Python
158     2.3 and earlier to work around signal blocking issues in
159     Python
160    
161     * Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-2
162     - Make builders retry downloads from the server up to 3 times
163    
164     * Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-1
165     - Fix job download from the builders
166     - Fix RPM copy to the repository on the server
167    
168     * Mon Oct 31 2005 Dan Williams <dcbw@redhat.com> 0.4.1-1
169     - Fail jobs on restart if we can't access the original SRPM
170     - For the server, honor config file location passed in on
171     the command line (Jeff Sheltren)
172     - Catch another mock failure case (Alexandr Kanevskiy)
173    
174     * Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-6
175     - Retry downloads from builders up to 3 times before failing
176     the job
177    
178     * Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-5
179     - Add a MySQL database backend (Jeff Sheltren)
180     - Trap repo copy errors rather than doing a traceback
181     - On the builder, deal correctly with jobs in 'downloaded' state
182     that have been killed
183    
184     * Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-4
185     - Really fix client's "allow_uploads" problem
186    
187     * Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-3
188     - Fix errors in client's 'job detail' function
189     - Ignore missing "allow_uploads" option in client config file
190     - Fix server when the Additional Package Arches section is missing
191     from a target config file
192     - Make server more robust against random builder SSL issues
193    
194     * Mon Oct 17 2005 Dan Williams <dcbw@redhat.com> 0.4-2
195     - Increase field size of 'username' and 'status' fields when
196     we initially create them on the server. Server ops will
197     need to increase manually or blow away their jobdb.
198    
199     * Sun Oct 16 2005 Dan Williams <dcbw@redhat.com> 0.4-1
200     - Version 0.4
201     o Server:
202     - Per-target config files, new format
203     - Support PostgreSQL as a database backend
204    
205     o Builder:
206     - Multiple concurrent builds with one builder process
207     - Better tracking of mock child processes
208     - Autodetect supported architectures and number of
209     concurrent build processes
210     - Per-target config files, new format
211    
212     o Client:
213     - Ability to upload packages to server
214    
215     o Utilities:
216     - New distro-rebuild.py utility
217     - Fixes for certhelper.py
218    
219     * Tue Aug 23 2005 Dan Williams <dcbw@redhat.com> 0.3.4-1
220     - Version 0.3.4
221     o Make repo scripts actually work
222     o Don't traceback when cleaning up job files if we have none
223    
224     * Mon Aug 19 2005 Dan Williams <dcbw@redhat.com> 0.3.3-1
225     - Version 0.3.3
226     o Add repo script support
227     o Fix double-slashes in log URL (Ignacio Vazquez-Abrams)
228     o Clear out old job info when requeueing jobs
229    
230     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-3
231     - Clear out old job info when requeueing jobs
232    
233     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-2
234     - Append %{?dist} to Releases to get correct precedence on FC3, FC4, and Rawhide
235    
236     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-1
237     - Version 0.3.2
238     o Fix errors in enqueue and enqueue_srpm return values
239     o Implement client/server API versioning
240    
241     * Thu Aug 11 2005 Dan Williams <dcbw@redhat.com> 0.3.1-1
242     - Version 0.3.1
243     o Clean up web interface error handling, catches more errors
244     o Clean up builder code, hopefully deal with block mock processes waiting
245     to write to stderr
246     o Use HTTP GET rather than POST for web forms, more back/forward/reload
247     friendly (Ville Skyttä)
248    
249     * Mon Aug 8 2005 Dan Williams <dcbw@redhat.com> 0.3-1
250     - Version 0.3
251    
252     * Sat Jul 16 2005 Dan Williams <dcbw@redhat.com>
253     - Bump version to 0.2
254     - Grab python files from /usr/lib, not %{_libdir} until the
255     multiarch issues get worked out
256    
257     * Sun Jun 26 2005 Dan Williams <dcbw@redhat.com>
258     - first version/packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed