/[smeserver]/rpms/ppp/sme7/ppp.spec
ViewVC logotype

Annotation of /rpms/ppp/sme7/ppp.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jun 12 17:08:31 2007 UTC (17 years ago) by slords
Branch: MAIN
CVS Tags: ppp-2_4_4-1_3_el4_sme
Import on branch sme7 of package ppp-2.4.4-1.3.el4.sme.src.rpm

1 slords 1.1 # Detect the distribution we're using
2     %define __distinit %(%{__sed} -e 's/ release .*//' -e 's/\\([A-Za-z]\\)[^ ]*/\\1/g' /etc/redhat-release | /usr/bin/tr -d '[:space:]' | /usr/bin/cut -c 1-4 | /usr/bin/tr '[:upper:]' '[:lower:]')
3     %define __distsubvers %(%{__sed} -e 's/.* release [^.]*[.]*\\([^ ]*\\) .*/\\1/' /etc/redhat-release)
4     # For development releases (x.y, y > 80), bump version to next one for dist tag
5     %if %([ 0%{__distsubvers} -gt 80 ] && echo 1 || echo 0)
6     %define __distvers %(/usr/bin/expr $(%{__sed} -e 's/.* release \\([^.]*\\)[^ ]* [(].*[)].*/\\1/' /etc/redhat-release) + 1)
7     %else
8     %define __distvers %(%{__sed} -e 's/.* release \\([^.]*\\)[^ ]* [(].*[)].*/\\1/' /etc/redhat-release)
9     %endif
10     # Identify CentOS & White Box as rhel
11     %if "%{__distinit}" == "c" || "%{__distinit}" == "wbel"
12     %define __distinit rhel
13     %endif
14     %{!?__id_u: %define __id_u %([ -x /bin/id ]&&echo /bin/id||([ -x /usr/bin/id ]&&echo /usr/bin/id||echo /bin/true)) -u}
15     %{!?disttag: %define disttag .%{__distinit}%{__distvers}}
16    
17     # Which libpcap package do we need to build against?
18     # --------------------------------------------------
19     %if 0%{!?libpcapreq:1}
20     # Red Hat Linux, Red Hat Enterprise Linux
21     %if "%{__distinit}" == "rhl" || "%{__distinit}" == "rhel"
22     %define libpcapreq libpcap
23     %endif
24     # Fedora Core 1-5
25     %if "%{__distinit}" == "fc" && %{__distvers} < 6
26     %define libpcapreq libpcap
27     %endif
28     # Fedora Core 6 onwards
29     %if "%{__distinit}" == "fc" && %{__distvers} >= 6
30     %define libpcapreq libpcap-devel
31     %endif
32     %endif
33    
34     Summary: The PPP (Point-to-Point Protocol) daemon
35     Name: ppp
36     Version: 2.4.4
37     Release: 1.3%{?dist}
38     License: Distributable
39     Group: System Environment/Daemons
40     Url: http://ppp.samba.org/ppp/index.html
41     Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
42     Source1: ppp-2.3.5-pamd.conf
43     Source2: ppp.logrotate
44     Patch0: ppp-2.4.3-make.patch
45     Patch1: ppp-2.3.6-sample.patch
46     Patch2: ppp-2.4.2-libutil.patch
47     Patch3: ppp-2.4.1-varargs.patch
48     Patch4: ppp-2.4.4-lib64.patch
49     Patch7: ppp-2.4.2-pie.patch
50     Patch8: ppp-2.4.3-fix.patch
51     Patch9: ppp-2.4.3-fix64.patch
52     Patch11: ppp-2.4.2-change_resolv_conf.patch
53     Patch13: ppp-2.4.4-no_strip.patch
54     Patch16: ppp-2.4.2-pppoatm-mtu.patch
55     Patch17: ppp-2.4.2-pppoatm-make.patch
56     Patch19: ppp-2.4.3-local.patch
57     Patch20: ppp-2.4.3-ipv6-accept-remote.patch
58     Patch21: ppp-2.4.3-usepeerdns-var_run_ppp_resolv.conf.patch
59     Patch22: ppp-2.4.4-cbcp.patch
60    
61     # Non-RedHat patches:
62     Patch100: mppe_lower_mtu.diff
63     Patch101: ppp-2.4.2-ifname.diff
64     Patch102: ppp-2.4.3-atm_backend.patch
65     Patch103: ppp-2.4.4-debuginfo.patch
66     Patch104: ppp-2.4.3-oldpam.patch
67     Patch105: ppp-2.4.3-bpf.patch
68     Patch106: ppp-2.4.2-pcap.patch
69     Patch107: ppp-2.4.3-cbcp_debug.patch
70     Patch121: ppp-2.4.4-usepeerdns-var_run_ppp_resolv.conf.patch
71    
72     Patch200: ppp-2.4.4-prehashed_chapms.patch
73     Patch201: ppp-2.4.4-HashorBin.patch
74    
75     # Keep RedHat spec file in SRPM for comparison
76     Source100: ppp.spec.redhat
77    
78     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
79     BuildRequires: pam-devel, %{libpcapreq} >= 0.6.2
80     Requires: glibc >= 2.0.6, /etc/pam.d/system-auth, logrotate
81    
82     %description
83     The ppp package contains the PPP (Point-to-Point Protocol) daemon and
84     documentation for PPP support. The PPP protocol provides a method for
85     transmitting datagrams over serial point-to-point links. PPP is
86     usually used to dial in to an ISP (Internet Service Provider) or other
87     organization over a modem and phone line.
88    
89     %prep
90     %setup -q
91     %patch0 -p1 -b .make
92     %patch1 -p1 -b .sample
93     # patch 2 depends on the -lutil in patch 0
94     %patch2 -p1 -b .libutil
95     %patch3 -p1 -b .varargs
96     # patch 4 depends on the -lutil in patch 0
97     %patch4 -p1 -b .lib64
98     %patch7 -p1 -b .pie
99     %patch8 -p1 -b .fix
100     %patch9 -p1 -b .fix64
101    
102     # This patch for the ppp support scripts requires the change_resolv_conf
103     # function, defined in the /etc/sysconfig/network-scripts/network-functions file
104     if %{__grep} -F change_resolv_conf /etc/sysconfig/network-scripts/network-functions &> /dev/null; then
105     %patch11 -p1 -b .change_resolv_conf
106     %patch21 -p1 -b .usepeerdns-var_run_ppp_resolv
107     else
108     %patch121 -p1 -b .usepeerdns-var_run_ppp_resolv
109     fi
110    
111     %patch13 -p1 -b .no_strip
112     %patch16 -p1 -b .atm-mtu
113     %patch17 -p1 -b .atm-make
114     %patch19 -p1 -b .local
115     %patch20 -p1 -b .ipv6cp
116     %patch22 -p1 -b .cbcp
117    
118     # ============================================================================
119     # The remaining patches are additional to those in the official Fedora package
120     # ============================================================================
121    
122     # Support additional options mppe-lower-mtu (default) & nomppe-lower-mtu
123     %patch100 -p1 -b .mtu
124    
125     # Arvin Schnell's ifname patch
126     # http://marc.theaimsgroup.com/?l=linux-ppp&m=109025160924399&w=2
127     %patch101 -p0 -b .ifname
128    
129     # atm_backend_t definition missing from system headers in Fedora Core 2
130     if ! %{__grep} -F atm_backend_t %{_includedir}/linux/atm.h &> /dev/null; then
131     %patch102 -p1 -b .atm_backend
132     fi
133    
134     # pppd and pppoe-discovery installed without user write permission, prevents stripping
135     %patch103 -p1 -b .debuginfo
136    
137     # Default PAM configuration file uses "include" syntax introduced in Fedora Core 5
138     # This patch reverts to the older syntax for older distributions
139     %{__cp} -p %{SOURCE1} ppp.pam
140     if ! %{__grep} '^auth[[:space:]][[:space:]]*include' /etc/pam.d/config-util &> /dev/null; then
141     %patch104 -p0
142     fi
143    
144     # libpcap < 0.8 has headers in different places
145     if [ ! -f %{_includedir}/pcap-bpf.h ]; then
146     %patch105 -p1 -b .bpf
147     fi
148    
149     # Fix inbound/outbound filter processing using internal functions for old libpcap versions
150     if [ -f %{_includedir}/pcap-int.h ]; then
151     %patch106 -p1 -b .pcap
152     fi
153    
154     # Don't debug trace calls to cbcp_open unless the debug flag is set
155     %patch107 -p1 -b .cbcp_debug
156    
157     %patch201 -p1 -b .prehashed_chapms
158    
159     # Red Hat 7.x has SIOCSIFNAME defined in <linux/sockios.h> but not in <bits/ioctls.h>,
160     # which is included by <sys/ioctl.h> from pppd/sys-linux.c
161     # This symbol is needed for the interface name-changing patch, so here's a kludge...
162     if ! %{__grep} SIOCSIFNAME %{_includedir}/bits/ioctls.h &> /dev/null; then
163     [ -f %{_includedir}/linux/sockios.h ] &&
164     %{__grep} SIOCSIFNAME %{_includedir}/linux/sockios.h >> pppd/patchlevel.h
165     fi
166    
167     # Clean up cruft left after patching etc.
168     %{__rm} -f scripts/{ppp-on-[rs]sh,secure-card}.local \
169     scripts/*change_resolv_conf \
170     scripts/*usepeerdns-var_run_ppp_resolv \
171     sample/*.sample
172    
173     # Allow for build in directory with setgid permission bit set
174     %{__chmod} 755 sample scripts scripts/chatchat
175    
176     %build
177     RPM_OPT_FLAGS="%{optflags} -fPIC -Wall"
178     ./configure --libdir=%{_libdir}
179     %{__make}
180    
181     %install
182     %{__rm} -rf %{buildroot}
183     export INSTROOT=%{buildroot}
184     %{__make} install install-etcppp
185    
186     %{__chmod} -R a+rX scripts
187     /usr/bin/find scripts -type f | /usr/bin/xargs %{__chmod} a-x
188     %{__chmod} 0755 %{buildroot}%{_libdir}/pppd/%{version}/*.so
189     %{__mkdir} -p %{buildroot}/etc/pam.d
190     %{__install} -m 644 ppp.pam %{buildroot}/etc/pam.d/ppp
191    
192     # Places for state and log files
193     %{__mkdir} -p %{buildroot}/var/log/ppp
194     %{__mkdir} -p %{buildroot}/var/run/ppp
195    
196     # Logrotate script
197     %{__mkdir} -p %{buildroot}/etc/logrotate.d
198     %{__install} -m 644 %{SOURCE2} %{buildroot}/etc/logrotate.d/ppp
199    
200     %clean
201     %{__rm} -rf %{buildroot}
202    
203     %files
204     %defattr(-,root,root)
205     %{_sbindir}/chat
206     %{_sbindir}/pppd
207     %{_sbindir}/pppdump
208     %{_sbindir}/pppoe-discovery
209     %{_sbindir}/pppstats
210     %{_mandir}/man8/chat.8*
211     %{_mandir}/man8/pppd.8*
212     %{_mandir}/man8/pppdump.8*
213     %{_mandir}/man8/pppd-radattr.8*
214     %{_mandir}/man8/pppd-radius.8*
215     %{_mandir}/man8/pppstats.8*
216     %{_includedir}/pppd/
217     %{_libdir}/pppd/
218     %dir /etc/ppp/
219     %dir /var/run/ppp/
220     %attr(700, root, root) %dir /var/log/ppp/
221     %config /etc/ppp/chap-secrets
222     %config /etc/ppp/options
223     %config /etc/ppp/pap-secrets
224     %config /etc/pam.d/ppp
225     %config /etc/logrotate.d/ppp
226     %doc FAQ PLUGINS README README.cbcp README.linux README.MPPE README.MSCHAP80
227     %doc README.MSCHAP81 README.pwfd README.pppoe scripts sample
228    
229     %changelog
230     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
231     - Clean up spec so package can be built by koji/plague
232    
233     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
234     - Update to new release naming. No functional changes.
235     - Make Packager generic
236    
237     * Thu Nov 23 2006 Charlie Brady <charlie_brady@mitel.com> 2.4.4-1.3
238     - Have another go at last patch.
239    
240     * Tue Nov 21 2006 Charlie Brady <charlie_brady@mitel.com> 2.4.4-1.2
241     - Add option for chapms secrets to be pre-hashed
242    
243     * Fri Sep 8 2006 Paul Howarth <paul@city-fan.org> 2.4.4-1.1
244     - add dist tag
245     - add URL
246     - define %%{__id_u} for builds on non-Red Hat-based distributions
247     - use Fedora standard buildroot
248     - vary libpcap buildreq based on distribution/release
249     - remove versioned libpcap dependency
250     - remove buildroot unconditionally in %%install
251     - got rid of a few cosmetic rpmlint warnings
252     - add patches:
253     * patch to support mppe_lower_mtu/nomppe_lower_mtu options
254     * Arvin Schnell's ifname patch
255     (http://marc.theaimsgroup.com/?l=linux-ppp&m=109025160924399&w=2)
256     * define atm_backend_t if the system headers don't (needed on FC2)
257     * extract debug symbols from pppd and pppoe-discovery
258     * use old-style PAM configs on older distributions
259     * look for libpcap headers in different places on older distributions
260     * fix inbound/outbound filter processing using internal functions for
261     old libpcap versions
262     * don't debug trace calls to cbcp_open unless the debug flag is set
263     * make sure SIOCSIFNAME is defined (needed for ifname patch on RHL7)
264     - clean patch cruft more carefully (don't delete ipv6 sample scripts)
265     - cosmetic spec file tidying
266    
267     * Wed Jul 19 2006 Thomas Woerner <twoerner@redhat.com> 2.4.4-1
268     - new version 2.4.4 with lots of fixes
269     - fixed resolv.conf docs (#165072)
270     Thanks to Matt Domsch for the initial patch
271     - enabled CBCP (#199278)
272    
273     * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.3-6.2.2
274     - rebuild
275    
276     * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.3-6.2.1
277     - bump again for double-long bug on ppc(64)
278    
279     * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.3-6.2
280     - rebuilt for new gcc4.1 snapshot and glibc changes
281    
282     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
283     - rebuilt
284    
285     * Sat Nov 12 2005 Florian La Roche <laroche@redhat.com>
286     - rebuild
287    
288     * Fri Nov 4 2005 David Woodhouse <dwmw2@redhat.com> 2.4.3-5
289     - Implement ipv6cp-accept-remote option
290    
291     * Fri Oct 7 2005 Tomas Mraz <tmraz@redhat.com> 2.4.3-4
292     - use include instead of pam_stack in pam config
293    
294     * Sun Jul 31 2005 Florian La Roche <laroche@redhat.com>
295     - rebuild for libpcap of the day
296    
297     * Tue Jul 19 2005 Thomas Woerner <twoerner@redhat.com> 2.4.3-2.1
298     - additional patch for the scripts, thanks to Sammy (#163621)
299    
300     * Tue Jul 19 2005 Thomas Woerner <twoerner@redhat.com> 2.4.3-2
301     - dropped all executable bits in scripts directory to prevent rpm requiring
302     programs used in there
303    
304     * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 2.4.3-1
305     - new version 2.4.3
306     - updated patches: make, lib64, dontwriteetc, fix, fix64, no_strip,
307     radiusplugin
308     - dropped patches: bpf, signal, pcap, pppoatm, pkgcheck
309    
310     * Tue Nov 2 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-7
311     - fixed out of bounds memory access, possible DOS
312    
313     * Thu Oct 7 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-6.3
314     - Fix use of 'demand' without explicit MTU/MRU with pppoatm
315    
316     * Tue Oct 5 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-6.2
317     - Link pppoatm plugin against libresolv.
318     - Revert to linux-atm headers without the workaround for #127098
319    
320     * Mon Oct 4 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-6.1
321     - Include atmsap.h for pppoatm plugin.
322    
323     * Mon Oct 4 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-6
324     - Add pppoatm plugin (#131555)
325    
326     * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-5.1
327     - fixed subscript out of range (#132677)
328    
329     * Wed Sep 15 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-5
330     - example scripts are using change_resolv_conf to modify /etc/resolv.conf
331     (#132482)
332     - require new libpcap library (>= 0.8.3-6) with a fix for inbound/outbound
333     filter processing
334     - not using internal libpcap structures anymore, fixes inbound/outbound
335     filter processing (#128053)
336    
337     * Fri Aug 6 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-4
338     - fixed signal handling (#29171)
339    
340     * Mon Jun 21 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-3.1
341     - fixed compiler warnings
342     - fixed 64bit problem with ms-chap (#125501)
343     - enabled pie again
344    
345     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
346     - rebuilt
347    
348     * Wed May 24 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-2.3
349     - Enable IPv6 support. Disable PIE to avoid bogus Provides:
350    
351     * Fri May 14 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-2.2
352     - compiled pppd and chat PIE
353    
354     * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-2.1
355     - added 'missingok' to ppp.logrotate (#122911)
356    
357     * Fri May 07 2004 Nils Philippsen <nphilipp@redhat.com> 2.4.2-2
358     - don't write to /etc (#118837)
359    
360     * Wed Mar 10 2004 Nalin Dahyabhai <nalin@redhat.com> 2.4.2-1
361     - update to 2.4.2
362    
363     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
364     - rebuilt
365    
366     * Fri Sep 5 2003 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-15
367     - rebuild
368    
369     * Fri Sep 5 2003 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-14
370     - apply the patch from -11
371    
372     * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
373     - rebuilt
374    
375     * Tue Jun 3 2003 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-12
376     - rebuild
377    
378     * Tue Jun 3 2003 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-11
379     - check for libcrypt in the right directory at compile-time
380    
381     * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
382     - rebuilt
383    
384     * Thu Dec 12 2002 Elliot Lee <sopwith@redhat.com> 2.4.1-9
385     - Fix build failure by rebuilding
386    
387     * Tue Nov 19 2002 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-8
388     - rebuild
389     - set x86_64 to use varargs the way s390 does
390    
391     * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
392     - add patch:
393     * Thu Jun 06 2002 Phil Knirsch <pknirsch@redhat.com>
394     - Fixed varargs problem for s390/s390x.
395    
396     * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
397     - automated rebuild
398    
399     * Sun May 26 2002 Tim Powers <timp@redhat.com>
400     - automated rebuild
401    
402     * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-4
403     - rebuild in new environment
404    
405     * Wed Feb 27 2002 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-3
406     - revert cbcp patch, it's wrong (#55367)
407    
408     * Thu Aug 9 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-2
409     - add buildprereq on pam-devel (#49559)
410     - add patch to respond to CBCP LCP requests (#15738)
411     - enable cbcp support at build-time
412     - change the Copyright: tag to a License: tag
413    
414     * Wed May 23 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-1
415     - update to 2.4.1
416    
417     * Fri Dec 1 2000 Nalin Dahyabhai <nalin@redhat.com>
418     - rebuild in new environment
419    
420     * Thu Nov 9 2000 Nalin Dahyabhai <nalin@redhat.com>
421     - update to 2.4.0
422    
423     * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
424     - automatic rebuild
425    
426     * Mon Jun 5 2000 Nalin Dahyabhai <nalin@redhat.com>
427     - move man pages to %%{_mandir}
428    
429     * Thu Jun 1 2000 Nalin Dahyabhai <nalin@redhat.com>
430     - change perms using defattr
431     - modify PAM setup to use system-auth
432    
433     * Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
434     - change to root:root perms
435    
436     * Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
437     - reaper bugs verified as fixed
438     - check pam_open_session result code (bug #9966)
439    
440     * Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
441     - take a shot at the wrong reaper bugs (#8153, #5290)
442    
443     * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
444     - free ride through the build system (release 2)
445    
446     * Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
447     - Update to 2.3.11
448    
449     * Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
450     - Better fix for both problems
451    
452     * Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
453     - fix for double-dial problem
454     - fix for requiring a controlling terminal problem
455    
456     * Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
457     - 2.3.10 bugfix release
458    
459     * Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
460     - New version 2.3.9 required for kernel 2.3.13 and will be required
461     for new initscripts. auth patch removed; 2.3.9 does the same thing
462     more readably than the previous patch.
463    
464     * Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
465     - add pppdump
466    
467     * Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
468     - force pppd use the glibc's logwtmp instead of implementing its own
469    
470     * Wed Apr 01 1999 Preston Brown <pbrown@redhat.com>
471     - version 2.3.7 bugfix release
472    
473     * Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
474     - version 2.3.6
475    
476     * Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
477     - auth patch
478    
479     * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
480     - auto rebuild in the new build environment (release 3)
481    
482     * Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
483     - build for glibc 2.1
484    
485     * Fri Jun 5 1998 Jeff Johnson <jbj@redhat.com>
486     - updated to 2.3.5.
487    
488     * Tue May 19 1998 Prospector System <bugs@redhat.com>
489     - translations modified for de
490    
491     * Fri May 8 1998 Jakub Jelinek <jj@ultra.linux.cz>
492     - make it run with kernels 2.1.100 and above.
493    
494     * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
495     - translations modified for de, fr, tr
496    
497     * Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
498     - requires glibc 2.0.6 or later
499    
500     * Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
501     - updated PAM patch to not turn off wtmp/utmp/syslog logging.
502    
503     * Wed Jan 7 1998 Cristian Gafton <gafton@redhat.com>
504     - added the /etc/pam.d config file
505     - updated PAM patch to include session support
506    
507     * Tue Jan 6 1998 Cristian Gafton <gafton@redhat.com>
508     - updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
509     required any more.
510     - added buildroot
511     - fixed the PAM support, which was really, completely broken and against any
512     standards (session support is still not here... :-( )
513     - we build against running kernel and pray that it will work
514     - added a samples patch; updated glibc patch
515    
516     * Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
517     - added a patch to use our own route.h, rather then glibc's (which has
518     alignment problems on Alpha's) -- I only applied this patch on the Alpha,
519     though it should be safe everywhere
520    
521     * Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
522     - turned off the execute bit for scripts in /usr/doc
523    
524     * Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
525     - built against glibc
526    
527     * Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
528     - Integrated new patch from David Mosberger
529     - Improved description
530    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed