/[smeserver]/rpms/ppp/sme7/ppp.spec
ViewVC logotype

Annotation of /rpms/ppp/sme7/ppp.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Wed Apr 9 13:51:54 2008 UTC (16 years, 1 month ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +2 -0 lines
Add Id to top of spec

1 slords 1.2 # $Id$
2    
3 slords 1.1 # Detect the distribution we're using
4     %define __distinit %(%{__sed} -e 's/ release .*//' -e 's/\\([A-Za-z]\\)[^ ]*/\\1/g' /etc/redhat-release | /usr/bin/tr -d '[:space:]' | /usr/bin/cut -c 1-4 | /usr/bin/tr '[:upper:]' '[:lower:]')
5     %define __distsubvers %(%{__sed} -e 's/.* release [^.]*[.]*\\([^ ]*\\) .*/\\1/' /etc/redhat-release)
6     # For development releases (x.y, y > 80), bump version to next one for dist tag
7     %if %([ 0%{__distsubvers} -gt 80 ] && echo 1 || echo 0)
8     %define __distvers %(/usr/bin/expr $(%{__sed} -e 's/.* release \\([^.]*\\)[^ ]* [(].*[)].*/\\1/' /etc/redhat-release) + 1)
9     %else
10     %define __distvers %(%{__sed} -e 's/.* release \\([^.]*\\)[^ ]* [(].*[)].*/\\1/' /etc/redhat-release)
11     %endif
12     # Identify CentOS & White Box as rhel
13     %if "%{__distinit}" == "c" || "%{__distinit}" == "wbel"
14     %define __distinit rhel
15     %endif
16     %{!?__id_u: %define __id_u %([ -x /bin/id ]&&echo /bin/id||([ -x /usr/bin/id ]&&echo /usr/bin/id||echo /bin/true)) -u}
17     %{!?disttag: %define disttag .%{__distinit}%{__distvers}}
18    
19     # Which libpcap package do we need to build against?
20     # --------------------------------------------------
21     %if 0%{!?libpcapreq:1}
22     # Red Hat Linux, Red Hat Enterprise Linux
23     %if "%{__distinit}" == "rhl" || "%{__distinit}" == "rhel"
24     %define libpcapreq libpcap
25     %endif
26     # Fedora Core 1-5
27     %if "%{__distinit}" == "fc" && %{__distvers} < 6
28     %define libpcapreq libpcap
29     %endif
30     # Fedora Core 6 onwards
31     %if "%{__distinit}" == "fc" && %{__distvers} >= 6
32     %define libpcapreq libpcap-devel
33     %endif
34     %endif
35    
36     Summary: The PPP (Point-to-Point Protocol) daemon
37     Name: ppp
38     Version: 2.4.4
39     Release: 1.3%{?dist}
40     License: Distributable
41     Group: System Environment/Daemons
42     Url: http://ppp.samba.org/ppp/index.html
43     Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
44     Source1: ppp-2.3.5-pamd.conf
45     Source2: ppp.logrotate
46     Patch0: ppp-2.4.3-make.patch
47     Patch1: ppp-2.3.6-sample.patch
48     Patch2: ppp-2.4.2-libutil.patch
49     Patch3: ppp-2.4.1-varargs.patch
50     Patch4: ppp-2.4.4-lib64.patch
51     Patch7: ppp-2.4.2-pie.patch
52     Patch8: ppp-2.4.3-fix.patch
53     Patch9: ppp-2.4.3-fix64.patch
54     Patch11: ppp-2.4.2-change_resolv_conf.patch
55     Patch13: ppp-2.4.4-no_strip.patch
56     Patch16: ppp-2.4.2-pppoatm-mtu.patch
57     Patch17: ppp-2.4.2-pppoatm-make.patch
58     Patch19: ppp-2.4.3-local.patch
59     Patch20: ppp-2.4.3-ipv6-accept-remote.patch
60     Patch21: ppp-2.4.3-usepeerdns-var_run_ppp_resolv.conf.patch
61     Patch22: ppp-2.4.4-cbcp.patch
62    
63     # Non-RedHat patches:
64     Patch100: mppe_lower_mtu.diff
65     Patch101: ppp-2.4.2-ifname.diff
66     Patch102: ppp-2.4.3-atm_backend.patch
67     Patch103: ppp-2.4.4-debuginfo.patch
68     Patch104: ppp-2.4.3-oldpam.patch
69     Patch105: ppp-2.4.3-bpf.patch
70     Patch106: ppp-2.4.2-pcap.patch
71     Patch107: ppp-2.4.3-cbcp_debug.patch
72     Patch121: ppp-2.4.4-usepeerdns-var_run_ppp_resolv.conf.patch
73    
74     Patch200: ppp-2.4.4-prehashed_chapms.patch
75     Patch201: ppp-2.4.4-HashorBin.patch
76    
77     # Keep RedHat spec file in SRPM for comparison
78     Source100: ppp.spec.redhat
79    
80     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
81     BuildRequires: pam-devel, %{libpcapreq} >= 0.6.2
82     Requires: glibc >= 2.0.6, /etc/pam.d/system-auth, logrotate
83    
84     %description
85     The ppp package contains the PPP (Point-to-Point Protocol) daemon and
86     documentation for PPP support. The PPP protocol provides a method for
87     transmitting datagrams over serial point-to-point links. PPP is
88     usually used to dial in to an ISP (Internet Service Provider) or other
89     organization over a modem and phone line.
90    
91     %prep
92     %setup -q
93     %patch0 -p1 -b .make
94     %patch1 -p1 -b .sample
95     # patch 2 depends on the -lutil in patch 0
96     %patch2 -p1 -b .libutil
97     %patch3 -p1 -b .varargs
98     # patch 4 depends on the -lutil in patch 0
99     %patch4 -p1 -b .lib64
100     %patch7 -p1 -b .pie
101     %patch8 -p1 -b .fix
102     %patch9 -p1 -b .fix64
103    
104     # This patch for the ppp support scripts requires the change_resolv_conf
105     # function, defined in the /etc/sysconfig/network-scripts/network-functions file
106     if %{__grep} -F change_resolv_conf /etc/sysconfig/network-scripts/network-functions &> /dev/null; then
107     %patch11 -p1 -b .change_resolv_conf
108     %patch21 -p1 -b .usepeerdns-var_run_ppp_resolv
109     else
110     %patch121 -p1 -b .usepeerdns-var_run_ppp_resolv
111     fi
112    
113     %patch13 -p1 -b .no_strip
114     %patch16 -p1 -b .atm-mtu
115     %patch17 -p1 -b .atm-make
116     %patch19 -p1 -b .local
117     %patch20 -p1 -b .ipv6cp
118     %patch22 -p1 -b .cbcp
119    
120     # ============================================================================
121     # The remaining patches are additional to those in the official Fedora package
122     # ============================================================================
123    
124     # Support additional options mppe-lower-mtu (default) & nomppe-lower-mtu
125     %patch100 -p1 -b .mtu
126    
127     # Arvin Schnell's ifname patch
128     # http://marc.theaimsgroup.com/?l=linux-ppp&m=109025160924399&w=2
129     %patch101 -p0 -b .ifname
130    
131     # atm_backend_t definition missing from system headers in Fedora Core 2
132     if ! %{__grep} -F atm_backend_t %{_includedir}/linux/atm.h &> /dev/null; then
133     %patch102 -p1 -b .atm_backend
134     fi
135    
136     # pppd and pppoe-discovery installed without user write permission, prevents stripping
137     %patch103 -p1 -b .debuginfo
138    
139     # Default PAM configuration file uses "include" syntax introduced in Fedora Core 5
140     # This patch reverts to the older syntax for older distributions
141     %{__cp} -p %{SOURCE1} ppp.pam
142     if ! %{__grep} '^auth[[:space:]][[:space:]]*include' /etc/pam.d/config-util &> /dev/null; then
143     %patch104 -p0
144     fi
145    
146     # libpcap < 0.8 has headers in different places
147     if [ ! -f %{_includedir}/pcap-bpf.h ]; then
148     %patch105 -p1 -b .bpf
149     fi
150    
151     # Fix inbound/outbound filter processing using internal functions for old libpcap versions
152     if [ -f %{_includedir}/pcap-int.h ]; then
153     %patch106 -p1 -b .pcap
154     fi
155    
156     # Don't debug trace calls to cbcp_open unless the debug flag is set
157     %patch107 -p1 -b .cbcp_debug
158    
159     %patch201 -p1 -b .prehashed_chapms
160    
161     # Red Hat 7.x has SIOCSIFNAME defined in <linux/sockios.h> but not in <bits/ioctls.h>,
162     # which is included by <sys/ioctl.h> from pppd/sys-linux.c
163     # This symbol is needed for the interface name-changing patch, so here's a kludge...
164     if ! %{__grep} SIOCSIFNAME %{_includedir}/bits/ioctls.h &> /dev/null; then
165     [ -f %{_includedir}/linux/sockios.h ] &&
166     %{__grep} SIOCSIFNAME %{_includedir}/linux/sockios.h >> pppd/patchlevel.h
167     fi
168    
169     # Clean up cruft left after patching etc.
170     %{__rm} -f scripts/{ppp-on-[rs]sh,secure-card}.local \
171     scripts/*change_resolv_conf \
172     scripts/*usepeerdns-var_run_ppp_resolv \
173     sample/*.sample
174    
175     # Allow for build in directory with setgid permission bit set
176     %{__chmod} 755 sample scripts scripts/chatchat
177    
178     %build
179     RPM_OPT_FLAGS="%{optflags} -fPIC -Wall"
180     ./configure --libdir=%{_libdir}
181     %{__make}
182    
183     %install
184     %{__rm} -rf %{buildroot}
185     export INSTROOT=%{buildroot}
186     %{__make} install install-etcppp
187    
188     %{__chmod} -R a+rX scripts
189     /usr/bin/find scripts -type f | /usr/bin/xargs %{__chmod} a-x
190     %{__chmod} 0755 %{buildroot}%{_libdir}/pppd/%{version}/*.so
191     %{__mkdir} -p %{buildroot}/etc/pam.d
192     %{__install} -m 644 ppp.pam %{buildroot}/etc/pam.d/ppp
193    
194     # Places for state and log files
195     %{__mkdir} -p %{buildroot}/var/log/ppp
196     %{__mkdir} -p %{buildroot}/var/run/ppp
197    
198     # Logrotate script
199     %{__mkdir} -p %{buildroot}/etc/logrotate.d
200     %{__install} -m 644 %{SOURCE2} %{buildroot}/etc/logrotate.d/ppp
201    
202     %clean
203     %{__rm} -rf %{buildroot}
204    
205     %files
206     %defattr(-,root,root)
207     %{_sbindir}/chat
208     %{_sbindir}/pppd
209     %{_sbindir}/pppdump
210     %{_sbindir}/pppoe-discovery
211     %{_sbindir}/pppstats
212     %{_mandir}/man8/chat.8*
213     %{_mandir}/man8/pppd.8*
214     %{_mandir}/man8/pppdump.8*
215     %{_mandir}/man8/pppd-radattr.8*
216     %{_mandir}/man8/pppd-radius.8*
217     %{_mandir}/man8/pppstats.8*
218     %{_includedir}/pppd/
219     %{_libdir}/pppd/
220     %dir /etc/ppp/
221     %dir /var/run/ppp/
222     %attr(700, root, root) %dir /var/log/ppp/
223     %config /etc/ppp/chap-secrets
224     %config /etc/ppp/options
225     %config /etc/ppp/pap-secrets
226     %config /etc/pam.d/ppp
227     %config /etc/logrotate.d/ppp
228     %doc FAQ PLUGINS README README.cbcp README.linux README.MPPE README.MSCHAP80
229     %doc README.MSCHAP81 README.pwfd README.pppoe scripts sample
230    
231     %changelog
232     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
233     - Clean up spec so package can be built by koji/plague
234    
235     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
236     - Update to new release naming. No functional changes.
237     - Make Packager generic
238    
239     * Thu Nov 23 2006 Charlie Brady <charlie_brady@mitel.com> 2.4.4-1.3
240     - Have another go at last patch.
241    
242     * Tue Nov 21 2006 Charlie Brady <charlie_brady@mitel.com> 2.4.4-1.2
243     - Add option for chapms secrets to be pre-hashed
244    
245     * Fri Sep 8 2006 Paul Howarth <paul@city-fan.org> 2.4.4-1.1
246     - add dist tag
247     - add URL
248     - define %%{__id_u} for builds on non-Red Hat-based distributions
249     - use Fedora standard buildroot
250     - vary libpcap buildreq based on distribution/release
251     - remove versioned libpcap dependency
252     - remove buildroot unconditionally in %%install
253     - got rid of a few cosmetic rpmlint warnings
254     - add patches:
255     * patch to support mppe_lower_mtu/nomppe_lower_mtu options
256     * Arvin Schnell's ifname patch
257     (http://marc.theaimsgroup.com/?l=linux-ppp&m=109025160924399&w=2)
258     * define atm_backend_t if the system headers don't (needed on FC2)
259     * extract debug symbols from pppd and pppoe-discovery
260     * use old-style PAM configs on older distributions
261     * look for libpcap headers in different places on older distributions
262     * fix inbound/outbound filter processing using internal functions for
263     old libpcap versions
264     * don't debug trace calls to cbcp_open unless the debug flag is set
265     * make sure SIOCSIFNAME is defined (needed for ifname patch on RHL7)
266     - clean patch cruft more carefully (don't delete ipv6 sample scripts)
267     - cosmetic spec file tidying
268    
269     * Wed Jul 19 2006 Thomas Woerner <twoerner@redhat.com> 2.4.4-1
270     - new version 2.4.4 with lots of fixes
271     - fixed resolv.conf docs (#165072)
272     Thanks to Matt Domsch for the initial patch
273     - enabled CBCP (#199278)
274    
275     * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.3-6.2.2
276     - rebuild
277    
278     * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.3-6.2.1
279     - bump again for double-long bug on ppc(64)
280    
281     * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.3-6.2
282     - rebuilt for new gcc4.1 snapshot and glibc changes
283    
284     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
285     - rebuilt
286    
287     * Sat Nov 12 2005 Florian La Roche <laroche@redhat.com>
288     - rebuild
289    
290     * Fri Nov 4 2005 David Woodhouse <dwmw2@redhat.com> 2.4.3-5
291     - Implement ipv6cp-accept-remote option
292    
293     * Fri Oct 7 2005 Tomas Mraz <tmraz@redhat.com> 2.4.3-4
294     - use include instead of pam_stack in pam config
295    
296     * Sun Jul 31 2005 Florian La Roche <laroche@redhat.com>
297     - rebuild for libpcap of the day
298    
299     * Tue Jul 19 2005 Thomas Woerner <twoerner@redhat.com> 2.4.3-2.1
300     - additional patch for the scripts, thanks to Sammy (#163621)
301    
302     * Tue Jul 19 2005 Thomas Woerner <twoerner@redhat.com> 2.4.3-2
303     - dropped all executable bits in scripts directory to prevent rpm requiring
304     programs used in there
305    
306     * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 2.4.3-1
307     - new version 2.4.3
308     - updated patches: make, lib64, dontwriteetc, fix, fix64, no_strip,
309     radiusplugin
310     - dropped patches: bpf, signal, pcap, pppoatm, pkgcheck
311    
312     * Tue Nov 2 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-7
313     - fixed out of bounds memory access, possible DOS
314    
315     * Thu Oct 7 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-6.3
316     - Fix use of 'demand' without explicit MTU/MRU with pppoatm
317    
318     * Tue Oct 5 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-6.2
319     - Link pppoatm plugin against libresolv.
320     - Revert to linux-atm headers without the workaround for #127098
321    
322     * Mon Oct 4 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-6.1
323     - Include atmsap.h for pppoatm plugin.
324    
325     * Mon Oct 4 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-6
326     - Add pppoatm plugin (#131555)
327    
328     * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-5.1
329     - fixed subscript out of range (#132677)
330    
331     * Wed Sep 15 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-5
332     - example scripts are using change_resolv_conf to modify /etc/resolv.conf
333     (#132482)
334     - require new libpcap library (>= 0.8.3-6) with a fix for inbound/outbound
335     filter processing
336     - not using internal libpcap structures anymore, fixes inbound/outbound
337     filter processing (#128053)
338    
339     * Fri Aug 6 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-4
340     - fixed signal handling (#29171)
341    
342     * Mon Jun 21 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-3.1
343     - fixed compiler warnings
344     - fixed 64bit problem with ms-chap (#125501)
345     - enabled pie again
346    
347     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
348     - rebuilt
349    
350     * Wed May 24 2004 David Woodhouse <dwmw2@redhat.com> 2.4.2-2.3
351     - Enable IPv6 support. Disable PIE to avoid bogus Provides:
352    
353     * Fri May 14 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-2.2
354     - compiled pppd and chat PIE
355    
356     * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> 2.4.2-2.1
357     - added 'missingok' to ppp.logrotate (#122911)
358    
359     * Fri May 07 2004 Nils Philippsen <nphilipp@redhat.com> 2.4.2-2
360     - don't write to /etc (#118837)
361    
362     * Wed Mar 10 2004 Nalin Dahyabhai <nalin@redhat.com> 2.4.2-1
363     - update to 2.4.2
364    
365     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
366     - rebuilt
367    
368     * Fri Sep 5 2003 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-15
369     - rebuild
370    
371     * Fri Sep 5 2003 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-14
372     - apply the patch from -11
373    
374     * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
375     - rebuilt
376    
377     * Tue Jun 3 2003 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-12
378     - rebuild
379    
380     * Tue Jun 3 2003 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-11
381     - check for libcrypt in the right directory at compile-time
382    
383     * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
384     - rebuilt
385    
386     * Thu Dec 12 2002 Elliot Lee <sopwith@redhat.com> 2.4.1-9
387     - Fix build failure by rebuilding
388    
389     * Tue Nov 19 2002 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-8
390     - rebuild
391     - set x86_64 to use varargs the way s390 does
392    
393     * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
394     - add patch:
395     * Thu Jun 06 2002 Phil Knirsch <pknirsch@redhat.com>
396     - Fixed varargs problem for s390/s390x.
397    
398     * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
399     - automated rebuild
400    
401     * Sun May 26 2002 Tim Powers <timp@redhat.com>
402     - automated rebuild
403    
404     * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-4
405     - rebuild in new environment
406    
407     * Wed Feb 27 2002 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-3
408     - revert cbcp patch, it's wrong (#55367)
409    
410     * Thu Aug 9 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-2
411     - add buildprereq on pam-devel (#49559)
412     - add patch to respond to CBCP LCP requests (#15738)
413     - enable cbcp support at build-time
414     - change the Copyright: tag to a License: tag
415    
416     * Wed May 23 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-1
417     - update to 2.4.1
418    
419     * Fri Dec 1 2000 Nalin Dahyabhai <nalin@redhat.com>
420     - rebuild in new environment
421    
422     * Thu Nov 9 2000 Nalin Dahyabhai <nalin@redhat.com>
423     - update to 2.4.0
424    
425     * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
426     - automatic rebuild
427    
428     * Mon Jun 5 2000 Nalin Dahyabhai <nalin@redhat.com>
429     - move man pages to %%{_mandir}
430    
431     * Thu Jun 1 2000 Nalin Dahyabhai <nalin@redhat.com>
432     - change perms using defattr
433     - modify PAM setup to use system-auth
434    
435     * Sun Mar 26 2000 Florian La Roche <Florian.La Roche@redhat.com>
436     - change to root:root perms
437    
438     * Mon Mar 06 2000 Nalin Dahyabhai <nalin@redhat.com>
439     - reaper bugs verified as fixed
440     - check pam_open_session result code (bug #9966)
441    
442     * Mon Feb 07 2000 Nalin Dahyabhai <nalin@redhat.com>
443     - take a shot at the wrong reaper bugs (#8153, #5290)
444    
445     * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
446     - free ride through the build system (release 2)
447    
448     * Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
449     - Update to 2.3.11
450    
451     * Sat Nov 06 1999 Michael K. Johnson <johnsonm@redhat.com>
452     - Better fix for both problems
453    
454     * Fri Nov 05 1999 Michael K. Johnson <johnsonm@redhat.com>
455     - fix for double-dial problem
456     - fix for requiring a controlling terminal problem
457    
458     * Sun Sep 19 1999 Preston Brown <pbrown@redhat.com>
459     - 2.3.10 bugfix release
460    
461     * Fri Aug 13 1999 Michael K. Johnson <johnsonm@redhat.com>
462     - New version 2.3.9 required for kernel 2.3.13 and will be required
463     for new initscripts. auth patch removed; 2.3.9 does the same thing
464     more readably than the previous patch.
465    
466     * Thu Jun 24 1999 Cristian Gafton <gafton@redhat.com>
467     - add pppdump
468    
469     * Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
470     - force pppd use the glibc's logwtmp instead of implementing its own
471    
472     * Wed Apr 01 1999 Preston Brown <pbrown@redhat.com>
473     - version 2.3.7 bugfix release
474    
475     * Tue Mar 23 1999 Cristian Gafton <gafton@redhat.com>
476     - version 2.3.6
477    
478     * Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
479     - auth patch
480    
481     * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
482     - auto rebuild in the new build environment (release 3)
483    
484     * Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
485     - build for glibc 2.1
486    
487     * Fri Jun 5 1998 Jeff Johnson <jbj@redhat.com>
488     - updated to 2.3.5.
489    
490     * Tue May 19 1998 Prospector System <bugs@redhat.com>
491     - translations modified for de
492    
493     * Fri May 8 1998 Jakub Jelinek <jj@ultra.linux.cz>
494     - make it run with kernels 2.1.100 and above.
495    
496     * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
497     - translations modified for de, fr, tr
498    
499     * Wed Mar 18 1998 Cristian Gafton <gafton@redhat.com>
500     - requires glibc 2.0.6 or later
501    
502     * Wed Mar 18 1998 Michael K. Johnson <johnsonm@redhat.com>
503     - updated PAM patch to not turn off wtmp/utmp/syslog logging.
504    
505     * Wed Jan 7 1998 Cristian Gafton <gafton@redhat.com>
506     - added the /etc/pam.d config file
507     - updated PAM patch to include session support
508    
509     * Tue Jan 6 1998 Cristian Gafton <gafton@redhat.com>
510     - updated to ppp-2.3.3, build against glibc-2.0.6 - previous patches not
511     required any more.
512     - added buildroot
513     - fixed the PAM support, which was really, completely broken and against any
514     standards (session support is still not here... :-( )
515     - we build against running kernel and pray that it will work
516     - added a samples patch; updated glibc patch
517    
518     * Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
519     - added a patch to use our own route.h, rather then glibc's (which has
520     alignment problems on Alpha's) -- I only applied this patch on the Alpha,
521     though it should be safe everywhere
522    
523     * Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
524     - turned off the execute bit for scripts in /usr/doc
525    
526     * Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
527     - built against glibc
528    
529     * Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
530     - Integrated new patch from David Mosberger
531     - Improved description
532    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed