/[smeserver]/rpms/pptpd/sme7/pptpd.spec
ViewVC logotype

Annotation of /rpms/pptpd/sme7/pptpd.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jun 12 17:09:21 2007 UTC (16 years, 11 months ago) by slords
Branch: MAIN
CVS Tags: pptpd-1_3_4-1_el4_sme
Import on branch sme7 of package pptpd-1.3.4-1.el4.sme.src.rpm

1 slords 1.1 %{!?__id_u: %define __id_u %([ -x /bin/id ]&&echo /bin/id||([ -x /usr/bin/id ]&&echo /usr/bin/id|| echo /bin/true)) -u}
2    
3     # Available rpmbuild options:
4     #
5     # --without libwrap
6     # --with bsdppp
7     # --with slirp
8     # --with ipalloc
9     # --without bcrelay
10     #
11    
12     Summary: PoPToP Point to Point Tunneling Server
13     Name: pptpd
14     Version: 1.3.4
15     Release: 1%{?dist}
16     License: GPL
17     Group: Applications/Internet
18     URL: http://poptop.sourceforge.net/
19     Source0: http://dl.sf.net/poptop/pptpd-%{version}.tar.gz
20     Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21     Requires: ppp >= 2.4.3
22    
23     %if %{?_without_libwrap:0}%{!?_without_libwrap:1}
24     BuildRequires: tcp_wrappers
25     %endif
26    
27     Requires(post): /sbin/chkconfig
28     Requires(preun): /sbin/chkconfig, /sbin/service
29     Requires(postun): /sbin/service
30    
31     %description
32     This implements a Virtual Private Networking Server (VPN) that is
33     compatible with Microsoft VPN clients. It allows windows users to
34     connect to an internal firewalled network using their dialup.
35    
36     %prep
37     %setup -q
38    
39     # Fix permissions
40     %{__chmod} 644 *.[ch] samples/pptpd.conf AUTHORS
41    
42     # Fix for distros with %{_libdir} = /usr/lib64
43     %{__perl} -pi -e 's,/usr/lib/pptpd,%{_libdir}/pptpd,;' pptpctrl.c
44    
45     %build
46     %configure \
47     %{!?_without_libwrap:--with-libwrap} \
48     %{?_without_libwrap:--without-libwrap} \
49     %{!?_with_bsdppp:--without-bsdppp} \
50     %{?_with_bsdppp:--with-bsdppp} \
51     %{!?_with_slirp:--without-slirp} \
52     %{?_with_slirp:--with-slirp} \
53     %{!?_with_ipalloc:--without-pppd-ip-alloc} \
54     %{?_with_ipalloc:--with-pppd-ip-alloc} \
55     %{!?_without_bcrelay:--with-bcrelay} \
56     %{?_without_bcrelay:--without-bcrelay}
57     (echo '#undef VERSION'; echo '#define VERSION "2.4.3"') >> plugins/patchlevel.h
58     %{__make} CFLAGS='-fno-builtin -fPIC -DSBINDIR=\"%{_sbindir}\" %{optflags}'
59    
60     %install
61     %{__rm} -rf %{buildroot}
62     %{__mkdir_p} %{buildroot}/etc/rc.d/init.d
63     %{__mkdir_p} %{buildroot}/etc/ppp
64     %{__mkdir_p} %{buildroot}%{_bindir}
65     %{__mkdir_p} %{buildroot}%{_mandir}/man{5,8}
66     %{__make} \
67     DESTDIR=%{buildroot} \
68     INSTALL=%{__install} \
69     LIBDIR=%{buildroot}%{_libdir}/pptpd \
70     install
71     %{__install} -m 0755 pptpd.init %{buildroot}/etc/rc.d/init.d/pptpd
72     %{__install} -m 0644 samples/pptpd.conf %{buildroot}/etc/pptpd.conf
73     %{__install} -m 0644 samples/options.pptpd %{buildroot}/etc/ppp/options.pptpd
74     %{__install} -m 0755 tools/vpnuser %{buildroot}%{_bindir}/vpnuser
75     %{__install} -m 0755 tools/vpnstats.pl %{buildroot}%{_bindir}/vpnstats.pl
76     %{__install} -m 0755 tools/pptp-portslave %{buildroot}%{_sbindir}/pptp-portslave
77     %{__install} -m 0644 pptpd.conf.5 %{buildroot}%{_mandir}/man5/pptpd.conf.5
78     %{__install} -m 0644 pptpd.8 %{buildroot}%{_mandir}/man8/pptpd.8
79     %{__install} -m 0644 pptpctrl.8 %{buildroot}%{_mandir}/man8/pptpctrl.8
80    
81     %post
82     /sbin/chkconfig --add pptpd || :
83     OUTD="" ; for i in d manager ctrl ; do
84     test -x /sbin/pptp$i && OUTD="$OUTD /sbin/pptp$i" ;
85     done
86     test -z "$OUTD" || \
87     { echo "possible outdated executable detected; we now use %{_sbindir}/pptp*, perhaps you should run the following command:"; echo "rm -i $OUTD" ;}
88    
89     %postun
90     [ $1 -gt 0 ] && /sbin/service pptpd condrestart &> /dev/null || :
91    
92     %preun
93     if [ "$1" -lt 1 ]; then
94     /sbin/service pptpd stop &> /dev/null || :
95     /sbin/chkconfig --del pptpd || :
96     fi
97    
98     %clean
99     %{__rm} -rf %{buildroot}
100    
101     %files
102     %defattr(-,root,root,0755)
103     %doc AUTHORS COPYING INSTALL README* TODO ChangeLog* samples
104     %{_sbindir}/pptpd
105     %{_sbindir}/pptpctrl
106     %{_sbindir}/pptp-portslave
107     %{!?_without_bcrelay:%{_sbindir}/bcrelay}
108     %{_libdir}/pptpd/pptpd-logwtmp.so
109     %{_bindir}/vpnuser
110     %{_bindir}/vpnstats.pl
111     %{_mandir}/man5/pptpd.conf.5*
112     %{_mandir}/man8/pptpd.8*
113     %{_mandir}/man8/pptpctrl.8*
114     /etc/rc.d/init.d/pptpd
115     %config(noreplace) /etc/pptpd.conf
116     %config(noreplace) /etc/ppp/options.pptpd
117    
118     %changelog
119     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
120     - Clean up spec so package can be built by koji/plague
121    
122     * Tue Apr 17 2007 Shad L. Lords <slords@mail.com> 1.3.4-1
123     - Update to 1.3.4
124    
125     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
126     - Update to new release naming. No functional changes.
127     - Make Packager generic
128    
129     * Thu Dec 07 2006 Charlie Brady <charlieb@e-smith.com> 1.3.3-2
130     - Avoid echo races if GRE arrives before pppd starts and takes
131     pty out of echo mode. For background, see these threads:
132     http://marc.theaimsgroup.com/?l=poptop-server&m=112264325812671
133     http://marc.theaimsgroup.com/?l=poptop-server&m=116466455009310
134    
135     * Tue Sep 5 2006 Paul Howarth <paul@city-fan.org> - 1.3.3-1
136     - Update to 1.3.3
137     - Add dist tag
138     - Add %%postun scriptlet dependency for /sbin/service
139     - Fix doc permissions
140    
141     * Fri Mar 31 2006 Paul Howarth <paul@city-fan.org> - 1.3.1-1
142     - Update to 1.3.1
143    
144     * Fri Mar 31 2006 Paul Howarth <paul@city-fan.org> - 1.3.0-1
145     - update to 1.3.0
146     - remove redundant macro definitions
147     - change Group: to one listed in rpm's GROUPS file
148     - use full URL for source
149     - simplify conditional build code
150     - use macros for destination directories
151     - honour %%{optflags}
152     - general spec file cleanup
153     - initscript updates:
154     don't enable the service by default
155     add reload and condrestart options
156     - condrestart service on package upgrade
157     - fix build on x86_64
158     - add buildreq tcp_wrappers
159    
160     * Fri Feb 18 2005 James Cameron <james.cameron@hp.com>
161     - fix to use ppp 2.4.3 for plugin
162    
163     * Thu Nov 11 2004 James Cameron <james.cameron@hp.com>
164     - adjust for building on Red Hat Enterprise Linux, per Charlie Brady
165     - remove vpnstats, superceded by vpnstats.pl
166    
167     * Fri May 21 2004 James Cameron <james.cameron@hp.com>
168     - adjust for packaging naming and test
169    
170     * Fri Apr 23 2004 James Cameron <james.cameron@hp.com>
171     - include vpnwho.pl
172    
173     * Thu Apr 22 2004 James Cameron <james.cameron@hp.com>
174     - change description wording
175     - change URL for upstream
176     - release first candidate for 1.2.0
177    
178     * Fri Jul 18 2003 R. de Vroede <richard@oip.tudelft.nl>
179     - Check the ChangeLog files.
180    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed