1 |
# $Id$ |
2 |
|
3 |
%{!?__id_u: %define __id_u %([ -x /bin/id ]&&echo /bin/id||([ -x /usr/bin/id ]&&echo /usr/bin/id|| echo /bin/true)) -u} |
4 |
|
5 |
# Available rpmbuild options: |
6 |
# |
7 |
# --without libwrap |
8 |
# --with bsdppp |
9 |
# --with slirp |
10 |
# --with ipalloc |
11 |
# --without bcrelay |
12 |
# |
13 |
|
14 |
Summary: PoPToP Point to Point Tunneling Server |
15 |
Name: pptpd |
16 |
Version: 1.3.4 |
17 |
Release: 1%{?dist} |
18 |
License: GPL |
19 |
Group: Applications/Internet |
20 |
URL: http://poptop.sourceforge.net/ |
21 |
Source0: http://dl.sf.net/poptop/pptpd-%{version}.tar.gz |
22 |
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
23 |
Requires: ppp >= 2.4.3 |
24 |
|
25 |
%if %{?_without_libwrap:0}%{!?_without_libwrap:1} |
26 |
BuildRequires: tcp_wrappers |
27 |
%endif |
28 |
|
29 |
Requires(post): /sbin/chkconfig |
30 |
Requires(preun): /sbin/chkconfig, /sbin/service |
31 |
Requires(postun): /sbin/service |
32 |
|
33 |
%description |
34 |
This implements a Virtual Private Networking Server (VPN) that is |
35 |
compatible with Microsoft VPN clients. It allows windows users to |
36 |
connect to an internal firewalled network using their dialup. |
37 |
|
38 |
%prep |
39 |
%setup -q |
40 |
|
41 |
# Fix permissions |
42 |
%{__chmod} 644 *.[ch] samples/pptpd.conf AUTHORS |
43 |
|
44 |
# Fix for distros with %{_libdir} = /usr/lib64 |
45 |
%{__perl} -pi -e 's,/usr/lib/pptpd,%{_libdir}/pptpd,;' pptpctrl.c |
46 |
|
47 |
%build |
48 |
%configure \ |
49 |
%{!?_without_libwrap:--with-libwrap} \ |
50 |
%{?_without_libwrap:--without-libwrap} \ |
51 |
%{!?_with_bsdppp:--without-bsdppp} \ |
52 |
%{?_with_bsdppp:--with-bsdppp} \ |
53 |
%{!?_with_slirp:--without-slirp} \ |
54 |
%{?_with_slirp:--with-slirp} \ |
55 |
%{!?_with_ipalloc:--without-pppd-ip-alloc} \ |
56 |
%{?_with_ipalloc:--with-pppd-ip-alloc} \ |
57 |
%{!?_without_bcrelay:--with-bcrelay} \ |
58 |
%{?_without_bcrelay:--without-bcrelay} |
59 |
(echo '#undef VERSION'; echo '#define VERSION "2.4.3"') >> plugins/patchlevel.h |
60 |
%{__make} CFLAGS='-fno-builtin -fPIC -DSBINDIR=\"%{_sbindir}\" %{optflags}' |
61 |
|
62 |
%install |
63 |
%{__rm} -rf %{buildroot} |
64 |
%{__mkdir_p} %{buildroot}/etc/rc.d/init.d |
65 |
%{__mkdir_p} %{buildroot}/etc/ppp |
66 |
%{__mkdir_p} %{buildroot}%{_bindir} |
67 |
%{__mkdir_p} %{buildroot}%{_mandir}/man{5,8} |
68 |
%{__make} \ |
69 |
DESTDIR=%{buildroot} \ |
70 |
INSTALL=%{__install} \ |
71 |
LIBDIR=%{buildroot}%{_libdir}/pptpd \ |
72 |
install |
73 |
%{__install} -m 0755 pptpd.init %{buildroot}/etc/rc.d/init.d/pptpd |
74 |
%{__install} -m 0644 samples/pptpd.conf %{buildroot}/etc/pptpd.conf |
75 |
%{__install} -m 0644 samples/options.pptpd %{buildroot}/etc/ppp/options.pptpd |
76 |
%{__install} -m 0755 tools/vpnuser %{buildroot}%{_bindir}/vpnuser |
77 |
%{__install} -m 0755 tools/vpnstats.pl %{buildroot}%{_bindir}/vpnstats.pl |
78 |
%{__install} -m 0755 tools/pptp-portslave %{buildroot}%{_sbindir}/pptp-portslave |
79 |
%{__install} -m 0644 pptpd.conf.5 %{buildroot}%{_mandir}/man5/pptpd.conf.5 |
80 |
%{__install} -m 0644 pptpd.8 %{buildroot}%{_mandir}/man8/pptpd.8 |
81 |
%{__install} -m 0644 pptpctrl.8 %{buildroot}%{_mandir}/man8/pptpctrl.8 |
82 |
|
83 |
%post |
84 |
/sbin/chkconfig --add pptpd || : |
85 |
OUTD="" ; for i in d manager ctrl ; do |
86 |
test -x /sbin/pptp$i && OUTD="$OUTD /sbin/pptp$i" ; |
87 |
done |
88 |
test -z "$OUTD" || \ |
89 |
{ echo "possible outdated executable detected; we now use %{_sbindir}/pptp*, perhaps you should run the following command:"; echo "rm -i $OUTD" ;} |
90 |
|
91 |
%postun |
92 |
[ $1 -gt 0 ] && /sbin/service pptpd condrestart &> /dev/null || : |
93 |
|
94 |
%preun |
95 |
if [ "$1" -lt 1 ]; then |
96 |
/sbin/service pptpd stop &> /dev/null || : |
97 |
/sbin/chkconfig --del pptpd || : |
98 |
fi |
99 |
|
100 |
%clean |
101 |
%{__rm} -rf %{buildroot} |
102 |
|
103 |
%files |
104 |
%defattr(-,root,root,0755) |
105 |
%doc AUTHORS COPYING INSTALL README* TODO ChangeLog* samples |
106 |
%{_sbindir}/pptpd |
107 |
%{_sbindir}/pptpctrl |
108 |
%{_sbindir}/pptp-portslave |
109 |
%{!?_without_bcrelay:%{_sbindir}/bcrelay} |
110 |
%{_libdir}/pptpd/pptpd-logwtmp.so |
111 |
%{_bindir}/vpnuser |
112 |
%{_bindir}/vpnstats.pl |
113 |
%{_mandir}/man5/pptpd.conf.5* |
114 |
%{_mandir}/man8/pptpd.8* |
115 |
%{_mandir}/man8/pptpctrl.8* |
116 |
/etc/rc.d/init.d/pptpd |
117 |
%config(noreplace) /etc/pptpd.conf |
118 |
%config(noreplace) /etc/ppp/options.pptpd |
119 |
|
120 |
%changelog |
121 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
122 |
- Clean up spec so package can be built by koji/plague |
123 |
|
124 |
* Tue Apr 17 2007 Shad L. Lords <slords@mail.com> 1.3.4-1 |
125 |
- Update to 1.3.4 |
126 |
|
127 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
128 |
- Update to new release naming. No functional changes. |
129 |
- Make Packager generic |
130 |
|
131 |
* Thu Dec 07 2006 Charlie Brady <charlieb@e-smith.com> 1.3.3-2 |
132 |
- Avoid echo races if GRE arrives before pppd starts and takes |
133 |
pty out of echo mode. For background, see these threads: |
134 |
http://marc.theaimsgroup.com/?l=poptop-server&m=112264325812671 |
135 |
http://marc.theaimsgroup.com/?l=poptop-server&m=116466455009310 |
136 |
|
137 |
* Tue Sep 5 2006 Paul Howarth <paul@city-fan.org> - 1.3.3-1 |
138 |
- Update to 1.3.3 |
139 |
- Add dist tag |
140 |
- Add %%postun scriptlet dependency for /sbin/service |
141 |
- Fix doc permissions |
142 |
|
143 |
* Fri Mar 31 2006 Paul Howarth <paul@city-fan.org> - 1.3.1-1 |
144 |
- Update to 1.3.1 |
145 |
|
146 |
* Fri Mar 31 2006 Paul Howarth <paul@city-fan.org> - 1.3.0-1 |
147 |
- update to 1.3.0 |
148 |
- remove redundant macro definitions |
149 |
- change Group: to one listed in rpm's GROUPS file |
150 |
- use full URL for source |
151 |
- simplify conditional build code |
152 |
- use macros for destination directories |
153 |
- honour %%{optflags} |
154 |
- general spec file cleanup |
155 |
- initscript updates: |
156 |
don't enable the service by default |
157 |
add reload and condrestart options |
158 |
- condrestart service on package upgrade |
159 |
- fix build on x86_64 |
160 |
- add buildreq tcp_wrappers |
161 |
|
162 |
* Fri Feb 18 2005 James Cameron <james.cameron@hp.com> |
163 |
- fix to use ppp 2.4.3 for plugin |
164 |
|
165 |
* Thu Nov 11 2004 James Cameron <james.cameron@hp.com> |
166 |
- adjust for building on Red Hat Enterprise Linux, per Charlie Brady |
167 |
- remove vpnstats, superceded by vpnstats.pl |
168 |
|
169 |
* Fri May 21 2004 James Cameron <james.cameron@hp.com> |
170 |
- adjust for packaging naming and test |
171 |
|
172 |
* Fri Apr 23 2004 James Cameron <james.cameron@hp.com> |
173 |
- include vpnwho.pl |
174 |
|
175 |
* Thu Apr 22 2004 James Cameron <james.cameron@hp.com> |
176 |
- change description wording |
177 |
- change URL for upstream |
178 |
- release first candidate for 1.2.0 |
179 |
|
180 |
* Fri Jul 18 2003 R. de Vroede <richard@oip.tudelft.nl> |
181 |
- Check the ChangeLog files. |
182 |
|