/[smeserver]/rpms/proftpd/sme7/proftpd.spec
ViewVC logotype

Annotation of /rpms/proftpd/sme7/proftpd.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Thu Nov 11 15:55:41 2010 UTC (13 years, 6 months ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +2 -2 lines
Fix .rf to .sme

1 slords 1.2 # $Id: proftpd.spec,v 1.1 2010/11/11 15:49:09 slords Exp $
2 slords 1.1 # Authority: dag
3    
4     %{?dtag: %{expand: %%define %dtag 1}}
5    
6     %{?rh7:%define _without_acl 1}
7     %{?el2:%define _without_acl 1}
8     %{?el2:%define _without_postgresql 1}
9    
10     Summary: Flexible, stable and highly-configurable FTP server
11     Name: proftpd
12     Version: 1.3.2
13 slords 1.2 Release: 1%{?dist}
14 slords 1.1 License: GPL
15     Group: System Environment/Daemons
16     URL: http://www.proftpd.org/
17    
18     Packager: Dag Wieers <dag@wieers.com>
19     Vendor: Dag Apt Repository, http://dag.wieers.com/apt/
20    
21     Source0: ftp://ftp.proftpd.org/distrib/source/proftpd-%{version}.tar.bz2
22     Source1: proftpd.conf
23     Source2: proftpd.init
24     Source3: proftpd-xinetd
25     Source4: proftpd.logrotate
26     Source5: welcome.msg
27     Source6: proftpd.pam
28     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29    
30     BuildRequires: pam-devel, ncurses-devel, pkgconfig
31     BuildRequires: openssl-devel, krb5-devel
32     BuildRequires: openldap-devel, mysql-devel, zlib-devel
33     %{!?_without_acl:BuildRequires: libacl-devel}
34     %{!?_without_postgresql:BuildRequires: postgresql-devel}
35     Requires: pam >= 0.59
36     Requires(post): /sbin/chkconfig
37     Requires(preun): /sbin/service, /sbin/chkconfig
38     Requires(postun): /sbin/service
39     Provides: ftpserver
40    
41     %description
42     ProFTPD is an enhanced FTP server with a focus toward simplicity, security,
43     and ease of configuration. It features a very Apache-like configuration
44     syntax, and a highly customizable server infrastructure, including support for
45     multiple 'virtual' FTP servers, anonymous FTP, and permission-based directory
46     visibility.
47    
48     This package defaults to the standalone behaviour of ProFTPD, but all the
49     needed scripts to have it run by xinetd instead are included.
50    
51     %package devel
52     Summary: Header files, libraries and development documentation for %{name}.
53     Group: Development/Libraries
54     Requires: %{name} = %{version}-%{release}
55    
56     %description devel
57     This package contains the header files, static libraries and development
58     documentation for %{name}. If you like to develop programs using %{name},
59     you will need to install %{name}-devel.
60    
61     %package ldap
62     Summary: Module to add LDAP support to the ProFTPD FTP server
63     Group: System Environment/Daemons
64     Requires: %{name} = %{version}-%{release}
65    
66     %description ldap
67     Module to add LDAP support to the ProFTPD FTP server.
68    
69     %package mysql
70     Summary: Module to add MySQL support to the ProFTPD FTP server
71     Group: System Environment/Daemons
72     Requires: %{name} = %{version}-%{release}
73    
74     %description mysql
75     Module to add MySQL support to the ProFTPD FTP server.
76    
77     %package postgresql
78     Summary: Module to add PostgreSQL support to the ProFTPD FTP server
79     Group: System Environment/Daemons
80     Requires: %{name} = %{version}-%{release}
81    
82     %description postgresql
83     Module to add PostgreSQL support to the ProFTPD FTP server.
84    
85     %prep
86     %setup
87    
88     # Disable stripping in order to get useful debuginfo packages
89     %{__perl} -pi -e 's|"-s"|""|g' configure
90    
91     %build
92     if pkg-config openssl; then
93     export CFLAGS="%{optflags} $(pkg-config --cflags openssl)"
94     export LDFLAGS="$LDFLAGS $(pkg-config --libs-only-L openssl)"
95     fi
96     %configure \
97     --libexecdir="%{_libexecdir}/proftpd" \
98     --localstatedir="%{_var}/run" \
99     --enable-ctrls \
100     --enable-dso \
101     %{!?_without_acl:--enable-facl} \
102     --enable-ipv6 \
103     --enable-nls \
104     --enable-openssl \
105     --with-includes="%{_includedir}/mysql" \
106     --with-libraries="%{_libdir}/mysql" \
107     --with-modules="mod_readme:mod_auth_pam:mod_tls" \
108     --with-shared="mod_ldap:mod_sql:mod_sql_mysql:%{!?_without_postgresql:mod_sql_postgres:}mod_quotatab:mod_quotatab_file:mod_quotatab_ldap:mod_quotatab_sql"
109     %{__make} %{?_smp_mflags}
110    
111     %install
112     %{__rm} -rf %{buildroot}
113     %{__make} install DESTDIR="%{buildroot}" \
114     rundir="%{_var}/run/proftpd" \
115     INSTALL_USER=`id -un` \
116     INSTALL_GROUP=`id -gn`
117     %{__install} -D -p -m 0640 %{SOURCE1} \
118     %{buildroot}%{_sysconfdir}/proftpd.conf
119     %{__install} -D -p -m 0755 %{SOURCE2} \
120     %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
121     %{__install} -D -p -m 0640 %{SOURCE3} \
122     %{buildroot}%{_sysconfdir}/xinetd.d/xproftpd
123     %{__install} -D -p -m 0644 %{SOURCE4} \
124     %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
125     %{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/var/ftp/welcome.msg
126     %{__install} -D -p -m 0644 %{SOURCE6} %{buildroot}%{_sysconfdir}/pam.d/proftpd
127     %{__mkdir_p} %{buildroot}/var/ftp/uploads
128     %{__mkdir_p} %{buildroot}/var/ftp/pub
129     %{__mkdir_p} %{buildroot}/var/log/proftpd
130     touch %{buildroot}%{_sysconfdir}/ftpusers
131    
132     %clean
133     %{__rm} -rf %{buildroot}
134    
135     %post
136     if [ $1 -eq 1 ]; then
137     /sbin/chkconfig --add proftpd
138     IFS=":"; cat /etc/passwd | \
139     while { read username nu nu gid nu nu nu nu; }; do \
140     if [ $gid -lt 100 -a "$username" != "ftp" ]; then
141     echo $username >> %{_sysconfdir}/ftpusers
142     fi
143     done
144     fi
145    
146     %preun
147     if [ $1 -eq 0 ]; then
148     /sbin/service proftpd stop &>/dev/null || :
149     /sbin/chkconfig --del proftpd
150     /sbin/service xinetd reload &>/dev/null || :
151     if [ -d %{_var}/run/proftpd ]; then
152     rm -rf %{_var}/run/proftpd/*
153     fi
154     fi
155    
156     %postun
157     if [ $1 -ge 1 ]; then
158     /sbin/service proftpd condrestart &>/dev/null || :
159     fi
160    
161     %files
162     %defattr(-, root, root, 0755)
163     %doc COPYING CREDITS ChangeLog NEWS README* doc/* sample-configurations/
164     %dir %{_localstatedir}/run/proftpd/
165     %config(noreplace) %{_sysconfdir}/proftpd.conf
166     %config(noreplace) %{_sysconfdir}/xinetd.d/xproftpd
167     %config %{_sysconfdir}/ftpusers
168     %config(noreplace) %{_sysconfdir}/pam.d/proftpd
169     %config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
170     %{_sysconfdir}/rc.d/init.d/proftpd
171     %{_mandir}/man?/*
172     %{_bindir}/*
173     %dir %{_libexecdir}/proftpd/
174     %{_libexecdir}/proftpd/mod_quotatab.so
175     %{_libexecdir}/proftpd/mod_quotatab_file.so
176     %{_libexecdir}/proftpd/mod_sql.so
177     %{_sbindir}/*
178     %dir /var/ftp/
179     %dir /var/ftp/pub/
180     %config(noreplace) /var/ftp/welcome.msg
181    
182     %defattr(0331, ftp, ftp, 0331)
183     %dir /var/ftp/uploads/
184    
185     %defattr(0750, root, root, 0750)
186     %dir /var/log/proftpd/
187     %exclude %{_libexecdir}/proftpd/*.a
188     %exclude %{_libexecdir}/proftpd/*.la
189    
190     %files devel
191     %defattr(-, root, root, 0755)
192     %{_includedir}/proftpd/
193     %{_libdir}/pkgconfig/proftpd.pc
194    
195     %files ldap
196     %defattr(-, root, root, 0755)
197     %dir %{_libexecdir}/proftpd/
198     %{_libexecdir}/proftpd/mod_ldap.so
199     %{_libexecdir}/proftpd/mod_quotatab_ldap.so
200    
201     %files mysql
202     %defattr(-, root, root, 0755)
203     %dir %{_libexecdir}/proftpd/
204     %{_libexecdir}/proftpd/mod_sql_mysql.so
205     %{_libexecdir}/proftpd/mod_quotatab_sql.so
206    
207     %if %{!?_without_postgresql:1}0
208     %files postgresql
209     %defattr(-, root, root, 0755)
210     %dir %{_libexecdir}/proftpd/
211     %{_libexecdir}/proftpd/mod_sql_postgres.so
212     %{_libexecdir}/proftpd/mod_quotatab_sql.so
213     %endif
214    
215     %changelog
216     * Thu Mar 12 2009 Dries Verachtert <dries@ulyssis.org> - 1.3.2-1 - 6721/dries
217     - Updated to release 1.3.2.
218    
219     * Sat Oct 06 2007 Dag Wieers <dag@wieers.com> - 1.3.1-1
220     - Updated to release 1.3.1.
221    
222     * Thu Jul 5 2007 Peter Bieringer <pb@bieringer.de> - 1.3.0a-4
223     - Migrate CVE-2007-2165 patches from Mandrake.
224    
225     * Tue Feb 6 2007 Matthias Saou <http://freshrpms.net/> 1.3.0a-3
226     - Patch to fix local user buffer overflow in controls request handling, rhbz
227     bug #219938, proftpd bug #2867.
228    
229     * Mon Dec 11 2006 Matthias Saou <http://freshrpms.net/> 1.3.0a-2
230     - Rebuild against new PostgreSQL.
231    
232     * Mon Nov 27 2006 Matthias Saou <http://freshrpms.net/> 1.3.0a-1
233     - Update to 1.3.0a, which actually fixes CVE-2006-5815... yes, #214820!).
234    
235     * Thu Nov 16 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-10
236     - Fix cmdbufsize patch for missing CommandBufferSize case (#214820 once more).
237    
238     * Thu Nov 16 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-9
239     - Include mod_tls patch (#214820 too).
240    
241     * Mon Nov 13 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-8
242     - Include cmdbufsize patch (#214820).
243    
244     * Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-7
245     - FC6 rebuild.
246    
247     * Mon Aug 21 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-6
248     - Add mod_quotatab, _file, _ldap and _sql (#134291).
249    
250     * Mon Jul 3 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-5
251     - Disable sendfile by default since it breaks displaying the download speed in
252     ftptop and ftpwho (#196913).
253    
254     * Mon Jun 19 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-4
255     - Include ctrls restart patch, see #195884 (patch from proftpd.org #2792).
256    
257     * Wed May 10 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-3
258     - Add commented section about DSO loading to the default proftpd.conf.
259     - Update TLS cert paths in the default proftpd.conf to /etc/pki/tls.
260    
261     * Fri Apr 28 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-2
262     - Mark pam.d and logrotate.d config files as noreplace.
263     - Include patch to remove -rpath to DESTDIR/usr/sbin/ in the proftpd binary
264     when DSO is enabled (#190122).
265    
266     * Fri Apr 21 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-1
267     - Update to 1.3.0 final.
268     - Remove no longer needed PostgreSQL and OpenSSL detection workarounds.
269     - Remove explicit conflicts on wu-ftpd, anonftp and vsftpd to let people
270     install more than one ftp daemon (what for? hmm...) (#189023).
271     - Enable LDAP, MySQL and PostgreSQL as DSOs by default, and stuff them in
272     new sub-packages. This won't introduce any regression since they weren't
273     enabled by default.
274     - Remove useless explicit requirements.
275     - Rearrange scriplets requirements.
276     - Enable ctrls (controls via ftpdctl) and facl (POSIX ACLs).
277     - Using --disable-static makes the build fail, so exclude .a files in %%files.
278     - Silence harmless IPv6 failure message at startup when IPv6 isn't available.
279    
280     * Tue Mar 7 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-0.2.rc4
281     - Update to 1.3.0rc4 (bugfix release).
282    
283     * Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-0.2.rc3
284     - FC5 rebuild.
285    
286     * Thu Feb 9 2006 Matthias Saou <http://freshrpms.net/> 1.3.0-0.1.rc3
287     - Update to 1.3.0rc3, which builds with the latest openssl.
288    
289     * Thu Nov 17 2005 Matthias Saou <http://freshrpms.net/> 1.2.10-7
290     - Rebuild against new openssl library... not.
291    
292     * Wed Jul 13 2005 Matthias Saou <http://freshrpms.net/> 1.2.10-6
293     - The provided pam.d file no longer works, use our own based on the one from
294     the vsftpd package (#163026).
295     - Rename the pam.d file we use from 'ftp' to 'proftpd'.
296     - Update deprecated AuthPAMAuthoritative in the config file (see README.PAM).
297    
298     * Tue May 10 2005 Matthias Saou <http://freshrpms.net/> 1.2.10-4
299     - Disable stripping in order to get useful debuginfo packages.
300    
301     * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 1.2.10-3
302     - rebuilt
303    
304     * Tue Nov 16 2004 Matthias Saou <http://freshrpms.net/> 1.2.10-2
305     - Bump release to provide Extras upgrade path.
306    
307     * Wed Sep 22 2004 Matthias Saou <http://freshrpms.net/> 1.2.10-1
308     - Updated to release 1.2.10.
309    
310     * Tue Jun 22 2004 Matthias Saou <http://freshrpms.net/> 1.2.9-8
311     - Added ncurses-devel build requires to fix the ftptop utility.
312    
313     * Fri Feb 26 2004 Magnus-swe <Magnus-swe@telia.com> 1.2.9-7
314     - Fixed the scoreboard and pidfile issues.
315    
316     * Fri Jan 9 2004 Matthias Saou <http://freshrpms.net/> 1.2.9-6
317     - Pass /var/run/proftpd as localstatedir to configure to fix pid and
318     scoreboard file problems.
319    
320     * Wed Dec 10 2003 Matthias Saou <http://freshrpms.net/> 1.2.9-4
321     - Fixed the MySQL include path, thanks to Jim Richardson.
322     - Renamed the postgres conditional build to postgresql.
323    
324     * Tue Nov 11 2003 Matthias Saou <http://freshrpms.net/> 1.2.9-3
325     - Renamed the xinetd service to xproftpd to avoid conflict.
326     - Only HUP the standalone proftpd through logrotate if it's running.
327    
328     * Fri Nov 7 2003 Matthias Saou <http://freshrpms.net/> 1.2.9-2
329     - Rebuild for Fedora Core 1.
330     - Modified the init script to make it i18n aware.
331    
332     * Fri Oct 31 2003 Matthias Saou <http://freshrpms.net/> 1.2.9-1
333     - Update to 1.2.9.
334    
335     * Wed Sep 24 2003 Matthias Saou <http://freshrpms.net/>
336     - Update to 1.2.8p to fix secutiry vulnerability.
337     - Fix the TLS build option at last, enable it by default.
338    
339     * Mon Aug 4 2003 Matthias Saou <http://freshrpms.net/>
340     - Minor fixes in included README files.
341    
342     * Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
343     - Rebuilt for Red Hat Linux 9.
344    
345     * Thu Mar 13 2003 Matthias Saou <http://freshrpms.net/>
346     - Update to 1.2.8.
347     - Remove the renamed linuxprivs module.
348     - Added TLS module build option.
349    
350     * Fri Dec 13 2002 Matthias Saou <http://freshrpms.net/>
351     - Fix change for ScoreboardFile in the default conf, thanks to Sven Hoexter.
352    
353     * Mon Dec 9 2002 Matthias Saou <http://freshrpms.net/>
354     - Update to 1.2.7.
355    
356     * Thu Sep 26 2002 Matthias Saou <http://freshrpms.net/>
357     - Rebuilt for Red Hat Linux 8.0.
358    
359     * Tue Sep 17 2002 Matthias Saou <http://freshrpms.net/>
360     - Update to 1.2.6.
361     - Fixed typo in the config for "AllowForeignAddress" thanks to Michel Kraus.
362     - Removed obsolete user install patch.
363     - Added "modular" ldap, mysql and postgresql support.
364    
365     * Mon Jun 10 2002 Matthias Saou <http://freshrpms.net/>
366     - Update to 1.2.5.
367     - Changed the welcome.msg to config so that it doesn't get replaced.
368    
369     * Fri May 3 2002 Matthias Saou <http://freshrpms.net/>
370     - Rebuilt against Red Hat Linux 7.3.
371     - Added the %%{?_smp_mflags} expansion.
372    
373     * Tue Oct 23 2001 Matthias Saou <http://freshrpms.net/>
374     - Changed the default config file : Where the pid file is stored, addedd
375     an upload authorization in anon server, and separate anon logfiles.
376     - Updated welcome.msg to something nicer.
377    
378     * Fri Oct 19 2001 Matthias Saou <http://freshrpms.net/>
379     - Update to 1.2.4, since 1.2.3 had a nasty umask bug.
380    
381     * Sat Aug 18 2001 Matthias Saou <http://freshrpms.net/>
382     - Update to 1.2.2 final.
383     - Changed the default config file a lot.
384    
385     * Wed Apr 25 2001 Matthias Saou <http://freshrpms.net/>
386     - Update to 1.2.2rc2.
387    
388     * Mon Apr 1 2001 Matthias Saou <http://freshrpms.net/>
389     - Update to 1.2.2rc1.
390    
391     * Tue Mar 20 2001 Matthias Saou <http://freshrpms.net/>
392     - Added a DenyFilter to prevent a recently discovered DOS attack.
393     This is only useful for fresh installs since the config file is not
394     overwritten.
395    
396     * Fri Mar 2 2001 Matthias Saou <http://freshrpms.net/>
397     - Upgraded to 1.2.1.
398     - New init script (added condrestart).
399    
400     * Tue Feb 27 2001 Matthias Saou <http://freshrpms.net/>
401     - Upgraded to 1.2.0 final.
402    
403     * Tue Feb 6 2001 Matthias Saou <http://freshrpms.net/>
404     - Upgraded to 1.2.0rc3 (at last a new version!)
405     - Modified the spec file to support transparent upgrades
406    
407     * Wed Nov 8 2000 Matthias Saou <http://freshrpms.net/>
408     - Upgraded to the latest CVS to fix the "no PORT command" bug
409     - Fixed the ftpuser creation script
410     - Modified the default config file to easily change to an anonymous
411     server
412    
413     * Sun Oct 15 2000 Matthias Saou <http://freshrpms.net/>
414     [proftpd-1.2.0rc2-2]
415     - Updated the spec file and build process for RedHat 7.0
416     - Added xinetd support
417     - Added logrotate.d support
418    
419     * Fri Jul 28 2000 Matthias Saou <http://freshrpms.net/>
420     [proftpd-1.2.0rc2-1]
421     - Upgraded to 1.2.0rc2
422    
423     - Upgraded to 1.2.0rc1
424     * Sat Jul 22 2000 Matthias Saou <http://freshrpms.net/>
425     [proftpd-1.2.0rc1-1]
426     - Upgraded to 1.2.0rc1
427     - Re-did the whole spec file (it's hopefully cleaner now)
428     - Made a patch to be able to build the RPM as an other user than root
429     - Added default pam support (but without /etc/shells check)
430     - Rewrote the rc.d script (mostly exit levels and ftpshut stuff)
431     - Modified the default configuration file to not display a version number
432     - Changed the package to standalone in one single RPM easily changeable
433     to inetd (for not-so-newbie users)
434     - Fixed the ftpusers generating shell script (missing "nu"s for me...)
435     - Removed mod_ratio (usually used with databases modules anyway)
436     - Removed the prefix (relocations a rarely used on non-X packages)
437     - Gzipped the man pages
438    
439     * Thu Oct 03 1999 O.Elliyasa <osman@Cable.EU.org>
440     - Multi package creation.
441     Created core, standalone, inetd (&doc) package creations.
442     Added startup script for init.d
443     Need to make the "standalone & inetd" packages being created as "noarch"
444     - Added URL.
445     - Added prefix to make the package relocatable.
446    
447     * Wed Sep 08 1999 O.Elliyasa <osman@Cable.EU.org>
448     - Corrected inetd.conf line addition/change logic.
449    
450     * Sat Jul 24 1999 MacGyver <macgyver@tos.net>
451     - Initial import of spec.
452    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed