1 |
slords |
1.1 |
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")} |
2 |
|
|
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")} |
3 |
|
|
|
4 |
|
|
%define _upstream_nvr elementtree-1.2.6-20050316 |
5 |
|
|
%define _upstream_cnvr cElementTree-1.0.5-20051216 |
6 |
|
|
|
7 |
|
|
%define python_ver %(%{__python} -c "import sys ; print sys.version[:3]") |
8 |
|
|
|
9 |
|
|
%if "%{python_ver}" < "2.3" |
10 |
|
|
%define buildel3 1 |
11 |
|
|
%else |
12 |
|
|
%define buildel3 0 |
13 |
|
|
%endif |
14 |
|
|
|
15 |
|
|
Name: python-elementtree |
16 |
|
|
Version: 1.2.6 |
17 |
|
|
Release: 5%{?dist} |
18 |
|
|
Summary: Fast XML parser and writer |
19 |
|
|
Group: Development/Libraries |
20 |
|
|
License: PSF |
21 |
|
|
URL: http://effbot.org/zone/element-index.htm |
22 |
|
|
Source0: http://effbot.org/downloads/%{_upstream_nvr}.zip |
23 |
|
|
Source1: http://effbot.org/downloads/%{_upstream_cnvr}.tar.gz |
24 |
|
|
Source2: cElementTree-system-expat-setup.py |
25 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
26 |
|
|
BuildRequires: expat-devel, python-devel |
27 |
|
|
|
28 |
|
|
%if %{buildel3} |
29 |
|
|
#Requires: python-abi = %(%{__python} -c "import sys ; print sys.version[:3]") |
30 |
|
|
%else |
31 |
|
|
Requires: python-abi = %(%{__python} -c "import sys ; print sys.version[:3]") |
32 |
|
|
%endif |
33 |
|
|
|
34 |
|
|
%description |
35 |
|
|
The Element type is a simple but flexible container object, designed |
36 |
|
|
to store hierarchical data structures, such as simplified XML |
37 |
|
|
infosets, in memory. The element type can be described as a cross |
38 |
|
|
between a Python list and a Python dictionary. |
39 |
|
|
|
40 |
|
|
This package also includes the C implementation, %{_upstream_cnvr}. |
41 |
|
|
|
42 |
|
|
%prep |
43 |
|
|
%setup -q -n %{_upstream_nvr} -a 1 |
44 |
|
|
|
45 |
|
|
## Take care of cElementTree |
46 |
|
|
pushd %{_upstream_cnvr} |
47 |
|
|
mv -f setup.py setup.py-orig |
48 |
|
|
cp -f %{SOURCE2} setup.py |
49 |
|
|
cp -f README ../README-cElementTree |
50 |
|
|
cp -f CHANGES ../CHANGES-cElementTree |
51 |
|
|
popd |
52 |
|
|
|
53 |
|
|
|
54 |
|
|
%build |
55 |
|
|
%{__python} setup.py build |
56 |
|
|
pushd %{_upstream_cnvr} |
57 |
|
|
CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build |
58 |
|
|
popd |
59 |
|
|
|
60 |
|
|
|
61 |
|
|
%install |
62 |
|
|
rm -rf $RPM_BUILD_ROOT |
63 |
|
|
%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT |
64 |
|
|
pushd %{_upstream_cnvr} |
65 |
|
|
%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT |
66 |
|
|
popd |
67 |
|
|
|
68 |
|
|
|
69 |
|
|
%clean |
70 |
|
|
rm -rf $RPM_BUILD_ROOT |
71 |
|
|
|
72 |
|
|
|
73 |
|
|
%files |
74 |
|
|
%defattr(-,root,root,-) |
75 |
|
|
%doc docs samples README* CHANGES* benchmark.py |
76 |
|
|
%dir %{python_sitelib}/elementtree |
77 |
|
|
%{python_sitelib}/elementtree/*.py* |
78 |
|
|
%{python_sitearch}/*.so |
79 |
|
|
|
80 |
|
|
%changelog |
81 |
|
|
* Mon Apr 30 2007 Johnny Hughes <johnny@centos.org> 1.2.6-5.el3.centos |
82 |
|
|
- modified to build on CentOS-3 or CentOS-4 by only requiring python-abi |
83 |
|
|
with python > 2.3 |
84 |
|
|
|
85 |
|
|
* Wed Sep 6 2006 Jeremy Katz <katzj@redhat.com> - 1.2.6-5 |
86 |
|
|
- don't ghost pyo files (#205446) |
87 |
|
|
- upstream bugfix release |
88 |
|
|
|
89 |
|
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.6-4.2.2 |
90 |
|
|
- rebuild |
91 |
|
|
|
92 |
|
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.6-4.2.1 |
93 |
|
|
- bump again for double-long bug on ppc(64) |
94 |
|
|
|
95 |
|
|
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.6-4.2 |
96 |
|
|
- rebuilt for new gcc4.1 snapshot and glibc changes |
97 |
|
|
|
98 |
|
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
99 |
|
|
- rebuilt |
100 |
|
|
|
101 |
|
|
* Mon Apr 4 2005 Jeremy Katz <katzj@redhat.com> - 1.2.6-4 |
102 |
|
|
- rebuild for core |
103 |
|
|
- use %%setup -q -a 1 instead of unzipping source1 |
104 |
|
|
|
105 |
|
|
* Tue Mar 30 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 1.2.6-3 |
106 |
|
|
- Use python_sitearch for the C library. |
107 |
|
|
|
108 |
|
|
* Tue Mar 29 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 1.2.6-2 |
109 |
|
|
- Use python_sitelib |
110 |
|
|
- Own the elementtree dir in site-packages |
111 |
|
|
- BuildRequire python-devel |
112 |
|
|
- Do not namely require expat |
113 |
|
|
- Do not use INSTALLED_FILES (safer) |
114 |
|
|
- Use ghosting for .pyo |
115 |
|
|
|
116 |
|
|
* Thu Mar 17 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 1.2.6-1 |
117 |
|
|
- Version 1.2.6 of ElementTree. |
118 |
|
|
|
119 |
|
|
* Thu Mar 10 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 1.2.5-1 |
120 |
|
|
- Rename as python-elementtree. |
121 |
|
|
|
122 |
|
|
* Sat Mar 5 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 1.2.5-1 |
123 |
|
|
- Initial RPM release. |
124 |
|
|
|