1 |
slords |
1.1 |
# |
2 |
|
|
# RPM spec file for Dan Bernstein's qmailanalog package |
3 |
|
|
# |
4 |
|
|
# $Id: qmailanalog.spec,v 1.3 2005/07/28 02:29:50 charlieb Exp $ |
5 |
|
|
# |
6 |
|
|
Summary: A collection of tools to help you analyze qmail's activity record. |
7 |
|
|
%define name qmailanalog |
8 |
|
|
Name: %{name} |
9 |
|
|
%define version 0.70 |
10 |
|
|
%define release 7 |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: Daniel J. Bernstein - http://cr.yp.to/distributors.html |
14 |
|
|
Group: Networking/Daemons |
15 |
|
|
Source: http://cr.yp.to/software/%{name}-%{version}.tar.gz |
16 |
|
|
URL: http://cr.yp.to/%{name}.html |
17 |
|
|
Patch0: %{name}-%{version}.patch.2001020500 |
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
|
|
Provides: qmailanalog |
20 |
|
|
AutoReqProv: no |
21 |
|
|
BuildRequires: groff |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
qmailanalog is a collection of tools to help you analyze qmail's activity |
25 |
|
|
record. It supplies statistics to answer a wide variety of questions: |
26 |
|
|
|
27 |
|
|
- overall: how many messages? recipients? attempts? etc. |
28 |
|
|
- ddist: how soon were 50% of the messages delivered? 90%? 95%? 99%? |
29 |
|
|
- rxdelay: what's the best order of recipients for mailing lists? |
30 |
|
|
- recipients, rhosts: who's getting mail? bytes? messages? attempts? |
31 |
|
|
- successes, failures, deferrals: why? how often? how much delay? |
32 |
|
|
- senders, suids: messages? bytes? load? recipients? attempts? delay? |
33 |
|
|
|
34 |
|
|
qmailanalog also includes several tools to focus attention on particular |
35 |
|
|
senders, recipients, or messages. |
36 |
|
|
|
37 |
|
|
%changelog |
38 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
39 |
|
|
- Clean up spec so package can be built by koji/plague |
40 |
|
|
|
41 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
42 |
|
|
- Update to new release naming. No functional changes. |
43 |
|
|
- Make Packager generic |
44 |
|
|
|
45 |
|
|
* Tue Dec 20 2005 Charlie Brady <charlieb@e-smith.com> 0.70-06 |
46 |
|
|
- Change obsolete Copyright tag to a License tag, and include |
47 |
|
|
URL to DJB's information for distributors. |
48 |
|
|
|
49 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> |
50 |
|
|
- Bump release number only |
51 |
|
|
|
52 |
|
|
* Fri Mar 18 2005 Charlie Brady <charlieb@e-smith.com> |
53 |
|
|
- [0.70-04] |
54 |
|
|
- Add workaround for glibc errno bug. |
55 |
|
|
|
56 |
|
|
* Mon Feb 5 2001 Peter Samuel <peters@e-smith.com> |
57 |
|
|
- [0.70-03] |
58 |
|
|
- Now installs in its own root area prior to creating binary RPM. |
59 |
|
|
- Default installation locations are restored. |
60 |
|
|
|
61 |
|
|
* Wed Aug 16 2000 Peter Samuel <peters@e-smith.com> |
62 |
|
|
- [0.70-2] |
63 |
|
|
- added patch to change default install location |
64 |
|
|
|
65 |
|
|
* Fri Jun 16 2000 Peter Samuel <Peter.Samuel@gormand.com.au> |
66 |
|
|
- [0.70-1] |
67 |
|
|
- Initial build |
68 |
|
|
|
69 |
|
|
%prep |
70 |
|
|
%setup |
71 |
|
|
|
72 |
|
|
# This patch allows files to be installed in a relative directory prior |
73 |
|
|
# to creating the binary RPM. It does not change the files or their |
74 |
|
|
# final installed locations. |
75 |
|
|
|
76 |
|
|
%patch0 -p1 |
77 |
|
|
|
78 |
|
|
# Create the relative installation directory. |
79 |
|
|
|
80 |
|
|
mkdir -p ./root/usr/local |
81 |
|
|
# Workaround glibc errno bug |
82 |
|
|
echo gcc -O --include /usr/include/errno.h > conf-cc |
83 |
|
|
|
84 |
|
|
%build |
85 |
|
|
make |
86 |
|
|
|
87 |
|
|
%install |
88 |
|
|
make setup |
89 |
|
|
make check |
90 |
|
|
rm -rf $RPM_BUILD_ROOT |
91 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
92 |
|
|
|
93 |
|
|
%clean |
94 |
|
|
rm -rf $RPM_BUILD_ROOT |
95 |
|
|
|
96 |
|
|
%files |
97 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/columnt |
98 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/ddist |
99 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/deferrals |
100 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/failures |
101 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/matchup |
102 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/recipients |
103 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/rhosts |
104 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/rxdelay |
105 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/senders |
106 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/successes |
107 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/suids |
108 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/xqp |
109 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/xrecipient |
110 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/xsender |
111 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zddist |
112 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zdeferrals |
113 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zfailures |
114 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zoverall |
115 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zrecipients |
116 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zrhosts |
117 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zrxdelay |
118 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zsenders |
119 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zsendmail |
120 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zsuccesses |
121 |
|
|
%attr(755,root,root) /usr/local/qmailanalog/bin/zsuids |
122 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/doc/ACCOUNTING |
123 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/doc/MATCHUP |
124 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/cat1/columnt.0 |
125 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/cat1/matchup.0 |
126 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/cat1/xqp.0 |
127 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/cat1/xrecipient.0 |
128 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/cat1/xsender.0 |
129 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/man1/columnt.1 |
130 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/man1/matchup.1 |
131 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/man1/xqp.1 |
132 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/man1/xrecipient.1 |
133 |
|
|
%attr(644,root,root) /usr/local/qmailanalog/man/man1/xsender.1 |