/[smeserver]/rpms/qmailanalog/sme8/qmailanalog.spec
ViewVC logotype

Annotation of /rpms/qmailanalog/sme8/qmailanalog.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Wed Apr 9 13:51:55 2008 UTC (16 years, 1 month ago) by slords
Branch: MAIN
Changes since 1.1: +2 -0 lines
Add Id to top of spec

1 slords 1.2 # $Id$
2    
3 slords 1.1 #
4     # RPM spec file for Dan Bernstein's qmailanalog package
5     #
6     # $Id: qmailanalog.spec,v 1.3 2005/07/28 02:29:50 charlieb Exp $
7     #
8     Summary: A collection of tools to help you analyze qmail's activity record.
9     %define name qmailanalog
10     Name: %{name}
11     %define version 0.70
12     %define release 7
13     Version: %{version}
14     Release: %{release}%{?dist}
15     License: Daniel J. Bernstein - http://cr.yp.to/distributors.html
16     Group: Networking/Daemons
17     Source: http://cr.yp.to/software/%{name}-%{version}.tar.gz
18     URL: http://cr.yp.to/%{name}.html
19     Patch0: %{name}-%{version}.patch.2001020500
20     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
21     Provides: qmailanalog
22     AutoReqProv: no
23     BuildRequires: groff
24    
25     %description
26     qmailanalog is a collection of tools to help you analyze qmail's activity
27     record. It supplies statistics to answer a wide variety of questions:
28    
29     - overall: how many messages? recipients? attempts? etc.
30     - ddist: how soon were 50% of the messages delivered? 90%? 95%? 99%?
31     - rxdelay: what's the best order of recipients for mailing lists?
32     - recipients, rhosts: who's getting mail? bytes? messages? attempts?
33     - successes, failures, deferrals: why? how often? how much delay?
34     - senders, suids: messages? bytes? load? recipients? attempts? delay?
35    
36     qmailanalog also includes several tools to focus attention on particular
37     senders, recipients, or messages.
38    
39     %changelog
40     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
41     - Clean up spec so package can be built by koji/plague
42    
43     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
44     - Update to new release naming. No functional changes.
45     - Make Packager generic
46    
47     * Tue Dec 20 2005 Charlie Brady <charlieb@e-smith.com> 0.70-06
48     - Change obsolete Copyright tag to a License tag, and include
49     URL to DJB's information for distributors.
50    
51     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au>
52     - Bump release number only
53    
54     * Fri Mar 18 2005 Charlie Brady <charlieb@e-smith.com>
55     - [0.70-04]
56     - Add workaround for glibc errno bug.
57    
58     * Mon Feb 5 2001 Peter Samuel <peters@e-smith.com>
59     - [0.70-03]
60     - Now installs in its own root area prior to creating binary RPM.
61     - Default installation locations are restored.
62    
63     * Wed Aug 16 2000 Peter Samuel <peters@e-smith.com>
64     - [0.70-2]
65     - added patch to change default install location
66    
67     * Fri Jun 16 2000 Peter Samuel <Peter.Samuel@gormand.com.au>
68     - [0.70-1]
69     - Initial build
70    
71     %prep
72     %setup
73    
74     # This patch allows files to be installed in a relative directory prior
75     # to creating the binary RPM. It does not change the files or their
76     # final installed locations.
77    
78     %patch0 -p1
79    
80     # Create the relative installation directory.
81    
82     mkdir -p ./root/usr/local
83     # Workaround glibc errno bug
84     echo gcc -O --include /usr/include/errno.h > conf-cc
85    
86     %build
87     make
88    
89     %install
90     make setup
91     make check
92     rm -rf $RPM_BUILD_ROOT
93     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
94    
95     %clean
96     rm -rf $RPM_BUILD_ROOT
97    
98     %files
99     %attr(755,root,root) /usr/local/qmailanalog/bin/columnt
100     %attr(755,root,root) /usr/local/qmailanalog/bin/ddist
101     %attr(755,root,root) /usr/local/qmailanalog/bin/deferrals
102     %attr(755,root,root) /usr/local/qmailanalog/bin/failures
103     %attr(755,root,root) /usr/local/qmailanalog/bin/matchup
104     %attr(755,root,root) /usr/local/qmailanalog/bin/recipients
105     %attr(755,root,root) /usr/local/qmailanalog/bin/rhosts
106     %attr(755,root,root) /usr/local/qmailanalog/bin/rxdelay
107     %attr(755,root,root) /usr/local/qmailanalog/bin/senders
108     %attr(755,root,root) /usr/local/qmailanalog/bin/successes
109     %attr(755,root,root) /usr/local/qmailanalog/bin/suids
110     %attr(755,root,root) /usr/local/qmailanalog/bin/xqp
111     %attr(755,root,root) /usr/local/qmailanalog/bin/xrecipient
112     %attr(755,root,root) /usr/local/qmailanalog/bin/xsender
113     %attr(755,root,root) /usr/local/qmailanalog/bin/zddist
114     %attr(755,root,root) /usr/local/qmailanalog/bin/zdeferrals
115     %attr(755,root,root) /usr/local/qmailanalog/bin/zfailures
116     %attr(755,root,root) /usr/local/qmailanalog/bin/zoverall
117     %attr(755,root,root) /usr/local/qmailanalog/bin/zrecipients
118     %attr(755,root,root) /usr/local/qmailanalog/bin/zrhosts
119     %attr(755,root,root) /usr/local/qmailanalog/bin/zrxdelay
120     %attr(755,root,root) /usr/local/qmailanalog/bin/zsenders
121     %attr(755,root,root) /usr/local/qmailanalog/bin/zsendmail
122     %attr(755,root,root) /usr/local/qmailanalog/bin/zsuccesses
123     %attr(755,root,root) /usr/local/qmailanalog/bin/zsuids
124     %attr(644,root,root) /usr/local/qmailanalog/doc/ACCOUNTING
125     %attr(644,root,root) /usr/local/qmailanalog/doc/MATCHUP
126     %attr(644,root,root) /usr/local/qmailanalog/man/cat1/columnt.0
127     %attr(644,root,root) /usr/local/qmailanalog/man/cat1/matchup.0
128     %attr(644,root,root) /usr/local/qmailanalog/man/cat1/xqp.0
129     %attr(644,root,root) /usr/local/qmailanalog/man/cat1/xrecipient.0
130     %attr(644,root,root) /usr/local/qmailanalog/man/cat1/xsender.0
131     %attr(644,root,root) /usr/local/qmailanalog/man/man1/columnt.1
132     %attr(644,root,root) /usr/local/qmailanalog/man/man1/matchup.1
133     %attr(644,root,root) /usr/local/qmailanalog/man/man1/xqp.1
134     %attr(644,root,root) /usr/local/qmailanalog/man/man1/xrecipient.1
135     %attr(644,root,root) /usr/local/qmailanalog/man/man1/xsender.1

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed