1 |
# $Id$ |
2 |
|
3 |
Summary: qpsmtpd plugins from www.openfusion.com |
4 |
%define name qpsmtpd-plugins |
5 |
Name: %{name} |
6 |
%define version 0.0.1 |
7 |
%define release 3 |
8 |
Version: %{version} |
9 |
Release: %{release}%{?dist} |
10 |
License: qpsmtpd |
11 |
Group: Networking/Daemons |
12 |
%define oname qpsmtpd-plugins-openfusion |
13 |
%define oversion 20050429 |
14 |
Source0: http://www.openfusion.com.au/labs/qpsmtpd/%{oname}-%{oversion}.tar.gz |
15 |
Patch0: check_goodrcptto_hypens.patch |
16 |
Patch1: check_goodrcptto_dos2unix.patch |
17 |
Patch2: check_goodrcptto_relaydenycomment.patch |
18 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
Requires: perl |
20 |
Obsoletes: qpsmtpd-plugins-openfusion |
21 |
Requires: qpsmtpd >= 0.31 |
22 |
BuildArchitectures: noarch |
23 |
AutoReqProv: no |
24 |
|
25 |
%description |
26 |
A package containing qpsmtpd plugins. |
27 |
|
28 |
Included in this version is a set of qpsmtpd plugins from Gavin Carr |
29 |
of OpenFusion: |
30 |
http://www.openfusion.com.au/labs/qpsmtpd/ |
31 |
|
32 |
%changelog |
33 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
34 |
- Clean up spec so package can be built by koji/plague |
35 |
|
36 |
* Thu Apr 12 2007 Stephen Noble <support@dungog.net> 0.0.1-3 |
37 |
- change invalid recipient comment to relay denied [SME: 2340] |
38 |
|
39 |
* Thu Apr 12 2007 Stephen Noble <support@dungog.net> 0.0.1-2 |
40 |
- run dos2unix on check_goodrcptto [SME: 2340] |
41 |
|
42 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
43 |
- Update to new release naming. No functional changes. |
44 |
- Make Packager generic |
45 |
|
46 |
* Fri Aug 18 2006 Gordon Rowell <gordonr@gormand.com.au> 0.0.1-sme06 |
47 |
- Fix check_goodrcptto handling of hyphenated usernames. |
48 |
Thanks Shad Lords [SME: 1268] |
49 |
|
50 |
* Wed Jan 4 2006 Gordon Rowell <gordonr@gormand.com.au> 0.0.1-sme05 |
51 |
- Bump version number only for rebuild |
52 |
|
53 |
* Mon Aug 29 2005 Gordon Rowell <gordonr@gormand.com.au> 0.0.1-sme04 |
54 |
- Updated qpsmtpd requires to 0.31 |
55 |
- Move plugins to /usr/share/qpsmtpd/plugins in line with Peter Holtzer's |
56 |
qpsmtpd RPMs |
57 |
|
58 |
* Mon Aug 15 2005 Charlie Brady <charlieb@e-smith.com> 0.0.1-sme03 |
59 |
- Rename to generic qpsmtpd-plugins (although currently only contains |
60 |
plugins sourced from openfusion). |
61 |
|
62 |
* Fri Apr 29 2005 Gordon Rowell <gordonr@gormand.com.au> 0.0.1-sme02 |
63 |
- Removed denysoft_greylist - it's in 0.29 - thanks Gavin |
64 |
|
65 |
* Fri Apr 29 2005 Gordon Rowell <gordonr@gormand.com.au> 0.0.1-sme01 |
66 |
- Initial packaging |
67 |
- Plugins in /usr/lib/qpsmtpd/plugins |
68 |
|
69 |
%prep |
70 |
%setup -n %{oname}-%{oversion} |
71 |
%patch0 -p1 |
72 |
%patch1 -p1 |
73 |
%patch2 -p1 |
74 |
|
75 |
%build |
76 |
mkdir -p root/usr/share/qpsmtpd |
77 |
mkdir -p root/usr/bin |
78 |
|
79 |
mv plugins config.sample root/usr/share/qpsmtpd |
80 |
|
81 |
%postun |
82 |
|
83 |
%install |
84 |
rm -rf $RPM_BUILD_ROOT |
85 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
86 |
find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | \ |
87 |
grep -v perllocal.pod > %{name}-%{version}-%{release}-filelist |
88 |
|
89 |
echo "%doc LICENSE" >> %{name}-%{version}-%{release}-filelist |
90 |
|
91 |
%clean |
92 |
rm -rf $RPM_BUILD_ROOT |
93 |
|
94 |
%files -f %{name}-%{version}-%{release}-filelist |
95 |
%defattr(-,root,root) |