/[smeserver]/rpms/rkhunter/sme7/rkhunter.spec
ViewVC logotype

Annotation of /rpms/rkhunter/sme7/rkhunter.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.14 - (hide annotations) (download)
Tue Apr 7 07:30:35 2009 UTC (15 years, 2 months ago) by snetram
Branch: MAIN
CVS Tags: rkhunter-1_3_4-7_el4_sme
Changes since 1.13: +5 -2 lines
* Tue Apr 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 1.3.4-7
- Remove quotes in DISABLE_TESTS setting [SME: 5149]

1 snetram 1.14 # $Id: rkhunter.spec,v 1.13 2009/04/02 18:01:19 slords Exp $
2 slords 1.12
3 slords 1.13 Name: rkhunter
4     Version: 1.3.4
5 snetram 1.14 Release: 7%{?dist}
6 slords 1.13 Summary: A host-based tool to scan for rootkits, backdoors and local exploits
7    
8     Group: Applications/System
9     License: GPLv2+
10     URL: http://rkhunter.sourceforge.net/
11     Source0: http://downloads.sourceforge.net/rkhunter/rkhunter-%{version}.tar.gz
12     Source1: http://downloads.sourceforge.net/rkhunter/rkhunter-%{version}.tar.gz.sha1.txt
13     Source2: 01-rkhunter
14     Source3: rkhunter.sysconfig
15     Patch0: rkhunter-1.3.4-smeconfig.patch
16     BuildArch: noarch
17     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18    
19     Requires: coreutils, binutils, modutils, findutils, grep, mktemp
20     Requires: e2fsprogs, procps, lsof, prelink, iproute, net-tools, wget
21     Requires: perl, perl(strict), perl(IO::Socket), mailx, logrotate
22 slords 1.1
23     %description
24 slords 1.13 Rootkit Hunter (RKH) is an easy-to-use tool which checks
25     computers running UNIX (clones) for the presence of rootkits
26     and other unwanted tools.
27 slords 1.1
28 slords 1.13 %prep
29 slords 1.1
30 slords 1.13 %setup -q
31 slords 1.1
32 slords 1.2 %patch0 -p1
33 slords 1.13
34     %{__cat} <<'EOF' >%{name}.logrotate
35     %{_localstatedir}/log/%{name}/%{name}.log {
36     weekly
37     notifempty
38     create 640 root root
39     }
40     EOF
41 slords 1.1
42     %build
43 slords 1.13 # Nothing to be built
44 slords 1.1
45     %install
46 slords 1.13 %{__rm} -rf $RPM_BUILD_ROOT
47 slords 1.9
48 slords 1.13 %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_bindir}
49     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{cron.daily,sysconfig,logrotate.d}
50     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts
51     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
52     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_mandir}/man8
53     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db
54     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/run/%{name}
55     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/log/%{name}
56     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n
57    
58     %{__install} -m755 -p files/%{name} ${RPM_BUILD_ROOT}%{_bindir}/
59    
60     %{__install} -m644 -p files/backdoorports.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
61     %{__install} -m644 -p files/defaulthashes.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
62     %{__install} -m644 -p files/md5blacklist.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
63     %{__install} -m644 -p files/mirrors.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
64     %{__install} -m644 -p files/os.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
65     %{__install} -m644 -p files/programs_bad.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
66     %{__install} -m644 -p files/programs_good.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
67     %{__install} -m644 -p files/i18n/cn ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n/
68     %{__install} -m644 -p files/i18n/en ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n/
69    
70     %{__install} -m644 -p files/CHANGELOG ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
71     %{__install} -m644 -p files/LICENSE ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
72     %{__install} -m644 -p files/README ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
73     %{__install} -m644 -p files/WISHLIST ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
74     %{__install} -m755 -p files/check_modules.pl ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
75     %{__install} -m755 -p files/check_port.pl ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
76     %{__install} -m755 -p files/check_update.sh ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
77     %{__install} -m644 -p files/*.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
78     # Don't ship these unless we want to Require the perl modules
79     #%{__install} -m750 -p files/filehashmd5.pl ${RPM_BUILD_ROOT}%{_prefix}/lib/%{name}/scripts/
80     #%{__install} -m750 -p files/filehashsha1.pl ${RPM_BUILD_ROOT}%{_prefix}/lib/%{name}/scripts/
81     %{__install} -m755 -p files/showfiles.pl ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
82     %{__install} -m755 -p %{SOURCE2} ${RPM_BUILD_ROOT}%{_sysconfdir}/cron.daily/%{name}
83     %{__install} -m644 -p %{name}.logrotate ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d/%{name}
84     %{__install} -m640 -p files/%{name}.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/
85     %{__install} -m640 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/%{name}
86 slords 1.1
87 slords 1.13 %clean
88     %{__rm} -rf $RPM_BUILD_ROOT
89 slords 1.1
90 slords 1.2 %post
91     # Only do this on an initial install
92     if [ $1 -eq 1 ]; then
93 slords 1.13 %{__cp} -p /etc/passwd /var/lib/rkhunter/ >/dev/null 2>&1 || :
94     %{__cp} -p /etc/group /var/lib/rkhunter/ >/dev/null 2>&1 || :
95 slords 1.2 fi
96 slords 1.1
97 slords 1.2 %files
98 slords 1.13 %defattr(-,root,root,-)
99     %doc %{_docdir}/%{name}-%{version}/*
100     %{_bindir}/%{name}
101     %dir %{_datadir}/%{name}
102     %{_datadir}/%{name}/scripts
103     %{_sysconfdir}/cron.daily/%{name}
104     %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
105     %dir %{_var}/lib/%{name}
106     %{_var}/lib/%{name}/db
107     %{_var}/lib/%{name}/db/i18n
108     %dir %{_var}/run/%{name}
109     %dir %{_var}/log/%{name}
110     %config(noreplace) %{_sysconfdir}/%{name}.conf
111     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
112     %dir %{_docdir}/%{name}-%{version}
113     %{_mandir}/man8/*
114 slords 1.1
115 slords 1.2 %changelog
116 snetram 1.14 * Tue Apr 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 1.3.4-7
117     - Remove quotes in DISABLE_TESTS setting [SME: 5149]
118    
119 slords 1.13 * Thu Apr 2 2009 Shad L. Lords <slords@mail.com> 1.3.4-6
120     - Update to epel version of rkhunter
121 slords 1.3 - Set parameters for sme specific tests
122 slords 1.1
123 slords 1.13 * Sun Mar 08 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-5
124     - Fix typo in patch file
125 slords 1.1
126 slords 1.13 * Wed Mar 04 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-4
127     - Rework spec file
128     - Add check for the new hmac ssh files
129    
130     * Thu Feb 26 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-3
131     - Update cron job to include hostname (thanks Manuel Wolfshant)
132    
133     * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-2
134     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
135    
136     * Fri Jan 02 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-1
137     - Update to 1.3.4
138     - Use libdir as tmp dir - bug #456340
139    
140     * Sat Dec 13 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-6
141     - Fix cron job sending as attachment - bug #472679
142     - Fix cron job trying to send with colors - bug #475916
143    
144     * Wed Sep 03 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-5
145     - Patch debug tmp file issue - bug #460628
146    
147     * Mon Jun 16 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-4
148     - Fix cron script to only mail on warn/error - bug #450703
149     - Fix conditional to account for fc10 rsyslog
150    
151     * Mon Apr 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-3
152     - Change cron to run after prelink - bug #438622
153    
154     * Wed Mar 26 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-2
155     - Move things to more standard locations for selinux - bug #438184
156     - Add exception for pulseaudio file - bug #438622
157    
158     * Thu Feb 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-1
159     - Update to 1.3.2
160     - Fix cron script
161    
162     * Thu Feb 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.0-2
163     - Use /etc/redhat-release for EPEL and /etc/fedora release for Fedora.
164     - Add conditionals to support EPEL
165     - Fix man page warning.
166    
167     * Sun Feb 03 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.0-1
168     - Revive package, clean up spec
169     - Update to 1.3.0
170    
171     * Sat Mar 18 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-3
172     - Made an RPM transparent change to move the sha1 canary check
173     file out of CVS and into the external lookaside cache (whose
174     filename changes with every new package release anyway...)
175    
176     * Fri Mar 17 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-2
177     - Fixed architectural dependency during package creation eliminating
178     use of _libdir configure macro (x86_64 /usr/lib64 mis-targeting)
179    
180     * Tue Mar 7 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-1
181     - New package version release
182     - reworked the .spec file to support optional dist tag
183     - Updated the application check default patchfile (chunk failure)
184     - Changed to SHA1 for optional message digest (canary check)
185     - Added a couple of suggested skip entries to rkhunter.conf
186    
187     * Mon Jun 11 2005 Greg Houlette <tamaster@pobox.com> - 1.2.7-1
188     - Added signature auto-updating to CRON scan (new script)
189     - Removed BOOTSCAN pending rewrite to full SysV Init scan in background
190     - Added the --append-log command line option
191     - Added Date Stamping to output
192     - Fixed bug in /etc/group missing report
193     - New package version release
194    
195     * Sun Jan 2 2005 Greg Houlette <tamaster@tekarmory.com> - 0:1.1.9-1
196     - New package version release
197     - Added the --run-application-check command line option
198     to listing in command help
199     - Replaced 'Here' Doc editing of rkhunter.conf file
200     with in-place Perl edit
201     - tweaked rpmbuild -bb Autoclean
202    
203     * Fri Oct 15 2004 Greg Houlette - 0:1.1.8-0.fdr.1 (revisited)
204     - Removed redundant buildrequires /bin/sh, coreutils and perl
205     - Revise postun scriptlet
206     - Added /usr/share/doc/rkhunter-1.1.8/ to files list
207    
208     * Mon Oct 11 2004 Greg Houlette - 0:1.1.8-0.fdr.1
209     - Changed Release Tag to 0.fdr.1 (testing) for QA
210     - Removed wget from dependencies
211     - Hid (temporarily) the --skip-application-check command
212     line option from being listed in help
213     - Fixed the spec files list, again!
214    
215     * Fri Oct 8 2004 Greg Houlette - 0:1.1.8-0.fdr.0.2.beta2
216     - Unified and disabled the md5 canary check in prep
217     (check is now optional) removing the sha1 cross-check
218     - Fixed the spec files list, adding the /var/rkhunter
219     directory and the /usr/bin/rkhunter executable
220     - Fixed missing dependencies (rkh uses runtime checks)
221     - Disabled "auto-clean" for rpmbuild -bb
222     - Changed Application version scan default to
223     disabled awaiting backport fix in upstream sources
224     - Fixed shared_man_search.patch, configuration files
225     verify and added postun(install) cleanup
226    
227     * Fri Oct 1 2004 Greg Houlette - 0:1.1.8-0.fdr.0.1.beta1
228     - More cosmetic patchwork
229     - Changed Release Tag to beta1 (pre-release) for QA submit
230    
231     * Tue Sep 28 2004 Greg Houlette - 0:1.1.8-0.fdr.1
232     - Removed hidden_search.patch (1.1.7) after it was
233     merged into upstream source by Michael Boelen
234     - Removed .spec file from md5 and sha1 file checks
235     (it must be modifiable by Fedora QA release build)
236     - Added BOOTSCAN description file to documentation
237     - Restructured dynamic file creation ('Here' Docs)
238     moving them to the "prep" stage so that *_ALL_*
239     files are available prior to the "build" stage
240     (for inspection purposes)
241     - Added a /etc/sysconfig/rkhunter parameters file
242    
243     * Sun Aug 29 2004 Greg Houlette - 0:1.1.7-0.fdr.1
244     - Cosmetic patchwork
245    
246     * Sat Aug 21 2004 Greg Houlette - 0:1.1.6-0.fdr.1
247     - Moderate reworking of .spec file for packaging standards
248     - Added md5 and sha1 file checks to prep procedure for source .rpm
249     - Included an optional rc.local replacement for scan on boot (with full logging)
250 slords 1.1
251     * Tue Aug 10 2004 Michael Boelen - 1.1.5
252     - Added update script
253     - Extended description
254    
255     * Sun Aug 08 2004 Greg Houlette - 1.1.5
256     - Changed the install procedure eliminating the specification of
257     destination filenames (only needed if you are renaming during install)
258     - Changed the permissions for documentation files (root only overkill)
259     - Added the installation of the rkhunter Man Page
260     - Added the installation of the programs_{bad, good}.dat database files
261     - Added the installation of the LICENSE documentation file
262     - Added the chmod for root only to the /var/rkhunter/db directory
263    
264     * Sun May 23 2004 Craig Orsinger (cjo) <cjorsinger@earthlink.net>
265     - version 1.1.0-1.cjo
266     - changed installation in accordance with new rootkit installation
267     procedure
268     - changed installation root to conform to LSB. Use standard macros.
269     - added recursive remove of old build root as prep for install phase
270    
271     * Wed Apr 28 2004 Doncho N. Gunchev - 1.0.9-0.mr700
272     - dropped Requires: perl - rkhunter works without it
273     - dropped the bash alignpatch (check the source or contact me)
274     - various file mode fixes (.../tmp/, *.db)
275     - optimized the %%files section - any new files in the
276     current dirs will be fine - just %%{__install} them.
277    
278     * Mon Apr 26 2004 Michael Boelen - 1.0.8-0
279     - Fixed missing md5blacklist.dat
280    
281     * Mon Apr 19 2004 Doncho N. Gunchev - 1.0.6-1.mr700
282     - added missing /usr/local/rkhunter/db/md5blacklist.dat
283     - patched to align results in --cronjob, I think rpm based
284     distros have symlink /bin/sh -> /bin/bash
285     - added --with/--without alignpatch for conditional builds
286     (in case previous patch breaks something)
287    
288     * Sat Apr 03 2004 Michael Boelen / Joe Klemmer - 1.0.6-0
289     - Update to 1.0.6
290    
291     * Mon Mar 29 2004 Doncho N. Gunchev - 1.0.0-0
292     - initial .spec file

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed