/[smeserver]/rpms/rkhunter/sme7/rkhunter.spec
ViewVC logotype

Annotation of /rpms/rkhunter/sme7/rkhunter.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.15 - (hide annotations) (download)
Thu May 14 17:10:05 2009 UTC (15 years ago) by snetram
Branch: MAIN
CVS Tags: rkhunter-1_3_4-8_el4_sme, HEAD
Changes since 1.14: +5 -2 lines
* Thu May 14 2009 Jonathan Martens <smeserver-contribs@snetram.nl>
- Bump version number in order to move package to SME Contribs [SME: 5172]

1 snetram 1.15 # $Id: rkhunter.spec,v 1.14 2009/04/07 07:30:35 snetram Exp $
2 slords 1.12
3 slords 1.13 Name: rkhunter
4     Version: 1.3.4
5 snetram 1.15 Release: 8%{?dist}
6 slords 1.13 Summary: A host-based tool to scan for rootkits, backdoors and local exploits
7    
8     Group: Applications/System
9     License: GPLv2+
10     URL: http://rkhunter.sourceforge.net/
11     Source0: http://downloads.sourceforge.net/rkhunter/rkhunter-%{version}.tar.gz
12     Source1: http://downloads.sourceforge.net/rkhunter/rkhunter-%{version}.tar.gz.sha1.txt
13     Source2: 01-rkhunter
14     Source3: rkhunter.sysconfig
15     Patch0: rkhunter-1.3.4-smeconfig.patch
16     BuildArch: noarch
17     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18    
19     Requires: coreutils, binutils, modutils, findutils, grep, mktemp
20     Requires: e2fsprogs, procps, lsof, prelink, iproute, net-tools, wget
21     Requires: perl, perl(strict), perl(IO::Socket), mailx, logrotate
22 slords 1.1
23     %description
24 slords 1.13 Rootkit Hunter (RKH) is an easy-to-use tool which checks
25     computers running UNIX (clones) for the presence of rootkits
26     and other unwanted tools.
27 slords 1.1
28 slords 1.13 %prep
29 slords 1.1
30 slords 1.13 %setup -q
31 slords 1.1
32 slords 1.2 %patch0 -p1
33 slords 1.13
34     %{__cat} <<'EOF' >%{name}.logrotate
35     %{_localstatedir}/log/%{name}/%{name}.log {
36     weekly
37     notifempty
38     create 640 root root
39     }
40     EOF
41 slords 1.1
42     %build
43 slords 1.13 # Nothing to be built
44 slords 1.1
45     %install
46 slords 1.13 %{__rm} -rf $RPM_BUILD_ROOT
47 slords 1.9
48 slords 1.13 %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_bindir}
49     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{cron.daily,sysconfig,logrotate.d}
50     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts
51     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
52     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_mandir}/man8
53     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db
54     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/run/%{name}
55     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/log/%{name}
56     %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n
57    
58     %{__install} -m755 -p files/%{name} ${RPM_BUILD_ROOT}%{_bindir}/
59    
60     %{__install} -m644 -p files/backdoorports.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
61     %{__install} -m644 -p files/defaulthashes.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
62     %{__install} -m644 -p files/md5blacklist.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
63     %{__install} -m644 -p files/mirrors.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
64     %{__install} -m644 -p files/os.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
65     %{__install} -m644 -p files/programs_bad.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
66     %{__install} -m644 -p files/programs_good.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
67     %{__install} -m644 -p files/i18n/cn ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n/
68     %{__install} -m644 -p files/i18n/en ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n/
69    
70     %{__install} -m644 -p files/CHANGELOG ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
71     %{__install} -m644 -p files/LICENSE ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
72     %{__install} -m644 -p files/README ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
73     %{__install} -m644 -p files/WISHLIST ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
74     %{__install} -m755 -p files/check_modules.pl ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
75     %{__install} -m755 -p files/check_port.pl ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
76     %{__install} -m755 -p files/check_update.sh ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
77     %{__install} -m644 -p files/*.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
78     # Don't ship these unless we want to Require the perl modules
79     #%{__install} -m750 -p files/filehashmd5.pl ${RPM_BUILD_ROOT}%{_prefix}/lib/%{name}/scripts/
80     #%{__install} -m750 -p files/filehashsha1.pl ${RPM_BUILD_ROOT}%{_prefix}/lib/%{name}/scripts/
81     %{__install} -m755 -p files/showfiles.pl ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
82     %{__install} -m755 -p %{SOURCE2} ${RPM_BUILD_ROOT}%{_sysconfdir}/cron.daily/%{name}
83     %{__install} -m644 -p %{name}.logrotate ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d/%{name}
84     %{__install} -m640 -p files/%{name}.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/
85     %{__install} -m640 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/%{name}
86 slords 1.1
87 slords 1.13 %clean
88     %{__rm} -rf $RPM_BUILD_ROOT
89 slords 1.1
90 slords 1.2 %post
91     # Only do this on an initial install
92     if [ $1 -eq 1 ]; then
93 slords 1.13 %{__cp} -p /etc/passwd /var/lib/rkhunter/ >/dev/null 2>&1 || :
94     %{__cp} -p /etc/group /var/lib/rkhunter/ >/dev/null 2>&1 || :
95 slords 1.2 fi
96 slords 1.1
97 slords 1.2 %files
98 slords 1.13 %defattr(-,root,root,-)
99     %doc %{_docdir}/%{name}-%{version}/*
100     %{_bindir}/%{name}
101     %dir %{_datadir}/%{name}
102     %{_datadir}/%{name}/scripts
103     %{_sysconfdir}/cron.daily/%{name}
104     %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
105     %dir %{_var}/lib/%{name}
106     %{_var}/lib/%{name}/db
107     %{_var}/lib/%{name}/db/i18n
108     %dir %{_var}/run/%{name}
109     %dir %{_var}/log/%{name}
110     %config(noreplace) %{_sysconfdir}/%{name}.conf
111     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
112     %dir %{_docdir}/%{name}-%{version}
113     %{_mandir}/man8/*
114 slords 1.1
115 slords 1.2 %changelog
116 snetram 1.15 * Thu May 14 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 1.3.4-8
117     - Bump version number in order to move package to SME Contribs [SME: 5172]
118    
119 snetram 1.14 * Tue Apr 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 1.3.4-7
120     - Remove quotes in DISABLE_TESTS setting [SME: 5149]
121    
122 slords 1.13 * Thu Apr 2 2009 Shad L. Lords <slords@mail.com> 1.3.4-6
123     - Update to epel version of rkhunter
124 slords 1.3 - Set parameters for sme specific tests
125 slords 1.1
126 slords 1.13 * Sun Mar 08 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-5
127     - Fix typo in patch file
128 slords 1.1
129 slords 1.13 * Wed Mar 04 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-4
130     - Rework spec file
131     - Add check for the new hmac ssh files
132    
133     * Thu Feb 26 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-3
134     - Update cron job to include hostname (thanks Manuel Wolfshant)
135    
136     * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-2
137     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
138    
139     * Fri Jan 02 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-1
140     - Update to 1.3.4
141     - Use libdir as tmp dir - bug #456340
142    
143     * Sat Dec 13 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-6
144     - Fix cron job sending as attachment - bug #472679
145     - Fix cron job trying to send with colors - bug #475916
146    
147     * Wed Sep 03 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-5
148     - Patch debug tmp file issue - bug #460628
149    
150     * Mon Jun 16 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-4
151     - Fix cron script to only mail on warn/error - bug #450703
152     - Fix conditional to account for fc10 rsyslog
153    
154     * Mon Apr 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-3
155     - Change cron to run after prelink - bug #438622
156    
157     * Wed Mar 26 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-2
158     - Move things to more standard locations for selinux - bug #438184
159     - Add exception for pulseaudio file - bug #438622
160    
161     * Thu Feb 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-1
162     - Update to 1.3.2
163     - Fix cron script
164    
165     * Thu Feb 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.0-2
166     - Use /etc/redhat-release for EPEL and /etc/fedora release for Fedora.
167     - Add conditionals to support EPEL
168     - Fix man page warning.
169    
170     * Sun Feb 03 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.0-1
171     - Revive package, clean up spec
172     - Update to 1.3.0
173    
174     * Sat Mar 18 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-3
175     - Made an RPM transparent change to move the sha1 canary check
176     file out of CVS and into the external lookaside cache (whose
177     filename changes with every new package release anyway...)
178    
179     * Fri Mar 17 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-2
180     - Fixed architectural dependency during package creation eliminating
181     use of _libdir configure macro (x86_64 /usr/lib64 mis-targeting)
182    
183     * Tue Mar 7 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-1
184     - New package version release
185     - reworked the .spec file to support optional dist tag
186     - Updated the application check default patchfile (chunk failure)
187     - Changed to SHA1 for optional message digest (canary check)
188     - Added a couple of suggested skip entries to rkhunter.conf
189    
190     * Mon Jun 11 2005 Greg Houlette <tamaster@pobox.com> - 1.2.7-1
191     - Added signature auto-updating to CRON scan (new script)
192     - Removed BOOTSCAN pending rewrite to full SysV Init scan in background
193     - Added the --append-log command line option
194     - Added Date Stamping to output
195     - Fixed bug in /etc/group missing report
196     - New package version release
197    
198     * Sun Jan 2 2005 Greg Houlette <tamaster@tekarmory.com> - 0:1.1.9-1
199     - New package version release
200     - Added the --run-application-check command line option
201     to listing in command help
202     - Replaced 'Here' Doc editing of rkhunter.conf file
203     with in-place Perl edit
204     - tweaked rpmbuild -bb Autoclean
205    
206     * Fri Oct 15 2004 Greg Houlette - 0:1.1.8-0.fdr.1 (revisited)
207     - Removed redundant buildrequires /bin/sh, coreutils and perl
208     - Revise postun scriptlet
209     - Added /usr/share/doc/rkhunter-1.1.8/ to files list
210    
211     * Mon Oct 11 2004 Greg Houlette - 0:1.1.8-0.fdr.1
212     - Changed Release Tag to 0.fdr.1 (testing) for QA
213     - Removed wget from dependencies
214     - Hid (temporarily) the --skip-application-check command
215     line option from being listed in help
216     - Fixed the spec files list, again!
217    
218     * Fri Oct 8 2004 Greg Houlette - 0:1.1.8-0.fdr.0.2.beta2
219     - Unified and disabled the md5 canary check in prep
220     (check is now optional) removing the sha1 cross-check
221     - Fixed the spec files list, adding the /var/rkhunter
222     directory and the /usr/bin/rkhunter executable
223     - Fixed missing dependencies (rkh uses runtime checks)
224     - Disabled "auto-clean" for rpmbuild -bb
225     - Changed Application version scan default to
226     disabled awaiting backport fix in upstream sources
227     - Fixed shared_man_search.patch, configuration files
228     verify and added postun(install) cleanup
229    
230     * Fri Oct 1 2004 Greg Houlette - 0:1.1.8-0.fdr.0.1.beta1
231     - More cosmetic patchwork
232     - Changed Release Tag to beta1 (pre-release) for QA submit
233    
234     * Tue Sep 28 2004 Greg Houlette - 0:1.1.8-0.fdr.1
235     - Removed hidden_search.patch (1.1.7) after it was
236     merged into upstream source by Michael Boelen
237     - Removed .spec file from md5 and sha1 file checks
238     (it must be modifiable by Fedora QA release build)
239     - Added BOOTSCAN description file to documentation
240     - Restructured dynamic file creation ('Here' Docs)
241     moving them to the "prep" stage so that *_ALL_*
242     files are available prior to the "build" stage
243     (for inspection purposes)
244     - Added a /etc/sysconfig/rkhunter parameters file
245    
246     * Sun Aug 29 2004 Greg Houlette - 0:1.1.7-0.fdr.1
247     - Cosmetic patchwork
248    
249     * Sat Aug 21 2004 Greg Houlette - 0:1.1.6-0.fdr.1
250     - Moderate reworking of .spec file for packaging standards
251     - Added md5 and sha1 file checks to prep procedure for source .rpm
252     - Included an optional rc.local replacement for scan on boot (with full logging)
253 slords 1.1
254     * Tue Aug 10 2004 Michael Boelen - 1.1.5
255     - Added update script
256     - Extended description
257    
258     * Sun Aug 08 2004 Greg Houlette - 1.1.5
259     - Changed the install procedure eliminating the specification of
260     destination filenames (only needed if you are renaming during install)
261     - Changed the permissions for documentation files (root only overkill)
262     - Added the installation of the rkhunter Man Page
263     - Added the installation of the programs_{bad, good}.dat database files
264     - Added the installation of the LICENSE documentation file
265     - Added the chmod for root only to the /var/rkhunter/db directory
266    
267     * Sun May 23 2004 Craig Orsinger (cjo) <cjorsinger@earthlink.net>
268     - version 1.1.0-1.cjo
269     - changed installation in accordance with new rootkit installation
270     procedure
271     - changed installation root to conform to LSB. Use standard macros.
272     - added recursive remove of old build root as prep for install phase
273    
274     * Wed Apr 28 2004 Doncho N. Gunchev - 1.0.9-0.mr700
275     - dropped Requires: perl - rkhunter works without it
276     - dropped the bash alignpatch (check the source or contact me)
277     - various file mode fixes (.../tmp/, *.db)
278     - optimized the %%files section - any new files in the
279     current dirs will be fine - just %%{__install} them.
280    
281     * Mon Apr 26 2004 Michael Boelen - 1.0.8-0
282     - Fixed missing md5blacklist.dat
283    
284     * Mon Apr 19 2004 Doncho N. Gunchev - 1.0.6-1.mr700
285     - added missing /usr/local/rkhunter/db/md5blacklist.dat
286     - patched to align results in --cronjob, I think rpm based
287     distros have symlink /bin/sh -> /bin/bash
288     - added --with/--without alignpatch for conditional builds
289     (in case previous patch breaks something)
290    
291     * Sat Apr 03 2004 Michael Boelen / Joe Klemmer - 1.0.6-0
292     - Update to 1.0.6
293    
294     * Mon Mar 29 2004 Doncho N. Gunchev - 1.0.0-0
295     - initial .spec file

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed