/[smeserver]/rpms/rkhunter/sme7/rkhunter.spec
ViewVC logotype

Annotation of /rpms/rkhunter/sme7/rkhunter.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Mon Dec 17 16:35:52 2007 UTC (16 years, 5 months ago) by slords
Branch: MAIN
Changes since 1.1: +91 -141 lines
Import on branch sme7 of package rkhunter-1.3.0-1.el4.sme.src.rpm

1 slords 1.2 # No debuginfo:
2     %define debug_package %{nil}
3    
4     # If you want to debug, uncomment the next line and remove
5     # the duplicate percent sign (due to macro expansion)
6     #%%dump
7    
8     %define name rkhunter
9     %define ver 1.3.0
10     %define rel 1
11     %define epoch 0
12    
13     # Don't change this define or also:
14     # 1. installer.sh --layout custom /temporary/dir/usr --striproot /temporary/dir --install
15     # 2. rewrite the files section below.
16     %define _prefix /usr
17    
18 slords 1.1 # We can't let RPM do the dependencies automatic because it'll then pick up
19     # a correct but undesirable perl dependency, which rkhunter does not require
20     # in order to function properly.
21     AutoReqProv: no
22    
23 slords 1.2 Name: %{name}
24     Summary: %{name} scans for rootkits, backdoors and local exploits
25     Version: %{ver}
26     Release: %{rel}%{dist}
27     Epoch: %{epoch}
28     License: GPL
29     Group: Applications/System
30     Source0: %{name}-%{version}.tar.gz
31     Patch0: rkhunter-installer.patch
32     Patch1: rkhunter-sme7.patch
33     BuildArch: noarch
34     Requires: filesystem, bash, grep, findutils, net-tools, coreutils, e2fsprogs, modutils, procps, binutils, wget, perl
35     Provides: %{name}
36     URL: http://rkhunter.sourceforge.net/
37     BuildRoot: %{_tmppath}/%{name}-%{version}
38 slords 1.1
39     %description
40 slords 1.2 Rootkit Hunter is a scanning tool to ensure you are about 99.9%%
41     clean of nasty tools. It scans for rootkits, backdoors and local
42 slords 1.1 exploits by running tests like:
43 slords 1.2 - File hash check
44 slords 1.1 - Look for default files used by rootkits
45     - Wrong file permissions for binaries
46     - Look for suspected strings in LKM and KLD modules
47     - Look for hidden files
48     - Optional scan within plaintext and binary files
49     - Software version checks
50     - Application tests
51    
52     Rootkit Hunter is released as a GPL licensed project and free for everyone to use.
53    
54    
55     %prep
56 slords 1.2 %setup -q
57     %patch0 -p1
58     %patch1 -p1
59 slords 1.1
60     %build
61    
62     %install
63 slords 1.2 sh ./installer.sh --layout RPM --install
64 slords 1.1
65    
66 slords 1.2 # Make a cron.daily file to mail us the reports
67 slords 1.1 %{__mkdir} -p "${RPM_BUILD_ROOT}/%{_sysconfdir}/cron.daily"
68     %{__cat} > "${RPM_BUILD_ROOT}/%{_sysconfdir}/cron.daily/01-rkhunter" <<EOF
69     #!/bin/sh
70 slords 1.2 ( %{_bindir}/rkhunter --cronjob --update --rwo && echo "" ) | /bin/mail -s "Rkhunter daily run on `uname -n`" root
71     exit 0
72 slords 1.1 EOF
73     %{__chmod} a+rwx,g-w,o-rwx ${RPM_BUILD_ROOT}%{_sysconfdir}/cron.daily/01-rkhunter
74    
75    
76 slords 1.2 %post
77     # Only do this on an initial install
78     if [ $1 -eq 1 ]; then
79     %{__cp} -p /etc/passwd /var/lib/rkhunter/tmp >/dev/null 2>&1 || :
80     %{__cp} -p /etc/group /var/lib/rkhunter/tmp >/dev/null 2>&1 || :
81     fi
82 slords 1.1
83    
84 slords 1.2 %preun
85     # Only do this when removing the RPM
86     if [ $1 -eq 0 ]; then
87     %{__rm} -f /var/log/rkhunter.log /var/log/rkhunter.log.old >/dev/null 2>&1
88     %{__rm} -rf /var/lib/rkhunter/* >/dev/null 2>&1
89     fi
90 slords 1.1
91    
92 slords 1.2 %clean
93     if [ "$RPM_BUILD_ROOT" = "/" ]; then
94     echo Invalid Build root \'"$RPM_BUILD_ROOT"\'
95     exit 1
96     else
97     rm -rf $RPM_BUILD_ROOT
98     fi
99 slords 1.1
100    
101 slords 1.2 %define docdir %{_prefix}/share/doc/%{name}-%{version}
102     %files
103     %defattr(-,root,root)
104     %attr(640,root,root) %config(noreplace) %{_sysconfdir}/%{name}.conf
105     %attr(750,root,root) %{_prefix}/bin/%{name}
106     %attr(750,root,root) %dir %{_libdir}/%{name}
107     %attr(750,root,root) %dir %{_libdir}/%{name}/scripts
108     %attr(750,root,root) %{_libdir}/%{name}/scripts/*.pl
109     %attr(750,root,root) %{_libdir}/%{name}/scripts/*.sh
110     %attr(644,root,root) %doc %{_prefix}/share/man/man8/%{name}.8.gz
111     %attr(755,root,root) %dir %{docdir}
112     %attr(644,root,root) %doc %{docdir}/*
113     %attr(750,root,root) %dir %{_var}/lib/%{name}
114     %attr(750,root,root) %dir %{_var}/lib/%{name}/db
115     %attr(640,root,root) %{_var}/lib/%{name}/db/*.dat
116     %attr(750,root,root) %dir %{_var}/lib/%{name}/db/i18n
117     %attr(640,root,root) %{_var}/lib/%{name}/db/i18n/*
118     %attr(750,root,root) %dir %{_var}/lib/%{name}/tmp
119     %{_sysconfdir}/cron.daily/01-rkhunter
120 slords 1.1
121    
122 slords 1.2 %changelog
123     * Mon Dec 17 2007 Shad L. Lords <slords@mail.com> 1.3.0-1
124     - Add sigs for 7.2, 7.3 and 8.0
125     - Fix installer to not install in local
126 slords 1.1
127 slords 1.2 * Sun Feb 11 2007 unSpawn - pre-1.3.0
128     - Sync spec with fixes, installer and CVS
129 slords 1.1
130 slords 1.2 * Sun Nov 12 2006 unSpawn - 1.2.9
131     - Re-spec, new installer
132 slords 1.1
133 slords 1.2 * Fri Sep 29 2006 unSpawn - 1.2.9
134     - Updated for release 1.2.9
135 slords 1.1
136     * Tue Aug 10 2004 Michael Boelen - 1.1.5
137     - Added update script
138     - Extended description
139    
140     * Sun Aug 08 2004 Greg Houlette - 1.1.5
141     - Changed the install procedure eliminating the specification of
142     destination filenames (only needed if you are renaming during install)
143     - Changed the permissions for documentation files (root only overkill)
144     - Added the installation of the rkhunter Man Page
145     - Added the installation of the programs_{bad, good}.dat database files
146     - Added the installation of the LICENSE documentation file
147     - Added the chmod for root only to the /var/rkhunter/db directory
148    
149     * Sun May 23 2004 Craig Orsinger (cjo) <cjorsinger@earthlink.net>
150     - version 1.1.0-1.cjo
151     - changed installation in accordance with new rootkit installation
152     procedure
153     - changed installation root to conform to LSB. Use standard macros.
154     - added recursive remove of old build root as prep for install phase
155    
156     * Wed Apr 28 2004 Doncho N. Gunchev - 1.0.9-0.mr700
157     - dropped Requires: perl - rkhunter works without it
158     - dropped the bash alignpatch (check the source or contact me)
159     - various file mode fixes (.../tmp/, *.db)
160     - optimized the %%files section - any new files in the
161     current dirs will be fine - just %%{__install} them.
162    
163     * Mon Apr 26 2004 Michael Boelen - 1.0.8-0
164     - Fixed missing md5blacklist.dat
165    
166     * Mon Apr 19 2004 Doncho N. Gunchev - 1.0.6-1.mr700
167     - added missing /usr/local/rkhunter/db/md5blacklist.dat
168     - patched to align results in --cronjob, I think rpm based
169     distros have symlink /bin/sh -> /bin/bash
170     - added --with/--without alignpatch for conditional builds
171     (in case previous patch breaks something)
172    
173     * Sat Apr 03 2004 Michael Boelen / Joe Klemmer - 1.0.6-0
174     - Update to 1.0.6
175    
176     * Mon Mar 29 2004 Doncho N. Gunchev - 1.0.0-0
177     - initial .spec file
178    
179 slords 1.2

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed