/[smeserver]/rpms/rkhunter/sme7/rkhunter.spec
ViewVC logotype

Annotation of /rpms/rkhunter/sme7/rkhunter.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Mon Dec 17 22:24:22 2007 UTC (16 years, 5 months ago) by bytegw
Branch: MAIN
CVS Tags: rkhunter-1_3_0-2_el4_sme
Changes since 1.3: +6 -1 lines
Updates

1 slords 1.2 # No debuginfo:
2     %define debug_package %{nil}
3    
4     # If you want to debug, uncomment the next line and remove
5     # the duplicate percent sign (due to macro expansion)
6     #%%dump
7    
8     %define name rkhunter
9     %define ver 1.3.0
10 bytegw 1.4 %define rel 2
11 slords 1.2 %define epoch 0
12    
13     # Don't change this define or also:
14     # 1. installer.sh --layout custom /temporary/dir/usr --striproot /temporary/dir --install
15     # 2. rewrite the files section below.
16     %define _prefix /usr
17    
18 slords 1.1 # We can't let RPM do the dependencies automatic because it'll then pick up
19     # a correct but undesirable perl dependency, which rkhunter does not require
20     # in order to function properly.
21     AutoReqProv: no
22    
23 slords 1.2 Name: %{name}
24     Summary: %{name} scans for rootkits, backdoors and local exploits
25     Version: %{ver}
26     Release: %{rel}%{dist}
27     Epoch: %{epoch}
28     License: GPL
29     Group: Applications/System
30     Source0: %{name}-%{version}.tar.gz
31     Patch0: rkhunter-installer.patch
32     BuildArch: noarch
33     Requires: filesystem, bash, grep, findutils, net-tools, coreutils, e2fsprogs, modutils, procps, binutils, wget, perl
34     Provides: %{name}
35     URL: http://rkhunter.sourceforge.net/
36     BuildRoot: %{_tmppath}/%{name}-%{version}
37 slords 1.1
38     %description
39 slords 1.2 Rootkit Hunter is a scanning tool to ensure you are about 99.9%%
40     clean of nasty tools. It scans for rootkits, backdoors and local
41 slords 1.1 exploits by running tests like:
42 slords 1.2 - File hash check
43 slords 1.1 - Look for default files used by rootkits
44     - Wrong file permissions for binaries
45     - Look for suspected strings in LKM and KLD modules
46     - Look for hidden files
47     - Optional scan within plaintext and binary files
48     - Software version checks
49     - Application tests
50    
51     Rootkit Hunter is released as a GPL licensed project and free for everyone to use.
52    
53    
54     %prep
55 slords 1.2 %setup -q
56     %patch0 -p1
57 slords 1.1
58     %build
59    
60     %install
61 slords 1.2 sh ./installer.sh --layout RPM --install
62 slords 1.1
63 slords 1.3 sed -i 's_#ALLOWPROCLISTEN=/sbin/dhclient_ALLOWPROCLISTEN=/sbin/dhclient_' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
64 bytegw 1.4 sed -i 's_#ALLOWPROCLISTEN=/usr/sbin/pppoe_ALLOWPROCLISTEN=/usr/sbin/pppoe_' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
65 slords 1.3 sed -i 's_#ALLOWHIDDENFILE=/usr/share/man/man1/..1.gz_ALLOWHIDDENFILE=/usr/share/man/man1/..1.gz_' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
66 bytegw 1.4 sed -i '/#ALLOWPROCLISTEN=\/usr\/bin\/dhcpcd/iALLOWPROCLISTEN=\/usr\/sbin\/dhcpd' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
67 slords 1.3 sed -i '/#ALLOWPROCDELFILE=\/usr\/sbin\/mysqld/aALLOWPROCDELFILE=\/usr\/sbin\/httpd' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
68 slords 1.1
69 slords 1.2 # Make a cron.daily file to mail us the reports
70 slords 1.1 %{__mkdir} -p "${RPM_BUILD_ROOT}/%{_sysconfdir}/cron.daily"
71     %{__cat} > "${RPM_BUILD_ROOT}/%{_sysconfdir}/cron.daily/01-rkhunter" <<EOF
72     #!/bin/sh
73 slords 1.3 %{_bindir}/rkhunter --cronjob --update --disable apps,system_commands --rwo
74 slords 1.2 exit 0
75 slords 1.1 EOF
76     %{__chmod} a+rwx,g-w,o-rwx ${RPM_BUILD_ROOT}%{_sysconfdir}/cron.daily/01-rkhunter
77    
78    
79 slords 1.2 %post
80     # Only do this on an initial install
81     if [ $1 -eq 1 ]; then
82     %{__cp} -p /etc/passwd /var/lib/rkhunter/tmp >/dev/null 2>&1 || :
83     %{__cp} -p /etc/group /var/lib/rkhunter/tmp >/dev/null 2>&1 || :
84     fi
85 slords 1.1
86    
87 slords 1.2 %preun
88     # Only do this when removing the RPM
89     if [ $1 -eq 0 ]; then
90     %{__rm} -f /var/log/rkhunter.log /var/log/rkhunter.log.old >/dev/null 2>&1
91     %{__rm} -rf /var/lib/rkhunter/* >/dev/null 2>&1
92     fi
93 slords 1.1
94    
95 slords 1.2 %clean
96     if [ "$RPM_BUILD_ROOT" = "/" ]; then
97     echo Invalid Build root \'"$RPM_BUILD_ROOT"\'
98     exit 1
99     else
100     rm -rf $RPM_BUILD_ROOT
101     fi
102 slords 1.1
103    
104 slords 1.2 %define docdir %{_prefix}/share/doc/%{name}-%{version}
105     %files
106     %defattr(-,root,root)
107     %attr(640,root,root) %config(noreplace) %{_sysconfdir}/%{name}.conf
108     %attr(750,root,root) %{_prefix}/bin/%{name}
109     %attr(750,root,root) %dir %{_libdir}/%{name}
110     %attr(750,root,root) %dir %{_libdir}/%{name}/scripts
111     %attr(750,root,root) %{_libdir}/%{name}/scripts/*.pl
112     %attr(750,root,root) %{_libdir}/%{name}/scripts/*.sh
113     %attr(644,root,root) %doc %{_prefix}/share/man/man8/%{name}.8.gz
114     %attr(755,root,root) %dir %{docdir}
115     %attr(644,root,root) %doc %{docdir}/*
116     %attr(750,root,root) %dir %{_var}/lib/%{name}
117     %attr(750,root,root) %dir %{_var}/lib/%{name}/db
118     %attr(640,root,root) %{_var}/lib/%{name}/db/*.dat
119     %attr(750,root,root) %dir %{_var}/lib/%{name}/db/i18n
120     %attr(640,root,root) %{_var}/lib/%{name}/db/i18n/*
121     %attr(750,root,root) %dir %{_var}/lib/%{name}/tmp
122     %{_sysconfdir}/cron.daily/01-rkhunter
123 slords 1.1
124    
125 slords 1.2 %changelog
126 bytegw 1.4 * Mon Dec 17 2007 Shad L. Lords <slords@mail.com> 1.3.0-2
127     - Add a few more services for sme tests
128    
129 slords 1.2 * Mon Dec 17 2007 Shad L. Lords <slords@mail.com> 1.3.0-1
130     - Fix installer to not install in local
131 slords 1.3 - Set parameters for sme specific tests
132 slords 1.1
133 slords 1.2 * Sun Feb 11 2007 unSpawn - pre-1.3.0
134     - Sync spec with fixes, installer and CVS
135 slords 1.1
136 slords 1.2 * Sun Nov 12 2006 unSpawn - 1.2.9
137     - Re-spec, new installer
138 slords 1.1
139 slords 1.2 * Fri Sep 29 2006 unSpawn - 1.2.9
140     - Updated for release 1.2.9
141 slords 1.1
142     * Tue Aug 10 2004 Michael Boelen - 1.1.5
143     - Added update script
144     - Extended description
145    
146     * Sun Aug 08 2004 Greg Houlette - 1.1.5
147     - Changed the install procedure eliminating the specification of
148     destination filenames (only needed if you are renaming during install)
149     - Changed the permissions for documentation files (root only overkill)
150     - Added the installation of the rkhunter Man Page
151     - Added the installation of the programs_{bad, good}.dat database files
152     - Added the installation of the LICENSE documentation file
153     - Added the chmod for root only to the /var/rkhunter/db directory
154    
155     * Sun May 23 2004 Craig Orsinger (cjo) <cjorsinger@earthlink.net>
156     - version 1.1.0-1.cjo
157     - changed installation in accordance with new rootkit installation
158     procedure
159     - changed installation root to conform to LSB. Use standard macros.
160     - added recursive remove of old build root as prep for install phase
161    
162     * Wed Apr 28 2004 Doncho N. Gunchev - 1.0.9-0.mr700
163     - dropped Requires: perl - rkhunter works without it
164     - dropped the bash alignpatch (check the source or contact me)
165     - various file mode fixes (.../tmp/, *.db)
166     - optimized the %%files section - any new files in the
167     current dirs will be fine - just %%{__install} them.
168    
169     * Mon Apr 26 2004 Michael Boelen - 1.0.8-0
170     - Fixed missing md5blacklist.dat
171    
172     * Mon Apr 19 2004 Doncho N. Gunchev - 1.0.6-1.mr700
173     - added missing /usr/local/rkhunter/db/md5blacklist.dat
174     - patched to align results in --cronjob, I think rpm based
175     distros have symlink /bin/sh -> /bin/bash
176     - added --with/--without alignpatch for conditional builds
177     (in case previous patch breaks something)
178    
179     * Sat Apr 03 2004 Michael Boelen / Joe Klemmer - 1.0.6-0
180     - Update to 1.0.6
181    
182     * Mon Mar 29 2004 Doncho N. Gunchev - 1.0.0-0
183     - initial .spec file
184    
185 slords 1.2

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed