/[smeserver]/rpms/rkhunter/sme7/rkhunter.spec
ViewVC logotype

Annotation of /rpms/rkhunter/sme7/rkhunter.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Tue Dec 18 10:47:34 2007 UTC (16 years, 5 months ago) by bytegw
Branch: MAIN
CVS Tags: rkhunter-1_3_0-3_el4_sme
Changes since 1.4: +15 -10 lines
Updates

1 slords 1.2 # No debuginfo:
2     %define debug_package %{nil}
3    
4     # If you want to debug, uncomment the next line and remove
5     # the duplicate percent sign (due to macro expansion)
6     #%%dump
7    
8     %define name rkhunter
9     %define ver 1.3.0
10 bytegw 1.5 %define rel 3
11 slords 1.2 %define epoch 0
12    
13     # Don't change this define or also:
14     # 1. installer.sh --layout custom /temporary/dir/usr --striproot /temporary/dir --install
15     # 2. rewrite the files section below.
16     %define _prefix /usr
17    
18 slords 1.1 # We can't let RPM do the dependencies automatic because it'll then pick up
19     # a correct but undesirable perl dependency, which rkhunter does not require
20     # in order to function properly.
21     AutoReqProv: no
22    
23 slords 1.2 Name: %{name}
24     Summary: %{name} scans for rootkits, backdoors and local exploits
25     Version: %{ver}
26     Release: %{rel}%{dist}
27     Epoch: %{epoch}
28     License: GPL
29     Group: Applications/System
30     Source0: %{name}-%{version}.tar.gz
31     Patch0: rkhunter-installer.patch
32 bytegw 1.5 Patch1: rkhunter-nolib.patch
33 slords 1.2 BuildArch: noarch
34     Requires: filesystem, bash, grep, findutils, net-tools, coreutils, e2fsprogs, modutils, procps, binutils, wget, perl
35     Provides: %{name}
36     URL: http://rkhunter.sourceforge.net/
37     BuildRoot: %{_tmppath}/%{name}-%{version}
38 slords 1.1
39     %description
40 slords 1.2 Rootkit Hunter is a scanning tool to ensure you are about 99.9%%
41     clean of nasty tools. It scans for rootkits, backdoors and local
42 slords 1.1 exploits by running tests like:
43 slords 1.2 - File hash check
44 slords 1.1 - Look for default files used by rootkits
45     - Wrong file permissions for binaries
46     - Look for suspected strings in LKM and KLD modules
47     - Look for hidden files
48     - Optional scan within plaintext and binary files
49     - Software version checks
50     - Application tests
51    
52     Rootkit Hunter is released as a GPL licensed project and free for everyone to use.
53    
54    
55     %prep
56 slords 1.2 %setup -q
57     %patch0 -p1
58 bytegw 1.5 %patch1 -p1
59 slords 1.1
60     %build
61    
62     %install
63 slords 1.2 sh ./installer.sh --layout RPM --install
64 slords 1.1
65 slords 1.3 sed -i 's_#ALLOWPROCLISTEN=/sbin/dhclient_ALLOWPROCLISTEN=/sbin/dhclient_' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
66 bytegw 1.4 sed -i 's_#ALLOWPROCLISTEN=/usr/sbin/pppoe_ALLOWPROCLISTEN=/usr/sbin/pppoe_' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
67 slords 1.3 sed -i 's_#ALLOWHIDDENFILE=/usr/share/man/man1/..1.gz_ALLOWHIDDENFILE=/usr/share/man/man1/..1.gz_' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
68 bytegw 1.4 sed -i '/#ALLOWPROCLISTEN=\/usr\/bin\/dhcpcd/iALLOWPROCLISTEN=\/usr\/sbin\/dhcpd' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
69 slords 1.3 sed -i '/#ALLOWPROCDELFILE=\/usr\/sbin\/mysqld/aALLOWPROCDELFILE=\/usr\/sbin\/httpd' ${RPM_BUILD_ROOT}%{_sysconfdir}/%{name}.conf
70 slords 1.1
71 slords 1.2 # Make a cron.daily file to mail us the reports
72 slords 1.1 %{__mkdir} -p "${RPM_BUILD_ROOT}/%{_sysconfdir}/cron.daily"
73     %{__cat} > "${RPM_BUILD_ROOT}/%{_sysconfdir}/cron.daily/01-rkhunter" <<EOF
74     #!/bin/sh
75 slords 1.3 %{_bindir}/rkhunter --cronjob --update --disable apps,system_commands --rwo
76 slords 1.2 exit 0
77 slords 1.1 EOF
78     %{__chmod} a+rwx,g-w,o-rwx ${RPM_BUILD_ROOT}%{_sysconfdir}/cron.daily/01-rkhunter
79    
80    
81 slords 1.2 %post
82     # Only do this on an initial install
83     if [ $1 -eq 1 ]; then
84 bytegw 1.5 %{__cp} -p /etc/passwd /var/rkhunter/tmp >/dev/null 2>&1 || :
85     %{__cp} -p /etc/group /var/rkhunter/tmp >/dev/null 2>&1 || :
86 slords 1.2 fi
87 slords 1.1
88    
89 slords 1.2 %preun
90     # Only do this when removing the RPM
91     if [ $1 -eq 0 ]; then
92     %{__rm} -f /var/log/rkhunter.log /var/log/rkhunter.log.old >/dev/null 2>&1
93 bytegw 1.5 %{__rm} -rf /var/rkhunter/* >/dev/null 2>&1
94 slords 1.2 fi
95 slords 1.1
96    
97 slords 1.2 %clean
98     if [ "$RPM_BUILD_ROOT" = "/" ]; then
99     echo Invalid Build root \'"$RPM_BUILD_ROOT"\'
100     exit 1
101     else
102     rm -rf $RPM_BUILD_ROOT
103     fi
104 slords 1.1
105    
106 slords 1.2 %define docdir %{_prefix}/share/doc/%{name}-%{version}
107     %files
108     %defattr(-,root,root)
109     %attr(640,root,root) %config(noreplace) %{_sysconfdir}/%{name}.conf
110     %attr(750,root,root) %{_prefix}/bin/%{name}
111     %attr(750,root,root) %dir %{_libdir}/%{name}
112     %attr(750,root,root) %dir %{_libdir}/%{name}/scripts
113     %attr(750,root,root) %{_libdir}/%{name}/scripts/*.pl
114     %attr(750,root,root) %{_libdir}/%{name}/scripts/*.sh
115     %attr(644,root,root) %doc %{_prefix}/share/man/man8/%{name}.8.gz
116     %attr(755,root,root) %dir %{docdir}
117     %attr(644,root,root) %doc %{docdir}/*
118 bytegw 1.5 %attr(750,root,root) %dir %{_var}/%{name}
119     %attr(750,root,root) %dir %{_var}/%{name}/db
120     %attr(640,root,root) %{_var}/%{name}/db/*.dat
121     %attr(750,root,root) %dir %{_var}/%{name}/db/i18n
122     %attr(640,root,root) %{_var}/%{name}/db/i18n/*
123     %attr(750,root,root) %dir %{_var}/%{name}/tmp
124 slords 1.2 %{_sysconfdir}/cron.daily/01-rkhunter
125 slords 1.1
126    
127 slords 1.2 %changelog
128 bytegw 1.5 * Mon Dec 17 2007 Shad L. Lords <slords@mail.com> 1.3.0-3
129     - Change /var/lib to /var to be consistent with previous versions
130    
131 bytegw 1.4 * Mon Dec 17 2007 Shad L. Lords <slords@mail.com> 1.3.0-2
132     - Add a few more services for sme tests
133    
134 slords 1.2 * Mon Dec 17 2007 Shad L. Lords <slords@mail.com> 1.3.0-1
135     - Fix installer to not install in local
136 slords 1.3 - Set parameters for sme specific tests
137 slords 1.1
138 slords 1.2 * Sun Feb 11 2007 unSpawn - pre-1.3.0
139     - Sync spec with fixes, installer and CVS
140 slords 1.1
141 slords 1.2 * Sun Nov 12 2006 unSpawn - 1.2.9
142     - Re-spec, new installer
143 slords 1.1
144 slords 1.2 * Fri Sep 29 2006 unSpawn - 1.2.9
145     - Updated for release 1.2.9
146 slords 1.1
147     * Tue Aug 10 2004 Michael Boelen - 1.1.5
148     - Added update script
149     - Extended description
150    
151     * Sun Aug 08 2004 Greg Houlette - 1.1.5
152     - Changed the install procedure eliminating the specification of
153     destination filenames (only needed if you are renaming during install)
154     - Changed the permissions for documentation files (root only overkill)
155     - Added the installation of the rkhunter Man Page
156     - Added the installation of the programs_{bad, good}.dat database files
157     - Added the installation of the LICENSE documentation file
158     - Added the chmod for root only to the /var/rkhunter/db directory
159    
160     * Sun May 23 2004 Craig Orsinger (cjo) <cjorsinger@earthlink.net>
161     - version 1.1.0-1.cjo
162     - changed installation in accordance with new rootkit installation
163     procedure
164     - changed installation root to conform to LSB. Use standard macros.
165     - added recursive remove of old build root as prep for install phase
166    
167     * Wed Apr 28 2004 Doncho N. Gunchev - 1.0.9-0.mr700
168     - dropped Requires: perl - rkhunter works without it
169     - dropped the bash alignpatch (check the source or contact me)
170     - various file mode fixes (.../tmp/, *.db)
171     - optimized the %%files section - any new files in the
172     current dirs will be fine - just %%{__install} them.
173    
174     * Mon Apr 26 2004 Michael Boelen - 1.0.8-0
175     - Fixed missing md5blacklist.dat
176    
177     * Mon Apr 19 2004 Doncho N. Gunchev - 1.0.6-1.mr700
178     - added missing /usr/local/rkhunter/db/md5blacklist.dat
179     - patched to align results in --cronjob, I think rpm based
180     distros have symlink /bin/sh -> /bin/bash
181     - added --with/--without alignpatch for conditional builds
182     (in case previous patch breaks something)
183    
184     * Sat Apr 03 2004 Michael Boelen / Joe Klemmer - 1.0.6-0
185     - Update to 1.0.6
186    
187     * Mon Mar 29 2004 Doncho N. Gunchev - 1.0.0-0
188     - initial .spec file
189    
190 slords 1.2

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed