/[smeserver]/rpms/runit/sme7/runit.spec
ViewVC logotype

Annotation of /rpms/runit/sme7/runit.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Mon Oct 6 14:42:04 2008 UTC (15 years, 7 months ago) by slords
Branch: MAIN
CVS Tags: runit-2_0_0-1_el4_sme, HEAD
Changes since 1.2: +5 -2 lines
Updates

1 slords 1.3 # $Id: runit.spec,v 1.2 2008/04/09 13:51:56 slords Exp $
2 slords 1.2
3 slords 1.1 Summary: a UNIX init scheme with service supervision
4     Name: runit
5 slords 1.3 Version: 2.0.0
6 slords 1.1 Release: 1%{?dist}
7     License: BSD style
8     Group: System Enviornment/Daemons
9     Url: http://smarden.org/runit/
10     Source: %{name}-%{version}.tar.gz
11     Source1: runit.svup
12     Source2: runit.svdown
13     Source3: runit.svdepcalc
14     Source4: runit.dependencies.README
15     BuildRequires: dietlibc
16     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}.root
17     %description
18    
19     runit is a daemontools alike replacement for sysvinit and other init
20     schemes. runit runs on GNU/Linux, OpenBSD, FreeBSD, and can easily be
21     adapted to other unix operating systems. If runit runs for you on any
22     other operating system or Linux distribution, please let me know.
23    
24     Warning: Replacing sysvinit or init can cause the system's boot to
25     fail. Make sure you are able to recover and repair your system, for
26     example if you run a boot loader, it should be able to pass init=/bin/sh
27     to the kernel.
28    
29     %changelog
30 slords 1.3 * Mon Oct 6 2008 Shad L. Lords <slords@mail.com>
31     - Update to 2.0.0 [SME: 4628]
32    
33 slords 1.1 * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
34     - Clean up spec so package can be built by koji/plague
35    
36     * Fri Feb 16 2007 Shad L. Lords <slords@mail.com>
37     - Update to 1.7.2
38    
39     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
40     - Update to new release naming. No functional changes.
41     - Make Packager generic
42    
43     * Thu Nov 09 2006 Charlie Brady <charlie_brady@mitel.com> 1.7.1-01
44     - Update to 1.7.1
45    
46     * Wed Nov 01 2006 Charlie Brady <charlie_brady@mitel.com> 1.7.0-02
47     - Build with dietlibc
48    
49     * Wed Nov 01 2006 Charlie Brady <charlie_brady@mitel.com> 1.7.0-01
50     - Update to 1.7.0
51    
52     * Thu Jun 29 2006 Charlie Brady <charlie_brady@mitel.com> 1.6.0-01
53     - Update to 1.6.0
54    
55     * Sun May 28 2006 Charlie Brady <charlie_brady@mitel.com> 1.5.1-01
56     - Update to 1.5.1
57    
58     * Fri Feb 03 2006 Charlie Brady <charlie_brady@mitel.com> 1.3.3-01
59     - Update to 1.3.3
60    
61     * Wed Aug 31 2005 Charlie Brady <charlieb@e-smith.com> 1.3.1-01
62     - Update to 1.3.1.
63    
64     * Sun Jan 16 2005 Charlie Brady <charlieb@e-smith.com> 1.2.1-01
65     - Update to 1.2.1.
66    
67     * Mon Dec 20 2004 Charlie Brady <charlieb@e-smith.com> 1.2.0-01
68     - Update to 1.2.0.
69    
70     * Thu Sep 23 2004 Charlie Brady <charlieb@e-smith.com> 1.0.5-01
71     - Update to 1.0.5.
72    
73     * Tue May 11 2004 Charlie Brady <charlieb@e-smith.com> 1.0.2-01
74     - Update to 1.0.2.
75     - Do not build against uCLibc.
76    
77     * Tue Nov 04 2003 Charlie Brady <charlieb@e-smith.com> 0.12.0-01
78     - Update to rev 0.12.0 (which includes the isup/isdown patch).
79    
80     * Wed Oct 29 2003 Charlie Brady <charlieb@e-smith.com> 0.11.2-02
81     - Add dependency management and isupdown patches from Torne Wuff
82     <torne-runit@wolfpuppy.org.uk>.
83     - Build against uClibc.
84     - Add missing man pages.
85    
86     * Thu Oct 02 2003 Charlie Brady <charlieb@e-smith.com> 0.11.2-01
87     - Upgrade to version 0.11.2.
88    
89     * Fri Jul 18 2003 Charlie Brady <charlieb@e-smith.com> 0.10-01
90     - Upgrade to version 0.10.0. Drop references to dietlibc (which wasn't
91     actually used, but appears to have an incompatible license).
92    
93     * Wed Jun 18 2003 Charlie Brady <charlieb@e-smith.com> 0.95-01
94     - Initial
95    
96     %prep
97     %setup -c -n %{name}-%{version}
98    
99     %build
100     cd admin/%{name}-%{version}
101     #Change the conf-cc and conf-ld to use diet
102     echo 'diet -Os gcc -O2 -Wall' >src/conf-cc
103     echo 'diet -Os gcc -s -Os -pipe' >src/conf-ld
104     ./package/compile
105    
106     %install
107     cd admin/%{name}-%{version}
108     mkdir -p $RPM_BUILD_ROOT/%{_bindir}
109     install %{SOURCE1} command/svisup
110     install %{SOURCE2} command/svisdown
111     install %{SOURCE3} command/svdepcalc
112     install %{SOURCE4} doc/dependencies.README
113     for i in $(cat package/commands) svisup svisdown svdepcalc
114     do
115     install command/$i $RPM_BUILD_ROOT/%{_bindir}
116     done
117     #mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
118     #install man/*.1 $RPM_BUILD_ROOT/%{_mandir}/man1
119     mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man8
120     install man/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
121    
122     %clean
123     rm -r $RPM_BUILD_ROOT
124    
125     %files
126     %defattr(-,root,root)
127     %{_bindir}/*
128     %doc %{_mandir}/man8/*
129     #%{_mandir}/man1/*
130     %doc admin/%{name}-%{version}/package/COPYING
131     %doc admin/%{name}-%{version}/doc/*

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed