/[smeserver]/rpms/runit/sme9/runit.spec
ViewVC logotype

Annotation of /rpms/runit/sme9/runit.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Tue Nov 11 12:20:30 2014 UTC (9 years, 6 months ago) by vip-ire
Branch: MAIN
CVS Tags: runit-2_1_2-1_el6_sme, HEAD
Changes since 1.1: +5 -2 lines
* Tue Nov 11 2014 Daniel Berteaud <daniel@firewall-services.com> - 2.1.2-1
- Update to 2.1.2 [SME: 8655]

1 vip-ire 1.2 # $Id: runit.spec,v 1.1 2013/01/25 18:40:43 slords Exp $
2 slords 1.1
3     Summary: a UNIX init scheme with service supervision
4     Name: runit
5 vip-ire 1.2 Version: 2.1.2
6 slords 1.1 Release: 1%{?dist}
7     License: BSD style
8     Group: System Enviornment/Daemons
9     Url: http://smarden.org/runit/
10     Source: %{name}-%{version}.tar.gz
11     Source1: runit.svup
12     Source2: runit.svdown
13     Source3: runit.svdepcalc
14     Source4: runit.dependencies.README
15     BuildRequires: dietlibc
16     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}.root
17     %description
18    
19     runit is a daemontools alike replacement for sysvinit and other init
20     schemes. runit runs on GNU/Linux, OpenBSD, FreeBSD, and can easily be
21     adapted to other unix operating systems. If runit runs for you on any
22     other operating system or Linux distribution, please let me know.
23    
24     Warning: Replacing sysvinit or init can cause the system's boot to
25     fail. Make sure you are able to recover and repair your system, for
26     example if you run a boot loader, it should be able to pass init=/bin/sh
27     to the kernel.
28    
29     %changelog
30 vip-ire 1.2 * Tue Nov 11 2014 Daniel Berteaud <daniel@firewall-services.com> - 2.1.2-1
31     - Update to 2.1.2 [SME: 8655]
32    
33 slords 1.1 * Mon Oct 6 2008 Shad L. Lords <slords@mail.com>
34     - Update to 2.0.0 [SME: 4628]
35    
36     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
37     - Clean up spec so package can be built by koji/plague
38    
39     * Fri Feb 16 2007 Shad L. Lords <slords@mail.com>
40     - Update to 1.7.2
41    
42     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
43     - Update to new release naming. No functional changes.
44     - Make Packager generic
45    
46     * Thu Nov 09 2006 Charlie Brady <charlie_brady@mitel.com> 1.7.1-01
47     - Update to 1.7.1
48    
49     * Wed Nov 01 2006 Charlie Brady <charlie_brady@mitel.com> 1.7.0-02
50     - Build with dietlibc
51    
52     * Wed Nov 01 2006 Charlie Brady <charlie_brady@mitel.com> 1.7.0-01
53     - Update to 1.7.0
54    
55     * Thu Jun 29 2006 Charlie Brady <charlie_brady@mitel.com> 1.6.0-01
56     - Update to 1.6.0
57    
58     * Sun May 28 2006 Charlie Brady <charlie_brady@mitel.com> 1.5.1-01
59     - Update to 1.5.1
60    
61     * Fri Feb 03 2006 Charlie Brady <charlie_brady@mitel.com> 1.3.3-01
62     - Update to 1.3.3
63    
64     * Wed Aug 31 2005 Charlie Brady <charlieb@e-smith.com> 1.3.1-01
65     - Update to 1.3.1.
66    
67     * Sun Jan 16 2005 Charlie Brady <charlieb@e-smith.com> 1.2.1-01
68     - Update to 1.2.1.
69    
70     * Mon Dec 20 2004 Charlie Brady <charlieb@e-smith.com> 1.2.0-01
71     - Update to 1.2.0.
72    
73     * Thu Sep 23 2004 Charlie Brady <charlieb@e-smith.com> 1.0.5-01
74     - Update to 1.0.5.
75    
76     * Tue May 11 2004 Charlie Brady <charlieb@e-smith.com> 1.0.2-01
77     - Update to 1.0.2.
78     - Do not build against uCLibc.
79    
80     * Tue Nov 04 2003 Charlie Brady <charlieb@e-smith.com> 0.12.0-01
81     - Update to rev 0.12.0 (which includes the isup/isdown patch).
82    
83     * Wed Oct 29 2003 Charlie Brady <charlieb@e-smith.com> 0.11.2-02
84     - Add dependency management and isupdown patches from Torne Wuff
85     <torne-runit@wolfpuppy.org.uk>.
86     - Build against uClibc.
87     - Add missing man pages.
88    
89     * Thu Oct 02 2003 Charlie Brady <charlieb@e-smith.com> 0.11.2-01
90     - Upgrade to version 0.11.2.
91    
92     * Fri Jul 18 2003 Charlie Brady <charlieb@e-smith.com> 0.10-01
93     - Upgrade to version 0.10.0. Drop references to dietlibc (which wasn't
94     actually used, but appears to have an incompatible license).
95    
96     * Wed Jun 18 2003 Charlie Brady <charlieb@e-smith.com> 0.95-01
97     - Initial
98    
99     %prep
100     %setup -c -n %{name}-%{version}
101    
102     %build
103     cd admin/%{name}-%{version}
104     #Change the conf-cc and conf-ld to use diet
105     echo 'diet -Os gcc -O2 -Wall' >src/conf-cc
106     echo 'diet -Os gcc -s -Os -pipe' >src/conf-ld
107     ./package/compile
108    
109     %install
110     cd admin/%{name}-%{version}
111     mkdir -p $RPM_BUILD_ROOT/%{_bindir}
112     install %{SOURCE1} command/svisup
113     install %{SOURCE2} command/svisdown
114     install %{SOURCE3} command/svdepcalc
115     install %{SOURCE4} doc/dependencies.README
116     for i in $(cat package/commands) svisup svisdown svdepcalc
117     do
118     install command/$i $RPM_BUILD_ROOT/%{_bindir}
119     done
120     #mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
121     #install man/*.1 $RPM_BUILD_ROOT/%{_mandir}/man1
122     mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man8
123     install man/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
124    
125     %clean
126     rm -r $RPM_BUILD_ROOT
127    
128     %files
129     %defattr(-,root,root)
130     %{_bindir}/*
131     %doc %{_mandir}/man8/*
132     #%{_mandir}/man1/*
133     %doc admin/%{name}-%{version}/package/COPYING
134     %doc admin/%{name}-%{version}/doc/*

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed