1 |
unnilennium |
1.1 |
# $Id: e-smith-horde.spec,v 1.22 2010/05/11 04:07:35 mrjhb3 Exp $ |
2 |
|
|
|
3 |
|
|
Summary: e-smith specific Horde configuration and templates. |
4 |
|
|
%define name smeserver-horde |
5 |
|
|
Name: %{name} |
6 |
|
|
%define version 1.0.0 |
7 |
|
|
%define release 1 |
8 |
|
|
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Daemons |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
#Patch1: e-smith-horde-4.8.0_renumber_database_creation.order.patch |
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
Requires: e-smith-base >= 4.9.44, php-horde-horde >= 5.2, mariadb |
17 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
18 |
|
|
AutoReqProv: no |
19 |
|
|
Obsoletes: horde-h3, e-smith-horde, imp-h3, e-smith-imp |
20 |
|
|
Obsoletes: ingo-h3, e-smith-ingo, turba-h3, e-smith-turba |
21 |
|
|
Obsoletes: kronolith-h3, smeserver-kronolith, nag-h3, smeserver-nag |
22 |
|
|
Obsoletes: mnemo-h3, smeserver-mnemo |
23 |
|
|
|
24 |
|
|
|
25 |
|
|
%changelog |
26 |
|
|
* Sun Jun 19 2016 John H. Bennett III <bennettj@johnbennettservices.com> 1.0.0-1 |
27 |
|
|
- First released build for SME10 |
28 |
|
|
|
29 |
|
|
%description |
30 |
|
|
This package adds necessary templates and configuration items |
31 |
|
|
for Horde, Imp, Ingo, Kronolith, Mnemo, Nag and Turba |
32 |
|
|
to work on SME Server 10 |
33 |
|
|
|
34 |
|
|
%prep |
35 |
|
|
%setup |
36 |
|
|
|
37 |
|
|
#%patch1 -p1 |
38 |
|
|
|
39 |
|
|
%build |
40 |
|
|
for i in post-install post-upgrade |
41 |
|
|
do |
42 |
|
|
mkdir -p root/etc/e-smith/events/$i |
43 |
|
|
done |
44 |
|
|
perl createlinks |
45 |
|
|
|
46 |
|
|
%install |
47 |
|
|
rm -rf $RPM_BUILD_ROOT |
48 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
49 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
50 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
51 |
|
|
|
52 |
|
|
%clean |
53 |
|
|
rm -rf $RPM_BUILD_ROOT |
54 |
|
|
|
55 |
|
|
%pre |
56 |
|
|
%preun |
57 |
|
|
%post |
58 |
|
|
|
59 |
|
|
%postun |
60 |
|
|
|
61 |
|
|
%files -f %{name}-%{version}-filelist |
62 |
|
|
%defattr(-,root,root) |