1 |
unnilennium |
1.1 |
# $Id: e-smith-horde.spec,v 1.22 2010/05/11 04:07:35 mrjhb3 Exp $ |
2 |
|
|
|
3 |
|
|
Summary: e-smith specific Horde configuration and templates. |
4 |
|
|
%define name smeserver-horde |
5 |
|
|
Name: %{name} |
6 |
|
|
%define version 1.0.0 |
7 |
unnilennium |
1.2 |
%define release 2 |
8 |
unnilennium |
1.1 |
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Daemons |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
#Patch1: e-smith-horde-4.8.0_renumber_database_creation.order.patch |
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
Requires: e-smith-base >= 4.9.44, php-horde-horde >= 5.2, mariadb |
17 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
18 |
|
|
AutoReqProv: no |
19 |
|
|
Obsoletes: horde-h3, e-smith-horde, imp-h3, e-smith-imp |
20 |
|
|
Obsoletes: ingo-h3, e-smith-ingo, turba-h3, e-smith-turba |
21 |
|
|
Obsoletes: kronolith-h3, smeserver-kronolith, nag-h3, smeserver-nag |
22 |
|
|
Obsoletes: mnemo-h3, smeserver-mnemo |
23 |
unnilennium |
1.2 |
Requires: php-horde-content, php-horde-imp, php-horde-ingo, php-horde-kronolith, |
24 |
|
|
Requires: php-horde-mnemo, php-horde-nag, php-horde-turba |
25 |
unnilennium |
1.1 |
|
26 |
unnilennium |
1.2 |
%changelog |
27 |
|
|
* Wed Jul 06 2016 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.0-2.sme |
28 |
|
|
- add main Required packages php-horde-* [SME: 9645] |
29 |
unnilennium |
1.1 |
|
30 |
|
|
* Sun Jun 19 2016 John H. Bennett III <bennettj@johnbennettservices.com> 1.0.0-1 |
31 |
|
|
- First released build for SME10 |
32 |
|
|
|
33 |
|
|
%description |
34 |
|
|
This package adds necessary templates and configuration items |
35 |
|
|
for Horde, Imp, Ingo, Kronolith, Mnemo, Nag and Turba |
36 |
|
|
to work on SME Server 10 |
37 |
|
|
|
38 |
|
|
%prep |
39 |
|
|
%setup |
40 |
|
|
|
41 |
|
|
#%patch1 -p1 |
42 |
|
|
|
43 |
|
|
%build |
44 |
|
|
for i in post-install post-upgrade |
45 |
|
|
do |
46 |
|
|
mkdir -p root/etc/e-smith/events/$i |
47 |
|
|
done |
48 |
|
|
perl createlinks |
49 |
|
|
|
50 |
|
|
%install |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
53 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
54 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%pre |
60 |
|
|
%preun |
61 |
|
|
%post |
62 |
|
|
|
63 |
|
|
%postun |
64 |
|
|
|
65 |
|
|
%files -f %{name}-%{version}-filelist |
66 |
|
|
%defattr(-,root,root) |