1 |
unnilennium |
1.1 |
# $Id: e-smith-horde.spec,v 1.22 2010/05/11 04:07:35 mrjhb3 Exp $ |
2 |
|
|
|
3 |
|
|
Summary: e-smith specific Horde configuration and templates. |
4 |
|
|
%define name smeserver-horde |
5 |
|
|
Name: %{name} |
6 |
|
|
%define version 1.0.0 |
7 |
unnilennium |
1.4 |
%define release 4 |
8 |
unnilennium |
1.1 |
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Daemons |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
#Patch1: e-smith-horde-4.8.0_renumber_database_creation.order.patch |
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
Requires: e-smith-base >= 4.9.44, php-horde-horde >= 5.2, mariadb |
17 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
18 |
|
|
AutoReqProv: no |
19 |
|
|
Obsoletes: horde-h3, e-smith-horde, imp-h3, e-smith-imp |
20 |
|
|
Obsoletes: ingo-h3, e-smith-ingo, turba-h3, e-smith-turba |
21 |
|
|
Obsoletes: kronolith-h3, smeserver-kronolith, nag-h3, smeserver-nag |
22 |
|
|
Obsoletes: mnemo-h3, smeserver-mnemo |
23 |
unnilennium |
1.3 |
Requires: php-horde-content, php-horde-imp, php-horde-ingo, php-horde-kronolith |
24 |
unnilennium |
1.2 |
Requires: php-horde-mnemo, php-horde-nag, php-horde-turba |
25 |
unnilennium |
1.4 |
# optional functions we provide |
26 |
unnilennium |
1.3 |
Requires: php-horde-Horde-ActiveSync |
27 |
|
|
Requires: php-horde-Horde-Service-Facebook |
28 |
|
|
Requires: php-horde-Horde-Service-Twitter |
29 |
|
|
Requires: php-pear-Date-Holidays-Australia, php-pear-Date-Holidays-Denmark |
30 |
|
|
Requires: php-pear-Date-Holidays-Germany, php-pear-Date-Holidays-Italy |
31 |
|
|
Requires: php-pear-Date-Holidays-Netherlands, php-pear-Date-Holidays-Norway |
32 |
|
|
Requires: php-pear-Date-Holidays-Portugal, php-pear-Date-Holidays-Russia |
33 |
|
|
Requires: php-pear-Date-Holidays-Slovenia, php-pear-Date-Holidays-Sweden |
34 |
unnilennium |
1.4 |
Requires: php-pear-Date-Holidays-France, php-pear-Date-Holidays-Turkey |
35 |
unnilennium |
1.3 |
Requires: php-horde-Horde-Text-Filter-Csstidy |
36 |
|
|
Requires: timeobjects |
37 |
unnilennium |
1.4 |
# maybe not required, but JHB used to have them in previous installs |
38 |
|
|
Requires: php-pear-Auth-SASL2 |
39 |
|
|
Requires: php-pear-Cache-Lite |
40 |
|
|
Requires: php-pear-Console-GetoptPlus |
41 |
|
|
Requires: php-pear-Crypt-Blowfish |
42 |
|
|
Requires: php-pear-File-CSV |
43 |
|
|
Requires: php-pear-File-Util |
44 |
|
|
Requires: php-pear-HTTP |
45 |
|
|
Requires: php-pear-HTTP-Request2 |
46 |
|
|
Requires: php-pear-HTTP_WebDAV_Server |
47 |
|
|
Requires: php-pear-Log |
48 |
|
|
Requires: php-pear-MDB2 |
49 |
|
|
Requires: php-pear-Net-URL2 |
50 |
|
|
Requires: php-pear-XML-Parser2 |
51 |
|
|
Requires: php-pear-XML-RPC2 |
52 |
unnilennium |
1.1 |
|
53 |
unnilennium |
1.2 |
%changelog |
54 |
unnilennium |
1.4 |
* Sun Jul 24 2016 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.0-4.sme |
55 |
|
|
- added last optionals dependencies [SME: 9645] |
56 |
|
|
- added France Holidays. |
57 |
|
|
|
58 |
unnilennium |
1.3 |
* Wed Jul 06 2016 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.0-3.sme |
59 |
|
|
- added Requires for pear Dates [SME: 9645] |
60 |
|
|
- Activesync, timeobjects, Facebook. Twitter, Text-Filter |
61 |
|
|
|
62 |
unnilennium |
1.2 |
* Wed Jul 06 2016 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.0-2.sme |
63 |
|
|
- add main Required packages php-horde-* [SME: 9645] |
64 |
unnilennium |
1.1 |
|
65 |
|
|
* Sun Jun 19 2016 John H. Bennett III <bennettj@johnbennettservices.com> 1.0.0-1 |
66 |
|
|
- First released build for SME10 |
67 |
|
|
|
68 |
|
|
%description |
69 |
|
|
This package adds necessary templates and configuration items |
70 |
|
|
for Horde, Imp, Ingo, Kronolith, Mnemo, Nag and Turba |
71 |
|
|
to work on SME Server 10 |
72 |
|
|
|
73 |
|
|
%prep |
74 |
|
|
%setup |
75 |
|
|
|
76 |
|
|
#%patch1 -p1 |
77 |
|
|
|
78 |
|
|
%build |
79 |
|
|
for i in post-install post-upgrade |
80 |
|
|
do |
81 |
|
|
mkdir -p root/etc/e-smith/events/$i |
82 |
|
|
done |
83 |
|
|
perl createlinks |
84 |
|
|
|
85 |
|
|
%install |
86 |
|
|
rm -rf $RPM_BUILD_ROOT |
87 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
88 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
89 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
90 |
|
|
|
91 |
|
|
%clean |
92 |
|
|
rm -rf $RPM_BUILD_ROOT |
93 |
|
|
|
94 |
|
|
%pre |
95 |
|
|
%preun |
96 |
|
|
%post |
97 |
|
|
|
98 |
|
|
%postun |
99 |
|
|
|
100 |
|
|
%files -f %{name}-%{version}-filelist |
101 |
|
|
%defattr(-,root,root) |