1 |
jpp |
1.1 |
# $Id: smeserver-devtools.spec,v 1.7 2017/05/25 15:48:49 unnilennium Exp $ |
2 |
|
|
|
3 |
|
|
Summary: smeserver-mock tools for building RPMs |
4 |
|
|
%define name e-smith-devtools |
5 |
|
|
Name: %{name} |
6 |
|
|
%define version 1.0 |
7 |
|
|
%define release 1 |
8 |
|
|
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Daemons |
12 |
|
|
Source: %{name}-%{version}.tgz |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: e-smith-devtools |
16 |
|
|
Requires: mock |
17 |
|
|
Requires: python-ctypes |
18 |
|
|
Requires: glances |
19 |
|
|
Requires: make rpm-build rpm-sign wget |
20 |
|
|
Requires: cmake automake libtool |
21 |
|
|
Buildrequires: e-smith-devtools |
22 |
|
|
# needed for scl |
23 |
|
|
Requires: scl-utils scl-utils-build centos-release-scl centos-release-scl-rh |
24 |
|
|
|
25 |
|
|
AutoReqProv: no |
26 |
|
|
|
27 |
|
|
%changelog |
28 |
|
|
* Sat Mar 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-1.sme |
29 |
|
|
- Initial release with SME Server mock config files |
30 |
|
|
- tools added : BogusDateBot.sh change-log clog createBuildDir prepa tagbuild |
31 |
|
|
|
32 |
|
|
|
33 |
|
|
|
34 |
|
|
%description |
35 |
|
|
Tools for use in building RPMs for the Koozali SME server and gateway. |
36 |
|
|
|
37 |
|
|
Few tools are also provided to help you with package building. |
38 |
|
|
|
39 |
|
|
%prep |
40 |
|
|
%setup |
41 |
|
|
|
42 |
|
|
%build |
43 |
|
|
|
44 |
|
|
%install |
45 |
|
|
rm -rf $RPM_BUILD_ROOT |
46 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
47 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
48 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
49 |
|
|
--file /usr/bin/BogusDateBot.sh '%attr(0755,root,root)' \ |
50 |
|
|
--file /usr/bin/change-log '%attr(0755,root,root)' \ |
51 |
|
|
--file /usr/bin/clog '%attr(0755,root,root)' \ |
52 |
|
|
--file /usr/bin/createBuildDir '%attr(0755,root,root)' \ |
53 |
|
|
--file /usr/bin/prepa '%attr(0755,root,root)' \ |
54 |
|
|
--file /usr/bin/tagbuild '%attr(0755,root,root)' \ |
55 |
|
|
--file /etc/mock/* '%attr(0754,root,mock)' \ |
56 |
|
|
> %{name}-%{version}-filelist |
57 |
|
|
|
58 |
|
|
%clean |
59 |
|
|
rm -rf $RPM_BUILD_ROOT |
60 |
|
|
|
61 |
|
|
%pre |
62 |
|
|
%preun |
63 |
|
|
%post |
64 |
|
|
%postun |
65 |
|
|
|
66 |
|
|
%files-f %{name}-%{version}-filelist |
67 |
|
|
%defattr(-,root,root,-) |