/[smeserver]/rpms/smeserver-mock/sme10/smeserver-mock.spec
ViewVC logotype

Annotation of /rpms/smeserver-mock/sme10/smeserver-mock.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.10 - (hide annotations) (download)
Mon Sep 30 19:34:51 2019 UTC (4 years, 8 months ago) by michel
Branch: MAIN
CVS Tags: smeserver-mock-1_0-8_el7_sme
Changes since 1.9: +7 -2 lines
* Mon Sep 30 2019 Michel Begue <mab974@gmail.com> 1.0-8.sme
- added include pkg ocaml, camlp5 [SME: 10809]

1 michel 1.10 # $Id: smeserver-mock.spec,v 1.9 2018/11/13 06:30:16 jpp Exp $
2 jpp 1.1
3     Summary: smeserver-mock tools for building RPMs
4 jpp 1.2 %define name smeserver-mock
5 jpp 1.1 Name: %{name}
6     %define version 1.0
7 michel 1.10 %define release 8
8 jpp 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tgz
13 jpp 1.5 Patch0: smeserver-mock-1.0-updates_values.patch
14 jpp 1.7 Patch1: smeserver-mock-1.0-sme10599-spamassassin.patch
15 jpp 1.8 Patch2: smeserver-mock-1.0-sme10600-video.patch
16 michel 1.10 Patch3: smeserver-mock-1.0-ocaml.patch
17 jpp 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
18     BuildArchitectures: noarch
19     Requires: e-smith-devtools
20     Requires: mock
21     Requires: glances
22     Requires: make rpm-build rpm-sign wget
23     Requires: cmake automake libtool
24     Buildrequires: e-smith-devtools
25     # needed for scl
26     Requires: scl-utils scl-utils-build centos-release-scl centos-release-scl-rh
27 jpp 1.3 Requires: python27-build
28 jpp 1.1 AutoReqProv: no
29    
30     %changelog
31 michel 1.10 * Mon Sep 30 2019 Michel Begue <mab974@gmail.com> 1.0-8.sme
32     - added include pkg ocaml, camlp5 [SME: 10809]
33    
34 jpp 1.9 * Tue Nov 13 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-7.sme
35     - fix non needed Requires python-ctypes [SME: 10647]
36    
37 jpp 1.8 * Wed Jun 20 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-6.sme
38     - added include pkg for video tools [SME: 1600]
39     - applied patch for previous bug fix [SME: 10599]
40    
41 jpp 1.6 * Tue Jun 19 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-5.sme
42     - update dependencies to build spamassassin [SME: 10599]
43    
44 jpp 1.5 * Sun Mar 18 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-4.sme
45     - update include package values according to buildsys
46    
47 jpp 1.4 * Sat Mar 17 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-3.sme
48     - set %config on mock config files
49     - a rpmsave of the previous version will be created if modified.
50     - fix typo in filename
51    
52 jpp 1.3 * Sun Mar 11 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-2.sme
53     - update of site-default.cfg via post script [SME: 10537]
54     - removed e-smith-devtools of requirements
55     - added Requires python27-build
56    
57 jpp 1.1 * Sat Mar 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-1.sme
58 jpp 1.2 - Initial release with SME iServer mock config files [SME: 10537]
59 jpp 1.1 - tools added : BogusDateBot.sh change-log clog createBuildDir prepa tagbuild
60    
61     %description
62     Tools for use in building RPMs for the Koozali SME server and gateway.
63    
64     Few tools are also provided to help you with package building.
65    
66     %prep
67     %setup
68 jpp 1.5 %patch0 -p1
69 jpp 1.7 %patch1 -p1
70 jpp 1.8 %patch2 -p1
71 michel 1.10 %patch3 -p1
72 jpp 1.1
73     %build
74    
75     %install
76     rm -rf $RPM_BUILD_ROOT
77     (cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT)
78     /bin/rm -f %{name}-%{version}-filelist
79     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
80     --file /usr/bin/BogusDateBot.sh '%attr(0755,root,root)' \
81     --file /usr/bin/change-log '%attr(0755,root,root)' \
82     --file /usr/bin/clog '%attr(0755,root,root)' \
83     --file /usr/bin/createBuildDir '%attr(0755,root,root)' \
84     --file /usr/bin/prepa '%attr(0755,root,root)' \
85     --file /usr/bin/tagbuild '%attr(0755,root,root)' \
86 jpp 1.2 | grep -v /etc/mock/ \
87 jpp 1.1 > %{name}-%{version}-filelist
88    
89     %clean
90     rm -rf $RPM_BUILD_ROOT
91    
92     %pre
93     %preun
94     %post
95 jpp 1.3
96     # updates sme site defaults
97     main=/etc/mock/site-defaults.cfg
98     tmp=/tmp/site-defaults.cfg
99     gen=/etc/mock/sme-site-defaults.cfg
100    
101     # position of the tags
102     BEGIN_GEN=$(cat $main | grep -n '### KOOZALI SME SERVER BEGIN GENERATED CONTENT' | sed 's/\(.*\):.*/\1/g' )
103     END_GEN=$(cat $main | grep -n '### KOOZALI SME SERVER END GENERATED CONTENT' | sed 's/\(.*\):.*/\1/g' )
104     #if tag is absent set first to 0
105     if [[ "$BEGIN_GEN" -eq "" ]]; then BEGIN_GEN=0; fi
106     if [[ "$END_GEN" -eq "" ]]; then
107     # if second tag is absent just concatenate
108     cat <(head -n $(expr $BEGIN_GEN - 1) $main) $gen >$tmp;
109    
110     else
111     # if both tags are present replace content
112     cat <(head -n $(expr $BEGIN_GEN - 1) $main) $gen <(tail -n +$(expr $END_GEN + 1) $main) >$tmp;
113    
114     fi
115     # mv tmp file to main file
116     mv $tmp $main
117    
118    
119 jpp 1.1 %postun
120    
121 jpp 1.2 %files -f %{name}-%{version}-filelist
122 jpp 1.1 %defattr(-,root,root,-)
123 jpp 1.4 /etc/mock/* %config %attr(0755,root,mock)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed