/[smeserver]/rpms/smeserver-mock/sme10/smeserver-mock.spec
ViewVC logotype

Annotation of /rpms/smeserver-mock/sme10/smeserver-mock.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.12 - (hide annotations) (download)
Tue May 19 04:13:16 2020 UTC (4 years ago) by jpp
Branch: MAIN
CVS Tags: smeserver-mock-1_0-9_el7_sme
Changes since 1.11: +5 -3 lines
* Thu May 14 2020 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-9.sme
- fix nspawn and package_manager set to yum [SME: 10946]
- updating list of included packages for SME10 and SME9 repo
- updating the attached bins to help building [SME: 10924]

1 jpp 1.12 # $Id: smeserver-mock.spec,v 1.11 2020/05/19 04:06:24 jpp Exp $
2 jpp 1.1
3     Summary: smeserver-mock tools for building RPMs
4 jpp 1.2 %define name smeserver-mock
5 jpp 1.1 Name: %{name}
6     %define version 1.0
7 jpp 1.11 %define release 9
8 jpp 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tgz
13 jpp 1.5 Patch0: smeserver-mock-1.0-updates_values.patch
14 jpp 1.7 Patch1: smeserver-mock-1.0-sme10599-spamassassin.patch
15 jpp 1.8 Patch2: smeserver-mock-1.0-sme10600-video.patch
16 michel 1.10 Patch3: smeserver-mock-1.0-ocaml.patch
17 jpp 1.11 Patch4: smeserver-mock-1.0-sme10946-mock.patch
18 jpp 1.12 Patch5: smeserver-mock-1.0-sme10924-bins.patch
19    
20 jpp 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
21     BuildArchitectures: noarch
22     Requires: e-smith-devtools
23     Requires: mock
24     Requires: glances
25     Requires: make rpm-build rpm-sign wget
26     Requires: cmake automake libtool
27     Buildrequires: e-smith-devtools
28     # needed for scl
29     Requires: scl-utils scl-utils-build centos-release-scl centos-release-scl-rh
30 jpp 1.3 Requires: python27-build
31 jpp 1.1 AutoReqProv: no
32    
33     %changelog
34 jpp 1.11 * Thu May 14 2020 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-9.sme
35     - fix nspawn and package_manager set to yum [SME: 10946]
36     - updating list of included packages for SME10 and SME9 repo
37 jpp 1.12 - updating the attached bins to help building [SME: 10924]
38 jpp 1.11
39 michel 1.10 * Mon Sep 30 2019 Michel Begue <mab974@gmail.com> 1.0-8.sme
40     - added include pkg ocaml, camlp5 [SME: 10809]
41    
42 jpp 1.9 * Tue Nov 13 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-7.sme
43     - fix non needed Requires python-ctypes [SME: 10647]
44    
45 jpp 1.8 * Wed Jun 20 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-6.sme
46     - added include pkg for video tools [SME: 1600]
47     - applied patch for previous bug fix [SME: 10599]
48    
49 jpp 1.6 * Tue Jun 19 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-5.sme
50     - update dependencies to build spamassassin [SME: 10599]
51    
52 jpp 1.5 * Sun Mar 18 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-4.sme
53     - update include package values according to buildsys
54    
55 jpp 1.4 * Sat Mar 17 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-3.sme
56     - set %config on mock config files
57     - a rpmsave of the previous version will be created if modified.
58     - fix typo in filename
59    
60 jpp 1.3 * Sun Mar 11 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-2.sme
61     - update of site-default.cfg via post script [SME: 10537]
62     - removed e-smith-devtools of requirements
63     - added Requires python27-build
64    
65 jpp 1.1 * Sat Mar 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-1.sme
66 jpp 1.2 - Initial release with SME iServer mock config files [SME: 10537]
67 jpp 1.1 - tools added : BogusDateBot.sh change-log clog createBuildDir prepa tagbuild
68    
69     %description
70     Tools for use in building RPMs for the Koozali SME server and gateway.
71    
72     Few tools are also provided to help you with package building.
73    
74     %prep
75     %setup
76 jpp 1.5 %patch0 -p1
77 jpp 1.7 %patch1 -p1
78 jpp 1.8 %patch2 -p1
79 michel 1.10 %patch3 -p1
80 jpp 1.11 %patch4 -p1
81 jpp 1.12 %patch5 -p1
82 jpp 1.1
83     %build
84    
85     %install
86     rm -rf $RPM_BUILD_ROOT
87     (cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT)
88     /bin/rm -f %{name}-%{version}-filelist
89     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
90     --file /usr/bin/BogusDateBot.sh '%attr(0755,root,root)' \
91     --file /usr/bin/change-log '%attr(0755,root,root)' \
92     --file /usr/bin/clog '%attr(0755,root,root)' \
93     --file /usr/bin/createBuildDir '%attr(0755,root,root)' \
94     --file /usr/bin/prepa '%attr(0755,root,root)' \
95     --file /usr/bin/tagbuild '%attr(0755,root,root)' \
96 jpp 1.2 | grep -v /etc/mock/ \
97 jpp 1.1 > %{name}-%{version}-filelist
98    
99     %clean
100     rm -rf $RPM_BUILD_ROOT
101    
102     %pre
103     %preun
104     %post
105 jpp 1.3
106     # updates sme site defaults
107     main=/etc/mock/site-defaults.cfg
108     tmp=/tmp/site-defaults.cfg
109     gen=/etc/mock/sme-site-defaults.cfg
110    
111     # position of the tags
112     BEGIN_GEN=$(cat $main | grep -n '### KOOZALI SME SERVER BEGIN GENERATED CONTENT' | sed 's/\(.*\):.*/\1/g' )
113     END_GEN=$(cat $main | grep -n '### KOOZALI SME SERVER END GENERATED CONTENT' | sed 's/\(.*\):.*/\1/g' )
114     #if tag is absent set first to 0
115     if [[ "$BEGIN_GEN" -eq "" ]]; then BEGIN_GEN=0; fi
116     if [[ "$END_GEN" -eq "" ]]; then
117     # if second tag is absent just concatenate
118     cat <(head -n $(expr $BEGIN_GEN - 1) $main) $gen >$tmp;
119    
120     else
121     # if both tags are present replace content
122     cat <(head -n $(expr $BEGIN_GEN - 1) $main) $gen <(tail -n +$(expr $END_GEN + 1) $main) >$tmp;
123    
124     fi
125     # mv tmp file to main file
126     mv $tmp $main
127    
128    
129 jpp 1.1 %postun
130    
131 jpp 1.2 %files -f %{name}-%{version}-filelist
132 jpp 1.1 %defattr(-,root,root,-)
133 jpp 1.4 /etc/mock/* %config %attr(0755,root,mock)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed