1 |
jpp |
1.2 |
# $Id: smeserver-mock.spec,v 1.1 2018/03/11 04:57:18 jpp Exp $ |
2 |
jpp |
1.1 |
|
3 |
|
|
Summary: smeserver-mock tools for building RPMs |
4 |
jpp |
1.2 |
%define name smeserver-mock |
5 |
jpp |
1.1 |
Name: %{name} |
6 |
|
|
%define version 1.0 |
7 |
|
|
%define release 1 |
8 |
|
|
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Daemons |
12 |
|
|
Source: %{name}-%{version}.tgz |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: e-smith-devtools |
16 |
|
|
Requires: mock |
17 |
|
|
Requires: python-ctypes |
18 |
|
|
Requires: glances |
19 |
|
|
Requires: make rpm-build rpm-sign wget |
20 |
|
|
Requires: cmake automake libtool |
21 |
|
|
Buildrequires: e-smith-devtools |
22 |
|
|
# needed for scl |
23 |
|
|
Requires: scl-utils scl-utils-build centos-release-scl centos-release-scl-rh |
24 |
|
|
|
25 |
|
|
AutoReqProv: no |
26 |
|
|
|
27 |
|
|
%changelog |
28 |
|
|
* Sat Mar 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-1.sme |
29 |
jpp |
1.2 |
- Initial release with SME iServer mock config files [SME: 10537] |
30 |
jpp |
1.1 |
- tools added : BogusDateBot.sh change-log clog createBuildDir prepa tagbuild |
31 |
|
|
|
32 |
|
|
%description |
33 |
|
|
Tools for use in building RPMs for the Koozali SME server and gateway. |
34 |
|
|
|
35 |
|
|
Few tools are also provided to help you with package building. |
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
%setup |
39 |
|
|
|
40 |
|
|
%build |
41 |
|
|
|
42 |
|
|
%install |
43 |
|
|
rm -rf $RPM_BUILD_ROOT |
44 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
45 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
46 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
47 |
|
|
--file /usr/bin/BogusDateBot.sh '%attr(0755,root,root)' \ |
48 |
|
|
--file /usr/bin/change-log '%attr(0755,root,root)' \ |
49 |
|
|
--file /usr/bin/clog '%attr(0755,root,root)' \ |
50 |
|
|
--file /usr/bin/createBuildDir '%attr(0755,root,root)' \ |
51 |
|
|
--file /usr/bin/prepa '%attr(0755,root,root)' \ |
52 |
|
|
--file /usr/bin/tagbuild '%attr(0755,root,root)' \ |
53 |
jpp |
1.2 |
| grep -v /etc/mock/ \ |
54 |
jpp |
1.1 |
> %{name}-%{version}-filelist |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%pre |
60 |
|
|
%preun |
61 |
|
|
%post |
62 |
|
|
%postun |
63 |
|
|
|
64 |
jpp |
1.2 |
%files -f %{name}-%{version}-filelist |
65 |
jpp |
1.1 |
%defattr(-,root,root,-) |
66 |
jpp |
1.2 |
/etc/mock/* %attr(0755,root,mock) |