/[smeserver]/rpms/smeserver-mock/sme10/smeserver-mock.spec
ViewVC logotype

Annotation of /rpms/smeserver-mock/sme10/smeserver-mock.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.8 - (hide annotations) (download)
Thu Jun 21 03:25:27 2018 UTC (5 years, 11 months ago) by jpp
Branch: MAIN
CVS Tags: smeserver-mock-1_0-6_el7_sme
Changes since 1.7: +8 -2 lines
* Wed Jun 20 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-6.sme
- added include pkg for video tools [SME: 1600]
- applied patch for previous bug fix [SME: 10599]

1 jpp 1.8 # $Id: smeserver-mock.spec,v 1.7 2018/06/21 03:21:19 jpp Exp $
2 jpp 1.1
3     Summary: smeserver-mock tools for building RPMs
4 jpp 1.2 %define name smeserver-mock
5 jpp 1.1 Name: %{name}
6     %define version 1.0
7 jpp 1.8 %define release 6
8 jpp 1.1 Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPL
11     Group: Networking/Daemons
12     Source: %{name}-%{version}.tgz
13 jpp 1.5 Patch0: smeserver-mock-1.0-updates_values.patch
14 jpp 1.7 Patch1: smeserver-mock-1.0-sme10599-spamassassin.patch
15 jpp 1.8 Patch2: smeserver-mock-1.0-sme10600-video.patch
16 jpp 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
17     BuildArchitectures: noarch
18     Requires: e-smith-devtools
19     Requires: mock
20     Requires: python-ctypes
21     Requires: glances
22     Requires: make rpm-build rpm-sign wget
23     Requires: cmake automake libtool
24     Buildrequires: e-smith-devtools
25     # needed for scl
26     Requires: scl-utils scl-utils-build centos-release-scl centos-release-scl-rh
27 jpp 1.3 Requires: python27-build
28 jpp 1.1 AutoReqProv: no
29    
30     %changelog
31 jpp 1.8 * Wed Jun 20 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-6.sme
32     - added include pkg for video tools [SME: 1600]
33     - applied patch for previous bug fix [SME: 10599]
34    
35 jpp 1.6 * Tue Jun 19 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-5.sme
36     - update dependencies to build spamassassin [SME: 10599]
37    
38 jpp 1.5 * Sun Mar 18 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-4.sme
39     - update include package values according to buildsys
40    
41 jpp 1.4 * Sat Mar 17 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-3.sme
42     - set %config on mock config files
43     - a rpmsave of the previous version will be created if modified.
44     - fix typo in filename
45    
46 jpp 1.3 * Sun Mar 11 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-2.sme
47     - update of site-default.cfg via post script [SME: 10537]
48     - removed e-smith-devtools of requirements
49     - added Requires python27-build
50    
51 jpp 1.1 * Sat Mar 10 2018 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-1.sme
52 jpp 1.2 - Initial release with SME iServer mock config files [SME: 10537]
53 jpp 1.1 - tools added : BogusDateBot.sh change-log clog createBuildDir prepa tagbuild
54    
55     %description
56     Tools for use in building RPMs for the Koozali SME server and gateway.
57    
58     Few tools are also provided to help you with package building.
59    
60     %prep
61     %setup
62 jpp 1.5 %patch0 -p1
63 jpp 1.7 %patch1 -p1
64 jpp 1.8 %patch2 -p1
65 jpp 1.1
66     %build
67    
68     %install
69     rm -rf $RPM_BUILD_ROOT
70     (cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT)
71     /bin/rm -f %{name}-%{version}-filelist
72     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
73     --file /usr/bin/BogusDateBot.sh '%attr(0755,root,root)' \
74     --file /usr/bin/change-log '%attr(0755,root,root)' \
75     --file /usr/bin/clog '%attr(0755,root,root)' \
76     --file /usr/bin/createBuildDir '%attr(0755,root,root)' \
77     --file /usr/bin/prepa '%attr(0755,root,root)' \
78     --file /usr/bin/tagbuild '%attr(0755,root,root)' \
79 jpp 1.2 | grep -v /etc/mock/ \
80 jpp 1.1 > %{name}-%{version}-filelist
81    
82     %clean
83     rm -rf $RPM_BUILD_ROOT
84    
85     %pre
86     %preun
87     %post
88 jpp 1.3
89     # updates sme site defaults
90     main=/etc/mock/site-defaults.cfg
91     tmp=/tmp/site-defaults.cfg
92     gen=/etc/mock/sme-site-defaults.cfg
93    
94     # position of the tags
95     BEGIN_GEN=$(cat $main | grep -n '### KOOZALI SME SERVER BEGIN GENERATED CONTENT' | sed 's/\(.*\):.*/\1/g' )
96     END_GEN=$(cat $main | grep -n '### KOOZALI SME SERVER END GENERATED CONTENT' | sed 's/\(.*\):.*/\1/g' )
97     #if tag is absent set first to 0
98     if [[ "$BEGIN_GEN" -eq "" ]]; then BEGIN_GEN=0; fi
99     if [[ "$END_GEN" -eq "" ]]; then
100     # if second tag is absent just concatenate
101     cat <(head -n $(expr $BEGIN_GEN - 1) $main) $gen >$tmp;
102    
103     else
104     # if both tags are present replace content
105     cat <(head -n $(expr $BEGIN_GEN - 1) $main) $gen <(tail -n +$(expr $END_GEN + 1) $main) >$tmp;
106    
107     fi
108     # mv tmp file to main file
109     mv $tmp $main
110    
111    
112 jpp 1.1 %postun
113    
114 jpp 1.2 %files -f %{name}-%{version}-filelist
115 jpp 1.1 %defattr(-,root,root,-)
116 jpp 1.4 /etc/mock/* %config %attr(0755,root,mock)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed