/[smeserver]/rpms/smolt/sme7/smolt.spec
ViewVC logotype

Annotation of /rpms/smolt/sme7/smolt.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.6 - (hide annotations) (download)
Wed Apr 9 13:51:57 2008 UTC (16 years, 2 months ago) by slords
Branch: MAIN
Changes since 1.5: +2 -0 lines
Add Id to top of spec

1 slords 1.6 # $Id$
2    
3 slords 1.1 Name: smolt
4     Summary: Fedora hardware profiler
5     Version: 0.9.8.1
6 bytegw 1.5 Release: 8%{?dist}
7 slords 1.1 License: GPL
8     Group: Applications/Internet
9     URL: http://hosted.fedoraproject.org/projects/smolt
10    
11     # Note: This is a link to the gzip, you can't download it directly
12     # This will get fixed as soon as hosted can create attachments directly
13    
14     Source: https://hosted.fedoraproject.org/projects/smolt/attachment/wiki/WikiStart/%{name}-%{version}.tar.gz
15     Patch0: smolt-0.9.8.1-sme.patch
16     Patch1: smolt-0.9.8.1-sme.patch2
17 slords 1.2 Patch2: smolt-0.9.8.1-sme.patch3
18 slords 1.3 Patch3: smolt-0.9.8.1-weekly.patch
19 bytegw 1.4 Patch4: smolt-0.9.8.1-motd.patch
20     Patch5: smolt-0.9.8.1-smoonURL.patch
21 slords 1.1 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22    
23     BuildArch: noarch
24     Requires: dbus-python
25     BuildRequires: gettext
26     BuildRequires: /usr/bin/msgfmt.py
27     BuildRequires: desktop-file-utils
28    
29     Requires(post): /sbin/chkconfig
30     Requires(preun): /sbin/chkconfig
31     Requires(preun): /sbin/service
32     Requires(postun): /sbin/service
33    
34     %description
35 bytegw 1.5 The Smolt hardware profiler is a server-client system that does a hardware
36     scan against a machine and sends the results to a public Contribs project
37     server. The sends are anonymous and should not contain any private
38 slords 1.1 information other than the physical hardware information and basic OS info.
39    
40     This package contains the client
41    
42     %package server
43 bytegw 1.5 Summary: Hardware profiler server
44 slords 1.1 Group: Applications/Internet
45     Requires: smolt = %{version}-%{release}
46     Requires: TurboGears
47    
48     %description server
49 bytegw 1.5 The Smolt hardware profiler is a server-client system that does a hardware
50     scan against a machine and sends the results to a public Contribs project
51     server. The sends are anonymous and should not contain any private
52 slords 1.1 information other than the physical hardware information and basic OS info.
53    
54     This package contains the server portion
55    
56     %package firstboot
57 bytegw 1.5 Summary: Hardware profile firstboot
58 slords 1.1 Group: Applications/Internet
59     Requires: smolt = %{version}-%{release}
60    
61     %description firstboot
62     This provides firstboot integration for smolt. It has been broken into a
63     separate package so firstboot isn't a requisite to use smolt.
64    
65     %package gui
66 bytegw 1.5 Summary: Hardware profiler gui
67 slords 1.1 Group: Applications/Internet
68     Requires: smolt = %{version}-%{release}
69    
70     %description gui
71     Provides smolt's gui functionality. Not included in the default package to
72     ensure that deps are kept small.
73    
74     %prep
75     %setup -q
76     %patch0 -p1
77     %patch1 -p1
78 slords 1.2 %patch2 -p1
79 slords 1.3 %patch3 -p1
80 bytegw 1.4 %patch4 -p1
81     %patch5 -p1
82 slords 1.1
83     %build
84     cd client/
85     make
86    
87     %install
88     %{__rm} -rf %{buildroot}
89     %{__install} -d -m 0755 smoon/ %{buildroot}/%{_datadir}/%{name}/smoon/
90     %{__cp} -adv smoon/* %{buildroot}/%{_datadir}/%{name}/smoon/
91    
92     %{__mkdir} -p %{buildroot}/%{_sysconfdir}/sysconfig/
93     %{__mkdir} -p %{buildroot}/%{_sysconfdir}/cron.d/
94     %{__mkdir} -p %{buildroot}/%{_bindir}
95     %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/modules/
96     %{__mkdir} -p %{buildroot}/%{_initrddir}
97     %{__mkdir} -p %{buildroot}/%{_datadir}/locale/
98     %{__mv} client/smoltFirstBoot.py %{buildroot}/%{_datadir}/firstboot/modules/smolt.py
99     %{__mv} client/smolt-init %{buildroot}/%{_initrddir}/smolt
100 slords 1.3 %{__mv} client/smolt.cron.weekly %{buildroot}/%{_sysconfdir}/cron.d/smolt
101 slords 1.1 %{__cp} -adv client/po/* %{buildroot}/%{_datadir}/locale/
102    
103     find %{buildroot} -name \*.po\* -exec rm {} \;
104    
105     touch %{buildroot}/%{_sysconfdir}/sysconfig/hw-uuid
106    
107     %{__install} -d -m 0755 client/ %{buildroot}/%{_datadir}/%{name}/client/
108     %{__install} -d -m 0755 client/icons/ %{buildroot}/%{_datadir}/%{name}/client/icons/
109     %{__cp} -adv client/*.py %{buildroot}/%{_datadir}/%{name}/client/
110    
111     # Icons
112     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/16x16/apps/
113     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/22x22/apps/
114     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/24x24/apps/
115     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/
116     %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/pixmaps/
117     %{__mv} client/icons/smolt-icon-16.png %{buildroot}/%{_datadir}/icons/hicolor/16x16/apps/smolt.png
118     %{__mv} client/icons/smolt-icon-22.png %{buildroot}/%{_datadir}/icons/hicolor/22x22/apps/smolt.png
119     %{__mv} client/icons/smolt-icon-24.png %{buildroot}/%{_datadir}/icons/hicolor/24x24/apps/smolt.png
120     %{__mv} client/icons/smolt-icon-32.png %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/smolt.png
121     %{__cp} -adv client/icons/* %{buildroot}/%{_datadir}/%{name}/client/icons/
122     %{__cp} -adv client/icons/smolt-icon-48.png %{buildroot}/%{_datadir}/firstboot/pixmaps/smolt.png
123    
124     %{__mkdir} -p %{buildroot}/%{_datadir}/%{name}/doc
125     %{__install} -p -m 0644 doc/PrivacyPolicy %{buildroot}/%{_datadir}/%{name}/doc
126    
127     ln -s %{_datadir}/%{name}/client/sendProfile.py %{buildroot}/%{_bindir}/smoltSendProfile
128     ln -s %{_datadir}/%{name}/client/deleteProfile.py %{buildroot}/%{_bindir}/smoltDeleteProfile
129     ln -s %{_datadir}/%{name}/client/smoltGui.py %{buildroot}/%{_bindir}/smoltGui
130    
131     %{__chmod} +x %{buildroot}/%{_datadir}/%{name}/client/*Profile.py
132     %{__chmod} +x %{buildroot}/%{_datadir}/%{name}/client/smoltGui.py
133     %{__chmod} +x %{buildroot}/%{_initrddir}/smolt
134    
135     desktop-file-install --vendor='fedora' --dir=%{buildroot}/%{_datadir}/applications client/smolt.desktop
136    
137     %find_lang %{name}
138    
139     %clean
140     rm -rf %{buildroot}
141    
142     %post
143     /sbin/chkconfig --add smolt
144     if ! [ -f %{_sysconfdir}/sysconfig/hw-uuid ]
145     then
146     /bin/cat /proc/sys/kernel/random/uuid > %{_sysconfdir}/sysconfig/hw-uuid
147     /bin/chmod 0644 %{_sysconfdir}/sysconfig/hw-uuid
148     /bin/chown root:root %{_sysconfdir}/sysconfig/hw-uuid
149     fi
150    
151     %preun
152     if [ $1 = 0 ]; then
153     /sbin/service smolt stop >/dev/null 2>&1
154     /sbin/chkconfig --del smolt
155     fi
156    
157     %files -f %{name}.lang
158     %defattr(-,root,root,-)
159     %doc README GPL doc/*
160     %dir %{_datadir}/%{name}
161     %{_datadir}/%{name}/client
162     %{_datadir}/%{name}/doc
163     %{_bindir}/smoltSendProfile
164     %{_bindir}/smoltDeleteProfile
165     %{_sysconfdir}/cron.d/%{name}
166     %{_initrddir}/%{name}
167     %ghost %config(noreplace) %{_sysconfdir}/sysconfig/hw-uuid
168    
169     %files server
170     %defattr(-,root,root,-)
171     %{_datadir}/%{name}/smoon
172    
173     %files firstboot
174     %defattr(-,root,root,-)
175     %{_datadir}/firstboot/modules/smolt.py*
176     %{_datadir}/firstboot/pixmaps/smolt.png
177    
178     %files gui
179     %defattr(-,root,root,-)
180     %{_datadir}/applications/fedora-smolt.desktop
181     %{_datadir}/icons/hicolor/*x*/apps/smolt.png
182     %{_bindir}/smoltGui
183    
184     %changelog
185 bytegw 1.5 * Sun Jan 20 2008 Stephen Noble <support@dungog.net> - 0.9.8.1-8
186     - Change rpm description to refer to Contribs [SME: 3758]
187    
188 bytegw 1.4 * Mon Jan 7 2008 Stephen Noble <support@dungog.net> - 0.9.8.1-7
189     - change smoonURL to contribs.org [SME: 3265]
190    
191     * Mon Jan 7 2008 Stephen Noble <support@dungog.net> - 0.9.8.1-6
192     - look in e-smith-release first [SME: 3258]
193    
194 slords 1.3 * Tue Jul 3 2007 Shad L. Lords <slords@lordsfam.net> - 0.9.8.1-5
195     - Make smolt checkins weekly instead of monthly.
196    
197 slords 1.2 * Sun Jul 1 2007 Shad L. Lords <slords@lordsfam.net> - 0.9.8.1-4
198     - Specify full paths so commands will run.
199    
200 slords 1.1 * Thu Jun 7 2007 Shad L. Lords <slords@lordsfam.net> - 0.9.8.1-3
201     - More patches for both el4 and sme.
202    
203     * Wed Jun 6 2007 Shad L. Lords <slords@lordsfam.net> - 0.9.8.1-2
204     - Patch to work with el4 and point at sme smolt server.
205    
206     * Thu May 24 2007 Mike McGrath <mmcgrath@redhat.com> - 0.9.8.1
207     - Upstream released new version
208    
209     * Sun Apr 22 2007 Mike McGrath <mmcgrath@redhat.com> - 0.9.7.1-3
210     - Added smolt icons
211    
212     * Tue Apr 17 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.6-4
213     - Add standard scriptlets in pre & post to handle init script - fixes #236776
214     - Use the find_lang macro to find/mark translations.
215    
216     * Fri Apr 13 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.6-3
217     - Put a copy of the privacy policy where the client is expecting it.
218    
219     * Wed Apr 11 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.6-2
220     - Upstream released new version.
221     - Much better support for languages on the client
222    
223     * Fri Mar 16 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.4-1
224     - Upstream released new version
225     - Major changes
226     - Added initial i18n support (Probably doesn't work)
227    
228     * Fri Mar 01 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.2-1
229     - Fixed firstboot
230     - Upstream released new version
231    
232     * Fri Mar 01 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.1-1
233     - Upstream released new version, major smoon changes.
234    
235     * Mon Feb 19 2007 Mike McGrath <mmcgrath@redhat.com> 0.9-1
236     - Upstream released new version
237    
238     * Mon Feb 12 2007 Mike McGrath <imlinux@gmail.com> 0.8-1
239     - New version released, major changes in both server and client
240    
241     * Wed Feb 07 2007 Mike McGrath <imlinux@gmail.com> 0.7-1
242     - Upstream released new version
243    
244     * Tue Jan 31 2007 Mike McGrath <imlinux@gmail.com> 0.6.2-1
245     - Upstream released new version (bug in firstboot)
246    
247     * Tue Jan 30 2007 Mike McGrath <imlinux@gmail.com> 0.6.1-3
248     - Removed LSB requirement for sparc
249    
250     * Tue Jan 30 2007 Mike McGrath <imlinux@gmail.com> 0.6.1-2
251     - Added firstboot
252     - Upstream released new version
253    
254     * Mon Jan 29 2007 Mike McGrath <imlinux@gmail.com> 0.6-1
255     - Upstream released new version
256     - Added new symlinks for smoltPrint and smoltSendProfile
257    
258     * Thu Jan 25 2007 Mike McGrath <imlinux@gmail.com> 0.5-4
259     - Forgot Requires of dbus-python
260    
261     * Wed Jan 24 2007 Mike McGrath <imlinux@gmail.com> 0.5-3
262     - Fixed silly bash syntax error
263    
264     * Thu Jan 22 2007 Mike McGrath <imlinux@gmail.com> 0.5-2
265     - s/turbogears/TurboGears/
266    
267     * Thu Jan 22 2007 Mike McGrath <imlinux@gmail.com> 0.5-1
268     - Upstream released new version
269     - Fixed small bug in post
270    
271     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.4-2
272     - Added comment about the not directly available tar-gzip file
273    
274     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.4-1
275     - New upstream version
276     - Altered post install section
277     - Added wget requires
278    
279     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.3-1
280     - Upstream released new version
281    
282     * Tue Jan 16 2006 Mike McGrath <imlinux@gmail.com> 0.2-1
283     - Initial Packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed