/[smeserver]/rpms/smolt/sme7/smolt.spec
ViewVC logotype

Annotation of /rpms/smolt/sme7/smolt.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.9 - (hide annotations) (download)
Sat Mar 6 16:53:30 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: smolt-1_4_3-3_el4_sme
Changes since 1.8: +5 -2 lines
Update

1 slords 1.9 # $Id: smolt.spec,v 1.8 2010/03/04 16:31:07 slords Exp $
2 slords 1.8
3 slords 1.7 Name: smolt
4 slords 1.6
5 slords 1.7 Summary: SME Server hardware profiler
6     Version: 1.4.3
7 slords 1.9 Release: 3%{?dist}
8 slords 1.7 License: GPLv2+
9 slords 1.1 Group: Applications/Internet
10 slords 1.7 URL: http://fedorahosted.org/smolt
11     Source: https://fedorahosted.org/releases/s/m/%{name}/%{name}-%{version}.tar.gz
12     Patch1: smolt-1.4.3-el4.patch
13     Patch2: smolt-1.4.3-sme.patch
14 slords 1.1 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15    
16 slords 1.7 Requires: dbus-python, python-urlgrabber, gawk, python-paste, hal, python-ctypes
17 slords 1.1 BuildArch: noarch
18     BuildRequires: gettext
19     BuildRequires: desktop-file-utils
20    
21 slords 1.7 Requires(pre): %{_sbindir}/groupadd
22     Requires(pre): %{_sbindir}/useradd
23 slords 1.1 Requires(post): /sbin/chkconfig
24     Requires(preun): /sbin/chkconfig
25     Requires(preun): /sbin/service
26     Requires(postun): /sbin/service
27 slords 1.7 Requires: python-simplejson
28 slords 1.1
29     %description
30 slords 1.7 The SME Server hardware profiler is a server-client system that does a hardware
31     scan against a machine and sends the results to a public SME Server Project
32     turbogears server. The sends are anonymous and should not contain any private
33 slords 1.1 information other than the physical hardware information and basic OS info.
34    
35     This package contains the client
36    
37     %package server
38 slords 1.7 Summary: SME Server hardware profiler server
39 slords 1.1 Group: Applications/Internet
40     Requires: smolt = %{version}-%{release}
41 slords 1.7 Requires: python-genshi
42     Requires: python-crypto
43     Requires: TurboGears mx
44     Requires: python-turboflot
45 slords 1.1
46     %description server
47 slords 1.7 The SME Server hardware profiler is a server-client system that does a hardware
48     scan against a machine and sends the results to a public SME Server Project
49     turbogears server. The sends are anonymous and should not contain any private
50 slords 1.1 information other than the physical hardware information and basic OS info.
51    
52     This package contains the server portion
53    
54     %package firstboot
55 slords 1.7 Summary: SME Server hardware profile firstboot
56 slords 1.1 Group: Applications/Internet
57     Requires: smolt = %{version}-%{release}
58    
59     %description firstboot
60     This provides firstboot integration for smolt. It has been broken into a
61     separate package so firstboot isn't a requisite to use smolt.
62    
63     %package gui
64 slords 1.7 Summary: SME Server hardware profiler gui
65 slords 1.1 Group: Applications/Internet
66     Requires: smolt = %{version}-%{release}
67 slords 1.7 Requires: PyQt4
68 slords 1.1
69     %description gui
70     Provides smolt's gui functionality. Not included in the default package to
71     ensure that deps are kept small.
72    
73     %prep
74     %setup -q
75     %patch1 -p1
76 slords 1.2 %patch2 -p1
77 slords 1.1
78     %build
79     cd client/
80     make
81    
82     %install
83     %{__rm} -rf %{buildroot}
84 slords 1.7 cd client
85     DESTDIR=%{buildroot} make install
86     cd ..
87 slords 1.1 %{__install} -d -m 0755 smoon/ %{buildroot}/%{_datadir}/%{name}/smoon/
88 slords 1.7 %{__mkdir} -p %{buildroot}/%{_mandir}/man1/
89 slords 1.1 %{__cp} -adv smoon/* %{buildroot}/%{_datadir}/%{name}/smoon/
90 slords 1.7 %{__cp} client/scan.py %{buildroot}/%{_datadir}/%{name}/client/
91     %{__cp} client/gate.py %{buildroot}/%{_datadir}/%{name}/client/
92     %{__cp} client/os_detect.py %{buildroot}/%{_datadir}/%{name}/client/
93     %{__cp} client/fs_util.py %{buildroot}/%{_datadir}/%{name}/client/
94     %{__cp} client/man/* %{buildroot}/%{_mandir}/man1/
95 slords 1.1
96     %{__mkdir} -p %{buildroot}/%{_sysconfdir}/sysconfig/
97     %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/modules/
98     %{__mkdir} -p %{buildroot}/%{_initrddir}
99 slords 1.7
100 slords 1.1 %{__mv} client/smoltFirstBoot.py %{buildroot}/%{_datadir}/firstboot/modules/smolt.py
101     %{__mv} client/smolt-init %{buildroot}/%{_initrddir}/smolt
102    
103     touch %{buildroot}/%{_sysconfdir}/sysconfig/hw-uuid
104    
105     # Icons
106     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/16x16/apps/
107     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/22x22/apps/
108     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/24x24/apps/
109     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/
110 slords 1.7
111 slords 1.1 %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/pixmaps/
112 slords 1.7 %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/themes/default/
113    
114 slords 1.1 %{__mv} client/icons/smolt-icon-16.png %{buildroot}/%{_datadir}/icons/hicolor/16x16/apps/smolt.png
115     %{__mv} client/icons/smolt-icon-22.png %{buildroot}/%{_datadir}/icons/hicolor/22x22/apps/smolt.png
116     %{__mv} client/icons/smolt-icon-24.png %{buildroot}/%{_datadir}/icons/hicolor/24x24/apps/smolt.png
117     %{__mv} client/icons/smolt-icon-32.png %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/smolt.png
118     %{__cp} -adv client/icons/* %{buildroot}/%{_datadir}/%{name}/client/icons/
119 slords 1.7 %{__cp} -adv client/icons/smolt-icon-48.png %{buildroot}/%{_datadir}/firstboot/themes/default/smolt.png
120 slords 1.1
121 slords 1.7 %{__rm} -f %{buildroot}/%{_bindir}/smoltSendProfile %{buildroot}/%{_bindir}/smoltDeleteProfile %{buildroot}/%{_bindir}/smoltGui
122     %{__rm} -f %{buildroot}/%{_datadir}/%{name}/client/config.py
123 slords 1.1
124     ln -s %{_datadir}/%{name}/client/sendProfile.py %{buildroot}/%{_bindir}/smoltSendProfile
125     ln -s %{_datadir}/%{name}/client/deleteProfile.py %{buildroot}/%{_bindir}/smoltDeleteProfile
126     ln -s %{_datadir}/%{name}/client/smoltGui.py %{buildroot}/%{_bindir}/smoltGui
127 slords 1.7 ln -s %{_sysconfdir}/%{name}/config.py %{buildroot}/%{_datadir}/%{name}/client/config.py
128 slords 1.1
129    
130     desktop-file-install --vendor='fedora' --dir=%{buildroot}/%{_datadir}/applications client/smolt.desktop
131 slords 1.7 %{__rm} -f %{buildroot}/%{_datadir}/applications/smolt.desktop
132     %find_lang %{name}
133 slords 1.1
134 slords 1.7 # Cleanup from the Makefile (will be cleaned up when it is finalized)
135     %{__rm} -f %{buildroot}/etc/init.d/smolt
136     %{__rm} -f %{buildroot}/etc/smolt/hw-uuid
137 slords 1.1
138     %clean
139     rm -rf %{buildroot}
140    
141 slords 1.7 %pre
142     %{_sbindir}/groupadd -r %{name} &>/dev/null || :
143     %{_sbindir}/useradd -r -s /sbin/nologin -d %{_datadir}/%{name} -M \
144     -c 'Smolt' -g %{name} %{name} &>/dev/null || :
145    
146 slords 1.1 %post
147     /sbin/chkconfig --add smolt
148 slords 1.7
149     #Randomize checkin times.
150     TMPFILE=$(/bin/mktemp /tmp/smolt.XXXXX)
151     /bin/awk '{ srand(); if($2 == 1 && $3 == 1) print $1,int((rand() * 100) % 22 + 1),int((rand() * 100) % 27 + 1),substr($0,index($0,$4)); else print $0}' /etc/cron.d/smolt > $TMPFILE
152     /bin/cp $TMPFILE /etc/cron.d/smolt
153     /bin/rm -f $TMPFILE
154 slords 1.1
155     %preun
156     if [ $1 = 0 ]; then
157     /sbin/service smolt stop >/dev/null 2>&1
158     /sbin/chkconfig --del smolt
159     fi
160    
161 slords 1.7 %post server
162     #Fail, will fix later
163     for f in delete.html deviceclass.html device.html devices.html error.html \
164     link.html login.html master.html myHosts.html notLoaded.html \
165     pub_uuid.html raw.html report_device_ratings.html \
166     report_host_ratings.html report_recent.html report_search_devices.html\
167     report_search.html report_search_profiles.html report_view_device.html\
168     report_view_devices.html report_view.html report_view_profile.html \
169     report_view_profiles.html showall.html show.html stats.html token.html\
170     welcome.html
171     do
172     touch %{_datadir}/%{name}/smoon/hardware/static/stats/$f
173     done
174    
175     %post gui
176     touch --no-create %{_datadir}/icons/hicolor || :
177     %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
178    
179     %postun gui
180     touch --no-create %{_datadir}/icons/hicolor || :
181     %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
182    
183 slords 1.1 %files -f %{name}.lang
184     %defattr(-,root,root,-)
185     %doc README GPL doc/*
186     %dir %{_datadir}/%{name}
187 slords 1.7 %dir %{_sysconfdir}/%{name}/
188 slords 1.1 %{_datadir}/%{name}/client
189 slords 1.7 #%ghost %{_datadir}/%{name}/client/scan.pyc
190     #%ghost %{_datadir}/%{name}/client/scan.pyo
191 slords 1.1 %{_datadir}/%{name}/doc
192     %{_bindir}/smoltSendProfile
193     %{_bindir}/smoltDeleteProfile
194 slords 1.7 %config(noreplace) /%{_sysconfdir}/%{name}/config*
195 slords 1.1 %{_sysconfdir}/cron.d/%{name}
196 slords 1.7 %{_mandir}/man1/*gz
197 slords 1.1 %{_initrddir}/%{name}
198     %ghost %config(noreplace) %{_sysconfdir}/sysconfig/hw-uuid
199    
200     %files server
201     %defattr(-,root,root,-)
202     %{_datadir}/%{name}/smoon
203    
204     %files firstboot
205     %defattr(-,root,root,-)
206     %{_datadir}/firstboot/modules/smolt.py*
207 slords 1.7 %{_datadir}/firstboot/themes/default/smolt.png
208 slords 1.1
209     %files gui
210     %defattr(-,root,root,-)
211     %{_datadir}/applications/fedora-smolt.desktop
212     %{_datadir}/icons/hicolor/*x*/apps/smolt.png
213     %{_bindir}/smoltGui
214    
215     %changelog
216 slords 1.9 * Sat Feb 6 2010 Shad L. Lords <slords@mail.com> 1.4.2-3.sme
217     - Make cronjob run as admin so we can get system type
218    
219 slords 1.7 * Mon Feb 3 2010 Shad L. Lords <slords@mail.com> 1.4.2-2.sme
220     - Apply patches so smolt will run under el4
221     - Apply sme specific patches
222    
223     * Mon Jan 25 2010 Mike McGrath <mmcgrath@redhat.com> 1.4.2-1
224     - Upstream released new version
225     - Added hal requires
226    
227     * Tue Oct 13 2009 Mike McGrath <mmcgrath@redhat.com> 1.4-4
228     - Fixing firstboot for F-12
229    
230     * Mon Sep 21 2009 Mike McGrath <mmcgrath@redhat.com> 1.4-2
231     - Patched issue with translations (already upstream)
232    
233     * Mon Sep 14 2009 Mike McGrath <mmcgrath@redhat.com> 1.4-1
234     - Upstream released new version
235    
236     * Thu Sep 10 2009 Mike McGrath <mmcgrath@redhat.com> - 1.3.2-2
237     - Added requires for PyQt4 on smolt gui
238    
239     * Thu Sep 03 2009 Mike McGrath <mmcgrath@redhat.com> - 1.3.2-1
240     - Upstream released new version
241     - Changed some link and copy info
242    
243     * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-2
244     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
245    
246     * Thu Jul 02 2009 Mike McGrath <mmcgrath@redhat.com> - 1.3-1
247     - Added touch for generated stats
248     - Upstream released new version
249    
250     * Tue Apr 14 2009 Mike McGrath <mmcgrath@redhat.com> - 1.2-4.2
251     - Removed fake attack
252    
253     * Fri Mar 13 2009 Mike McGrath <mmcgrath@redhat.com> - 1.2-4.1
254     - Fixed some formatting in the spec file
255     - Added note to %post
256    
257     * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-4
258     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
259    
260     * Wed Jan 21 2009 Mike McGrath <mmcgrath@redhat.com> - 1.2-3
261     - Added os_detect.py as it is now required.
262    
263     * Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2-2
264     - Rebuild for Python 2.6
265 bytegw 1.5
266 slords 1.7 * Sun Nov 30 2008 Mike McGrath <mmcgrath@redhat.com> 1.2-1
267     - Upstream released new version
268    
269     * Fri Nov 21 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-10
270     - Fix for bug 472101
271    
272     * Wed Nov 12 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-9
273     - Fix for bug 470829
274    
275     * Tue Nov 11 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-8
276     - Added patch for fixed scanner
277    
278     * Wed Oct 1 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-7
279     - Fix for 439496
280    
281     * Sun Sep 7 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-6
282     - Added turboflot to server, removed from firstboot
283    
284     * Thu Sep 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.1.1-5
285     - fix license tag
286    
287     * Thu Apr 03 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-4
288     - One revert for rawhide
289    
290     * Sat Mar 08 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-3
291     - Fixing firstboot again for 437708, 437765
292    
293     * Sat Mar 08 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-2
294     - Fix firstboot for 437708, 437765
295    
296     * Sat Mar 08 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-1
297     - Upstream released new version
298    
299     * Wed Mar 05 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1-1
300     - Upstream released new version
301     - Manfiles added
302     - Source location updated
303    
304     * Wed Feb 27 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1-3
305     - Copy instead of move cron file so that selinux contexts are set
306     properly. (BZ#435050)
307    
308     * Wed Feb 27 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1-2
309     - Create smolt user. (BZ#435136)
310 bytegw 1.4
311 slords 1.7 * Fri Feb 01 2008 Mike McGrath <mmcgrath@redhat.com> 1.0-5
312     - Added a req for mx on smoon
313 bytegw 1.4
314 slords 1.7 * Thu Jan 08 2008 Mike McGrath <mmcgrath@redhat.com> 1.0-4
315     - Fixed firstboot
316    
317     * Thu Jan 08 2008 Mike McGrath <mmcgrath@redhat.com> 1.0-3
318     - Added python-urlgrabber as a requires - 427969
319    
320     * Thu Nov 22 2007 Mike McGrath <mmcgrath@redhat.com> 1.0-2
321     - Installed scanner - #395901
322    
323     * Tue Nov 20 2007 Mike McGrath <mmcgrath@redhat.com> 1.0-1
324     - Upstream released new version
325    
326     * Tue Oct 25 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9.2-1
327     - Upstream released new version
328    
329     * Tue Oct 23 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9.1-4
330     - Upstream released new version
331    
332     * Thu Oct 18 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9-2
333     - Fixed /etc/smolt/ ownership issue
334    
335     * Tue Oct 16 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9-1
336     - Upstream released new version
337 slords 1.3
338 slords 1.7 * Fri Sep 28 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-8
339     - Fixed Selinux
340 slords 1.2
341 slords 1.7 * Thu Sep 27 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-6
342     - Added translations
343 slords 1.1
344 slords 1.7 * Fri Sep 21 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-5
345     - Fixed firstboot issues
346    
347     * Mon Aug 13 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-4
348     - Rebuild to clean up 'config.py' compilations
349    
350     * Mon Aug 13 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-1
351     - Upstream released new version (major changes)
352     - New config file
353     - New Makefile
354     - Added deps
355    
356     * Fri Jun 22 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.3
357     - Upstream released new version
358 slords 1.1
359     * Thu May 24 2007 Mike McGrath <mmcgrath@redhat.com> - 0.9.8.1
360     - Upstream released new version
361    
362     * Sun Apr 22 2007 Mike McGrath <mmcgrath@redhat.com> - 0.9.7.1-3
363     - Added smolt icons
364    
365     * Tue Apr 17 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.6-4
366     - Add standard scriptlets in pre & post to handle init script - fixes #236776
367     - Use the find_lang macro to find/mark translations.
368    
369     * Fri Apr 13 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.6-3
370     - Put a copy of the privacy policy where the client is expecting it.
371    
372     * Wed Apr 11 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.6-2
373     - Upstream released new version.
374     - Much better support for languages on the client
375    
376     * Fri Mar 16 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.4-1
377     - Upstream released new version
378     - Major changes
379     - Added initial i18n support (Probably doesn't work)
380    
381     * Fri Mar 01 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.2-1
382     - Fixed firstboot
383     - Upstream released new version
384    
385     * Fri Mar 01 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.1-1
386     - Upstream released new version, major smoon changes.
387    
388     * Mon Feb 19 2007 Mike McGrath <mmcgrath@redhat.com> 0.9-1
389     - Upstream released new version
390    
391     * Mon Feb 12 2007 Mike McGrath <imlinux@gmail.com> 0.8-1
392     - New version released, major changes in both server and client
393    
394     * Wed Feb 07 2007 Mike McGrath <imlinux@gmail.com> 0.7-1
395     - Upstream released new version
396    
397     * Tue Jan 31 2007 Mike McGrath <imlinux@gmail.com> 0.6.2-1
398     - Upstream released new version (bug in firstboot)
399    
400     * Tue Jan 30 2007 Mike McGrath <imlinux@gmail.com> 0.6.1-3
401     - Removed LSB requirement for sparc
402    
403     * Tue Jan 30 2007 Mike McGrath <imlinux@gmail.com> 0.6.1-2
404     - Added firstboot
405     - Upstream released new version
406    
407     * Mon Jan 29 2007 Mike McGrath <imlinux@gmail.com> 0.6-1
408     - Upstream released new version
409     - Added new symlinks for smoltPrint and smoltSendProfile
410    
411     * Thu Jan 25 2007 Mike McGrath <imlinux@gmail.com> 0.5-4
412     - Forgot Requires of dbus-python
413    
414     * Wed Jan 24 2007 Mike McGrath <imlinux@gmail.com> 0.5-3
415     - Fixed silly bash syntax error
416    
417     * Thu Jan 22 2007 Mike McGrath <imlinux@gmail.com> 0.5-2
418     - s/turbogears/TurboGears/
419    
420     * Thu Jan 22 2007 Mike McGrath <imlinux@gmail.com> 0.5-1
421     - Upstream released new version
422     - Fixed small bug in post
423    
424     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.4-2
425     - Added comment about the not directly available tar-gzip file
426    
427     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.4-1
428     - New upstream version
429     - Altered post install section
430     - Added wget requires
431    
432     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.3-1
433     - Upstream released new version
434    
435     * Tue Jan 16 2006 Mike McGrath <imlinux@gmail.com> 0.2-1
436     - Initial Packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed