/[smeserver]/rpms/smolt/sme8/smolt.spec
ViewVC logotype

Annotation of /rpms/smolt/sme8/smolt.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.10 - (hide annotations) (download)
Sat Mar 6 17:24:22 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: smolt-1_4_3-4_el5_sme
Changes since 1.9: +5 -2 lines
Update

1 slords 1.10 # $Id: smolt.spec,v 1.9 2010/03/06 16:53:30 slords Exp $
2 slords 1.8
3 slords 1.7 Name: smolt
4 slords 1.6
5 slords 1.7 Summary: SME Server hardware profiler
6     Version: 1.4.3
7 slords 1.10 Release: 4%{?dist}
8 slords 1.7 License: GPLv2+
9 slords 1.1 Group: Applications/Internet
10 slords 1.7 URL: http://fedorahosted.org/smolt
11     Source: https://fedorahosted.org/releases/s/m/%{name}/%{name}-%{version}.tar.gz
12     Patch0: smolt-1.4.3-ddl.patch
13     Patch1: smolt-1.4.3-el5.patch
14     Patch2: smolt-1.4.3-sme.patch
15 slords 1.1 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16    
17 slords 1.7 Requires: dbus-python, python-urlgrabber, gawk, python-paste, hal, python-ctypes
18 slords 1.1 BuildArch: noarch
19     BuildRequires: gettext
20     BuildRequires: desktop-file-utils
21    
22 slords 1.7 Requires(pre): %{_sbindir}/groupadd
23     Requires(pre): %{_sbindir}/useradd
24 slords 1.1 Requires(post): /sbin/chkconfig
25     Requires(preun): /sbin/chkconfig
26     Requires(preun): /sbin/service
27     Requires(postun): /sbin/service
28 slords 1.7 Requires: python-simplejson
29 slords 1.1
30     %description
31 slords 1.7 The SME Server hardware profiler is a server-client system that does a hardware
32     scan against a machine and sends the results to a public SME Server Project
33     turbogears server. The sends are anonymous and should not contain any private
34 slords 1.1 information other than the physical hardware information and basic OS info.
35    
36     This package contains the client
37    
38     %package server
39 slords 1.7 Summary: SME Server hardware profiler server
40 slords 1.1 Group: Applications/Internet
41     Requires: smolt = %{version}-%{release}
42 slords 1.7 Requires: python-genshi
43     Requires: python-crypto
44     Requires: TurboGears mx
45     Requires: python-turboflot
46 slords 1.1
47     %description server
48 slords 1.7 The SME Server hardware profiler is a server-client system that does a hardware
49     scan against a machine and sends the results to a public SME Server Project
50     turbogears server. The sends are anonymous and should not contain any private
51 slords 1.1 information other than the physical hardware information and basic OS info.
52    
53     This package contains the server portion
54    
55     %package firstboot
56 slords 1.7 Summary: SME Server hardware profile firstboot
57 slords 1.1 Group: Applications/Internet
58     Requires: smolt = %{version}-%{release}
59    
60     %description firstboot
61     This provides firstboot integration for smolt. It has been broken into a
62     separate package so firstboot isn't a requisite to use smolt.
63    
64     %package gui
65 slords 1.7 Summary: SME Server hardware profiler gui
66 slords 1.1 Group: Applications/Internet
67     Requires: smolt = %{version}-%{release}
68 slords 1.7 Requires: PyQt4
69 slords 1.1
70     %description gui
71     Provides smolt's gui functionality. Not included in the default package to
72     ensure that deps are kept small.
73    
74     %prep
75     %setup -q
76     %patch0 -p1
77     %patch1 -p1
78 slords 1.2 %patch2 -p1
79 slords 1.1
80     %build
81     cd client/
82     make
83    
84     %install
85     %{__rm} -rf %{buildroot}
86 slords 1.7 cd client
87     DESTDIR=%{buildroot} make install
88     cd ..
89 slords 1.1 %{__install} -d -m 0755 smoon/ %{buildroot}/%{_datadir}/%{name}/smoon/
90 slords 1.7 %{__mkdir} -p %{buildroot}/%{_mandir}/man1/
91 slords 1.1 %{__cp} -adv smoon/* %{buildroot}/%{_datadir}/%{name}/smoon/
92 slords 1.7 %{__cp} client/scan.py %{buildroot}/%{_datadir}/%{name}/client/
93     %{__cp} client/gate.py %{buildroot}/%{_datadir}/%{name}/client/
94     %{__cp} client/os_detect.py %{buildroot}/%{_datadir}/%{name}/client/
95     %{__cp} client/fs_util.py %{buildroot}/%{_datadir}/%{name}/client/
96     %{__cp} client/man/* %{buildroot}/%{_mandir}/man1/
97 slords 1.1
98     %{__mkdir} -p %{buildroot}/%{_sysconfdir}/sysconfig/
99     %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/modules/
100     %{__mkdir} -p %{buildroot}/%{_initrddir}
101 slords 1.7
102 slords 1.1 %{__mv} client/smoltFirstBoot.py %{buildroot}/%{_datadir}/firstboot/modules/smolt.py
103     %{__mv} client/smolt-init %{buildroot}/%{_initrddir}/smolt
104    
105     touch %{buildroot}/%{_sysconfdir}/sysconfig/hw-uuid
106    
107     # Icons
108     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/16x16/apps/
109     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/22x22/apps/
110     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/24x24/apps/
111     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/
112 slords 1.7
113 slords 1.1 %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/pixmaps/
114 slords 1.7 %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/themes/default/
115    
116 slords 1.1 %{__mv} client/icons/smolt-icon-16.png %{buildroot}/%{_datadir}/icons/hicolor/16x16/apps/smolt.png
117     %{__mv} client/icons/smolt-icon-22.png %{buildroot}/%{_datadir}/icons/hicolor/22x22/apps/smolt.png
118     %{__mv} client/icons/smolt-icon-24.png %{buildroot}/%{_datadir}/icons/hicolor/24x24/apps/smolt.png
119     %{__mv} client/icons/smolt-icon-32.png %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/smolt.png
120     %{__cp} -adv client/icons/* %{buildroot}/%{_datadir}/%{name}/client/icons/
121 slords 1.7 %{__cp} -adv client/icons/smolt-icon-48.png %{buildroot}/%{_datadir}/firstboot/themes/default/smolt.png
122 slords 1.1
123 slords 1.7 %{__rm} -f %{buildroot}/%{_bindir}/smoltSendProfile %{buildroot}/%{_bindir}/smoltDeleteProfile %{buildroot}/%{_bindir}/smoltGui
124     %{__rm} -f %{buildroot}/%{_datadir}/%{name}/client/config.py
125 slords 1.1
126     ln -s %{_datadir}/%{name}/client/sendProfile.py %{buildroot}/%{_bindir}/smoltSendProfile
127     ln -s %{_datadir}/%{name}/client/deleteProfile.py %{buildroot}/%{_bindir}/smoltDeleteProfile
128     ln -s %{_datadir}/%{name}/client/smoltGui.py %{buildroot}/%{_bindir}/smoltGui
129 slords 1.7 ln -s %{_sysconfdir}/%{name}/config.py %{buildroot}/%{_datadir}/%{name}/client/config.py
130 slords 1.1
131    
132     desktop-file-install --vendor='fedora' --dir=%{buildroot}/%{_datadir}/applications client/smolt.desktop
133 slords 1.7 %{__rm} -f %{buildroot}/%{_datadir}/applications/smolt.desktop
134     %find_lang %{name}
135 slords 1.1
136 slords 1.7 # Cleanup from the Makefile (will be cleaned up when it is finalized)
137     %{__rm} -f %{buildroot}/etc/init.d/smolt
138     %{__rm} -f %{buildroot}/etc/smolt/hw-uuid
139 slords 1.1
140     %clean
141     rm -rf %{buildroot}
142    
143 slords 1.7 %pre
144     %{_sbindir}/groupadd -r %{name} &>/dev/null || :
145     %{_sbindir}/useradd -r -s /sbin/nologin -d %{_datadir}/%{name} -M \
146     -c 'Smolt' -g %{name} %{name} &>/dev/null || :
147    
148 slords 1.1 %post
149     /sbin/chkconfig --add smolt
150 slords 1.7
151     #Randomize checkin times.
152     TMPFILE=$(/bin/mktemp /tmp/smolt.XXXXX)
153     /bin/awk '{ srand(); if($2 == 1 && $3 == 1) print $1,int((rand() * 100) % 22 + 1),int((rand() * 100) % 27 + 1),substr($0,index($0,$4)); else print $0}' /etc/cron.d/smolt > $TMPFILE
154     /bin/cp $TMPFILE /etc/cron.d/smolt
155     /bin/rm -f $TMPFILE
156 slords 1.1
157     %preun
158     if [ $1 = 0 ]; then
159     /sbin/service smolt stop >/dev/null 2>&1
160     /sbin/chkconfig --del smolt
161     fi
162    
163 slords 1.7 %post server
164     #Fail, will fix later
165     for f in delete.html deviceclass.html device.html devices.html error.html \
166     link.html login.html master.html myHosts.html notLoaded.html \
167     pub_uuid.html raw.html report_device_ratings.html \
168     report_host_ratings.html report_recent.html report_search_devices.html\
169     report_search.html report_search_profiles.html report_view_device.html\
170     report_view_devices.html report_view.html report_view_profile.html \
171     report_view_profiles.html showall.html show.html stats.html token.html\
172     welcome.html
173     do
174     touch %{_datadir}/%{name}/smoon/hardware/static/stats/$f
175     done
176    
177     %post gui
178     touch --no-create %{_datadir}/icons/hicolor || :
179     %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
180    
181     %postun gui
182     touch --no-create %{_datadir}/icons/hicolor || :
183     %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
184    
185 slords 1.1 %files -f %{name}.lang
186     %defattr(-,root,root,-)
187     %doc README GPL doc/*
188     %dir %{_datadir}/%{name}
189 slords 1.7 %dir %{_sysconfdir}/%{name}/
190 slords 1.1 %{_datadir}/%{name}/client
191 slords 1.7 #%ghost %{_datadir}/%{name}/client/scan.pyc
192     #%ghost %{_datadir}/%{name}/client/scan.pyo
193 slords 1.1 %{_datadir}/%{name}/doc
194     %{_bindir}/smoltSendProfile
195     %{_bindir}/smoltDeleteProfile
196 slords 1.7 %config(noreplace) /%{_sysconfdir}/%{name}/config*
197 slords 1.1 %{_sysconfdir}/cron.d/%{name}
198 slords 1.7 %{_mandir}/man1/*gz
199 slords 1.1 %{_initrddir}/%{name}
200     %ghost %config(noreplace) %{_sysconfdir}/sysconfig/hw-uuid
201    
202     %files server
203     %defattr(-,root,root,-)
204     %{_datadir}/%{name}/smoon
205    
206     %files firstboot
207     %defattr(-,root,root,-)
208     %{_datadir}/firstboot/modules/smolt.py*
209 slords 1.7 %{_datadir}/firstboot/themes/default/smolt.png
210 slords 1.1
211     %files gui
212     %defattr(-,root,root,-)
213     %{_datadir}/applications/fedora-smolt.desktop
214     %{_datadir}/icons/hicolor/*x*/apps/smolt.png
215     %{_bindir}/smoltGui
216    
217     %changelog
218 slords 1.10 * Sat Feb 6 2010 Shad L. Lords <slords@mail.com> 1.4.2-4.sme
219     - Make cronjob run as root so we can get machine type
220    
221 slords 1.9 * Sat Feb 6 2010 Shad L. Lords <slords@mail.com> 1.4.2-3.sme
222     - Make cronjob run as admin so we can get system type
223    
224 slords 1.7 * Mon Feb 3 2010 Shad L. Lords <slords@mail.com> 1.4.2-2.sme
225     - Apply patches so smolt will run under el5
226     - Apply sme specific patches
227    
228     * Mon Jan 25 2010 Mike McGrath <mmcgrath@redhat.com> 1.4.2-1
229     - Upstream released new version
230     - Added hal requires
231    
232     * Tue Oct 13 2009 Mike McGrath <mmcgrath@redhat.com> 1.4-4
233     - Fixing firstboot for F-12
234    
235     * Mon Sep 21 2009 Mike McGrath <mmcgrath@redhat.com> 1.4-2
236     - Patched issue with translations (already upstream)
237    
238     * Mon Sep 14 2009 Mike McGrath <mmcgrath@redhat.com> 1.4-1
239     - Upstream released new version
240    
241     * Thu Sep 10 2009 Mike McGrath <mmcgrath@redhat.com> - 1.3.2-2
242     - Added requires for PyQt4 on smolt gui
243    
244     * Thu Sep 03 2009 Mike McGrath <mmcgrath@redhat.com> - 1.3.2-1
245     - Upstream released new version
246     - Changed some link and copy info
247    
248     * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-2
249     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
250    
251     * Thu Jul 02 2009 Mike McGrath <mmcgrath@redhat.com> - 1.3-1
252     - Added touch for generated stats
253     - Upstream released new version
254    
255     * Tue Apr 14 2009 Mike McGrath <mmcgrath@redhat.com> - 1.2-4.2
256     - Removed fake attack
257    
258     * Fri Mar 13 2009 Mike McGrath <mmcgrath@redhat.com> - 1.2-4.1
259     - Fixed some formatting in the spec file
260     - Added note to %post
261    
262     * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-4
263     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
264    
265     * Wed Jan 21 2009 Mike McGrath <mmcgrath@redhat.com> - 1.2-3
266     - Added os_detect.py as it is now required.
267    
268     * Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2-2
269     - Rebuild for Python 2.6
270 bytegw 1.5
271 slords 1.7 * Sun Nov 30 2008 Mike McGrath <mmcgrath@redhat.com> 1.2-1
272     - Upstream released new version
273    
274     * Fri Nov 21 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-10
275     - Fix for bug 472101
276    
277     * Wed Nov 12 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-9
278     - Fix for bug 470829
279    
280     * Tue Nov 11 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-8
281     - Added patch for fixed scanner
282    
283     * Wed Oct 1 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-7
284     - Fix for 439496
285    
286     * Sun Sep 7 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-6
287     - Added turboflot to server, removed from firstboot
288    
289     * Thu Sep 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.1.1-5
290     - fix license tag
291    
292     * Thu Apr 03 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-4
293     - One revert for rawhide
294    
295     * Sat Mar 08 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-3
296     - Fixing firstboot again for 437708, 437765
297    
298     * Sat Mar 08 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-2
299     - Fix firstboot for 437708, 437765
300    
301     * Sat Mar 08 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-1
302     - Upstream released new version
303    
304     * Wed Mar 05 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1-1
305     - Upstream released new version
306     - Manfiles added
307     - Source location updated
308    
309     * Wed Feb 27 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1-3
310     - Copy instead of move cron file so that selinux contexts are set
311     properly. (BZ#435050)
312    
313     * Wed Feb 27 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1-2
314     - Create smolt user. (BZ#435136)
315 bytegw 1.4
316 slords 1.7 * Fri Feb 01 2008 Mike McGrath <mmcgrath@redhat.com> 1.0-5
317     - Added a req for mx on smoon
318 bytegw 1.4
319 slords 1.7 * Thu Jan 08 2008 Mike McGrath <mmcgrath@redhat.com> 1.0-4
320     - Fixed firstboot
321    
322     * Thu Jan 08 2008 Mike McGrath <mmcgrath@redhat.com> 1.0-3
323     - Added python-urlgrabber as a requires - 427969
324    
325     * Thu Nov 22 2007 Mike McGrath <mmcgrath@redhat.com> 1.0-2
326     - Installed scanner - #395901
327    
328     * Tue Nov 20 2007 Mike McGrath <mmcgrath@redhat.com> 1.0-1
329     - Upstream released new version
330    
331     * Tue Oct 25 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9.2-1
332     - Upstream released new version
333    
334     * Tue Oct 23 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9.1-4
335     - Upstream released new version
336    
337     * Thu Oct 18 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9-2
338     - Fixed /etc/smolt/ ownership issue
339    
340     * Tue Oct 16 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9-1
341     - Upstream released new version
342 slords 1.3
343 slords 1.7 * Fri Sep 28 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-8
344     - Fixed Selinux
345 slords 1.2
346 slords 1.7 * Thu Sep 27 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-6
347     - Added translations
348 slords 1.1
349 slords 1.7 * Fri Sep 21 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-5
350     - Fixed firstboot issues
351    
352     * Mon Aug 13 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-4
353     - Rebuild to clean up 'config.py' compilations
354    
355     * Mon Aug 13 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-1
356     - Upstream released new version (major changes)
357     - New config file
358     - New Makefile
359     - Added deps
360    
361     * Fri Jun 22 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.3
362     - Upstream released new version
363 slords 1.1
364     * Thu May 24 2007 Mike McGrath <mmcgrath@redhat.com> - 0.9.8.1
365     - Upstream released new version
366    
367     * Sun Apr 22 2007 Mike McGrath <mmcgrath@redhat.com> - 0.9.7.1-3
368     - Added smolt icons
369    
370     * Tue Apr 17 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.6-4
371     - Add standard scriptlets in pre & post to handle init script - fixes #236776
372     - Use the find_lang macro to find/mark translations.
373    
374     * Fri Apr 13 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.6-3
375     - Put a copy of the privacy policy where the client is expecting it.
376    
377     * Wed Apr 11 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.6-2
378     - Upstream released new version.
379     - Much better support for languages on the client
380    
381     * Fri Mar 16 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.4-1
382     - Upstream released new version
383     - Major changes
384     - Added initial i18n support (Probably doesn't work)
385    
386     * Fri Mar 01 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.2-1
387     - Fixed firstboot
388     - Upstream released new version
389    
390     * Fri Mar 01 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.1-1
391     - Upstream released new version, major smoon changes.
392    
393     * Mon Feb 19 2007 Mike McGrath <mmcgrath@redhat.com> 0.9-1
394     - Upstream released new version
395    
396     * Mon Feb 12 2007 Mike McGrath <imlinux@gmail.com> 0.8-1
397     - New version released, major changes in both server and client
398    
399     * Wed Feb 07 2007 Mike McGrath <imlinux@gmail.com> 0.7-1
400     - Upstream released new version
401    
402     * Tue Jan 31 2007 Mike McGrath <imlinux@gmail.com> 0.6.2-1
403     - Upstream released new version (bug in firstboot)
404    
405     * Tue Jan 30 2007 Mike McGrath <imlinux@gmail.com> 0.6.1-3
406     - Removed LSB requirement for sparc
407    
408     * Tue Jan 30 2007 Mike McGrath <imlinux@gmail.com> 0.6.1-2
409     - Added firstboot
410     - Upstream released new version
411    
412     * Mon Jan 29 2007 Mike McGrath <imlinux@gmail.com> 0.6-1
413     - Upstream released new version
414     - Added new symlinks for smoltPrint and smoltSendProfile
415    
416     * Thu Jan 25 2007 Mike McGrath <imlinux@gmail.com> 0.5-4
417     - Forgot Requires of dbus-python
418    
419     * Wed Jan 24 2007 Mike McGrath <imlinux@gmail.com> 0.5-3
420     - Fixed silly bash syntax error
421    
422     * Thu Jan 22 2007 Mike McGrath <imlinux@gmail.com> 0.5-2
423     - s/turbogears/TurboGears/
424    
425     * Thu Jan 22 2007 Mike McGrath <imlinux@gmail.com> 0.5-1
426     - Upstream released new version
427     - Fixed small bug in post
428    
429     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.4-2
430     - Added comment about the not directly available tar-gzip file
431    
432     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.4-1
433     - New upstream version
434     - Altered post install section
435     - Added wget requires
436    
437     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.3-1
438     - Upstream released new version
439    
440     * Tue Jan 16 2006 Mike McGrath <imlinux@gmail.com> 0.2-1
441     - Initial Packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed