/[smeserver]/rpms/smolt/sme9/smolt.spec
ViewVC logotype

Annotation of /rpms/smolt/sme9/smolt.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Thu Jan 31 22:25:16 2013 UTC (11 years, 4 months ago) by slords
Branch: MAIN
CVS Tags: smolt-1_4_3-5_el6_sme, HEAD
Initial import

1 slords 1.1 # $Id: smolt.spec,v 1.11 2010/03/06 22:19:42 slords Exp $
2    
3     Name: smolt
4    
5     Summary: SME Server hardware profiler
6     Version: 1.4.3
7     Release: 5%{?dist}
8     License: GPLv2+
9     Group: Applications/Internet
10     URL: http://fedorahosted.org/smolt
11     Source: https://fedorahosted.org/releases/s/m/%{name}/%{name}-%{version}.tar.gz
12     Patch0: smolt-1.4.3-ddl.patch
13     Patch1: smolt-1.4.3-el5.patch
14     Patch2: smolt-1.4.3-mod_proxy.patch
15     Patch3: smolt-1.4.3-sme.patch
16     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17    
18     Requires: dbus-python, python-urlgrabber, gawk, python-paste, hal, python-ctypes
19     BuildArch: noarch
20     BuildRequires: gettext
21     BuildRequires: desktop-file-utils
22    
23     Requires(pre): %{_sbindir}/groupadd
24     Requires(pre): %{_sbindir}/useradd
25     Requires(post): /sbin/chkconfig
26     Requires(preun): /sbin/chkconfig
27     Requires(preun): /sbin/service
28     Requires(postun): /sbin/service
29     Requires: python-simplejson
30    
31     %description
32     The SME Server hardware profiler is a server-client system that does a hardware
33     scan against a machine and sends the results to a public SME Server Project
34     turbogears server. The sends are anonymous and should not contain any private
35     information other than the physical hardware information and basic OS info.
36    
37     This package contains the client
38    
39     %package server
40     Summary: SME Server hardware profiler server
41     Group: Applications/Internet
42     Requires: smolt = %{version}-%{release}
43     Requires: python-genshi
44     Requires: python-crypto
45     Requires: TurboGears mx
46     Requires: python-turboflot
47    
48     %description server
49     The SME Server hardware profiler is a server-client system that does a hardware
50     scan against a machine and sends the results to a public SME Server Project
51     turbogears server. The sends are anonymous and should not contain any private
52     information other than the physical hardware information and basic OS info.
53    
54     This package contains the server portion
55    
56     %package firstboot
57     Summary: SME Server hardware profile firstboot
58     Group: Applications/Internet
59     Requires: smolt = %{version}-%{release}
60    
61     %description firstboot
62     This provides firstboot integration for smolt. It has been broken into a
63     separate package so firstboot isn't a requisite to use smolt.
64    
65     %package gui
66     Summary: SME Server hardware profiler gui
67     Group: Applications/Internet
68     Requires: smolt = %{version}-%{release}
69     Requires: PyQt4
70    
71     %description gui
72     Provides smolt's gui functionality. Not included in the default package to
73     ensure that deps are kept small.
74    
75     %prep
76     %setup -q
77     %patch0 -p1
78     %patch1 -p1
79     %patch2 -p1
80     %patch3 -p1
81    
82     %build
83     cd client/
84     make
85    
86     %install
87     %{__rm} -rf %{buildroot}
88     cd client
89     DESTDIR=%{buildroot} make install
90     cd ..
91     %{__install} -d -m 0755 smoon/ %{buildroot}/%{_datadir}/%{name}/smoon/
92     %{__mkdir} -p %{buildroot}/%{_mandir}/man1/
93     %{__cp} -adv smoon/* %{buildroot}/%{_datadir}/%{name}/smoon/
94     %{__cp} client/scan.py %{buildroot}/%{_datadir}/%{name}/client/
95     %{__cp} client/gate.py %{buildroot}/%{_datadir}/%{name}/client/
96     %{__cp} client/os_detect.py %{buildroot}/%{_datadir}/%{name}/client/
97     %{__cp} client/fs_util.py %{buildroot}/%{_datadir}/%{name}/client/
98     %{__cp} client/man/* %{buildroot}/%{_mandir}/man1/
99    
100     %{__mkdir} -p %{buildroot}/%{_sysconfdir}/sysconfig/
101     %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/modules/
102     %{__mkdir} -p %{buildroot}/%{_initrddir}
103    
104     %{__mv} client/smoltFirstBoot.py %{buildroot}/%{_datadir}/firstboot/modules/smolt.py
105     %{__mv} client/smolt-init %{buildroot}/%{_initrddir}/smolt
106    
107     touch %{buildroot}/%{_sysconfdir}/sysconfig/hw-uuid
108    
109     # Icons
110     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/16x16/apps/
111     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/22x22/apps/
112     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/24x24/apps/
113     %{__mkdir} -p %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/
114    
115     %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/pixmaps/
116     %{__mkdir} -p %{buildroot}/%{_datadir}/firstboot/themes/default/
117    
118     %{__mv} client/icons/smolt-icon-16.png %{buildroot}/%{_datadir}/icons/hicolor/16x16/apps/smolt.png
119     %{__mv} client/icons/smolt-icon-22.png %{buildroot}/%{_datadir}/icons/hicolor/22x22/apps/smolt.png
120     %{__mv} client/icons/smolt-icon-24.png %{buildroot}/%{_datadir}/icons/hicolor/24x24/apps/smolt.png
121     %{__mv} client/icons/smolt-icon-32.png %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps/smolt.png
122     %{__cp} -adv client/icons/* %{buildroot}/%{_datadir}/%{name}/client/icons/
123     %{__cp} -adv client/icons/smolt-icon-48.png %{buildroot}/%{_datadir}/firstboot/themes/default/smolt.png
124    
125     %{__rm} -f %{buildroot}/%{_bindir}/smoltSendProfile %{buildroot}/%{_bindir}/smoltDeleteProfile %{buildroot}/%{_bindir}/smoltGui
126     %{__rm} -f %{buildroot}/%{_datadir}/%{name}/client/config.py
127    
128     ln -s %{_datadir}/%{name}/client/sendProfile.py %{buildroot}/%{_bindir}/smoltSendProfile
129     ln -s %{_datadir}/%{name}/client/deleteProfile.py %{buildroot}/%{_bindir}/smoltDeleteProfile
130     ln -s %{_datadir}/%{name}/client/smoltGui.py %{buildroot}/%{_bindir}/smoltGui
131     ln -s %{_sysconfdir}/%{name}/config.py %{buildroot}/%{_datadir}/%{name}/client/config.py
132    
133    
134     desktop-file-install --vendor='fedora' --dir=%{buildroot}/%{_datadir}/applications client/smolt.desktop
135     %{__rm} -f %{buildroot}/%{_datadir}/applications/smolt.desktop
136     %find_lang %{name}
137    
138     # Cleanup from the Makefile (will be cleaned up when it is finalized)
139     %{__rm} -f %{buildroot}/etc/init.d/smolt
140     %{__rm} -f %{buildroot}/etc/smolt/hw-uuid
141    
142     %clean
143     rm -rf %{buildroot}
144    
145     %pre
146     %{_sbindir}/groupadd -r %{name} &>/dev/null || :
147     %{_sbindir}/useradd -r -s /sbin/nologin -d %{_datadir}/%{name} -M \
148     -c 'Smolt' -g %{name} %{name} &>/dev/null || :
149    
150     %post
151     /sbin/chkconfig --add smolt
152    
153     #Randomize checkin times.
154     TMPFILE=$(/bin/mktemp /tmp/smolt.XXXXX)
155     /bin/awk '{ srand(); if($2 == 1 && $3 == 1) print $1,int((rand() * 100) % 22 + 1),int((rand() * 100) % 27 + 1),substr($0,index($0,$4)); else print $0}' /etc/cron.d/smolt > $TMPFILE
156     /bin/cp $TMPFILE /etc/cron.d/smolt
157     /bin/rm -f $TMPFILE
158    
159     %preun
160     if [ $1 = 0 ]; then
161     /sbin/service smolt stop >/dev/null 2>&1
162     /sbin/chkconfig --del smolt
163     fi
164    
165     %post server
166     #Fail, will fix later
167     for f in delete.html deviceclass.html device.html devices.html error.html \
168     link.html login.html master.html myHosts.html notLoaded.html \
169     pub_uuid.html raw.html report_device_ratings.html \
170     report_host_ratings.html report_recent.html report_search_devices.html\
171     report_search.html report_search_profiles.html report_view_device.html\
172     report_view_devices.html report_view.html report_view_profile.html \
173     report_view_profiles.html showall.html show.html stats.html token.html\
174     welcome.html
175     do
176     touch %{_datadir}/%{name}/smoon/hardware/static/stats/$f
177     done
178    
179     %post gui
180     touch --no-create %{_datadir}/icons/hicolor || :
181     %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
182    
183     %postun gui
184     touch --no-create %{_datadir}/icons/hicolor || :
185     %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
186    
187     %files -f %{name}.lang
188     %defattr(-,root,root,-)
189     %doc README GPL doc/*
190     %dir %{_datadir}/%{name}
191     %dir %{_sysconfdir}/%{name}/
192     %{_datadir}/%{name}/client
193     #%ghost %{_datadir}/%{name}/client/scan.pyc
194     #%ghost %{_datadir}/%{name}/client/scan.pyo
195     %{_datadir}/%{name}/doc
196     %{_bindir}/smoltSendProfile
197     %{_bindir}/smoltDeleteProfile
198     %config(noreplace) /%{_sysconfdir}/%{name}/config*
199     %{_sysconfdir}/cron.d/%{name}
200     %{_mandir}/man1/*gz
201     %{_initrddir}/%{name}
202     %ghost %config(noreplace) %{_sysconfdir}/sysconfig/hw-uuid
203    
204     %files server
205     %defattr(-,root,root,-)
206     %{_datadir}/%{name}/smoon
207    
208     %files firstboot
209     %defattr(-,root,root,-)
210     %{_datadir}/firstboot/modules/smolt.py*
211     %{_datadir}/firstboot/themes/default/smolt.png
212    
213     %files gui
214     %defattr(-,root,root,-)
215     %{_datadir}/applications/fedora-smolt.desktop
216     %{_datadir}/icons/hicolor/*x*/apps/smolt.png
217     %{_bindir}/smoltGui
218    
219     %changelog
220     * Sat Feb 6 2010 Shad L. Lords <slords@mail.com> 1.4.2-5.sme
221     - Fix links so they work with mod_proxy
222    
223     * Sat Feb 6 2010 Shad L. Lords <slords@mail.com> 1.4.2-4.sme
224     - Make cronjob run as root so we can get machine type
225    
226     * Sat Feb 6 2010 Shad L. Lords <slords@mail.com> 1.4.2-3.sme
227     - Make cronjob run as admin so we can get system type
228    
229     * Mon Feb 3 2010 Shad L. Lords <slords@mail.com> 1.4.2-2.sme
230     - Apply patches so smolt will run under el5
231     - Apply sme specific patches
232    
233     * Mon Jan 25 2010 Mike McGrath <mmcgrath@redhat.com> 1.4.2-1
234     - Upstream released new version
235     - Added hal requires
236    
237     * Tue Oct 13 2009 Mike McGrath <mmcgrath@redhat.com> 1.4-4
238     - Fixing firstboot for F-12
239    
240     * Mon Sep 21 2009 Mike McGrath <mmcgrath@redhat.com> 1.4-2
241     - Patched issue with translations (already upstream)
242    
243     * Mon Sep 14 2009 Mike McGrath <mmcgrath@redhat.com> 1.4-1
244     - Upstream released new version
245    
246     * Thu Sep 10 2009 Mike McGrath <mmcgrath@redhat.com> - 1.3.2-2
247     - Added requires for PyQt4 on smolt gui
248    
249     * Thu Sep 03 2009 Mike McGrath <mmcgrath@redhat.com> - 1.3.2-1
250     - Upstream released new version
251     - Changed some link and copy info
252    
253     * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-2
254     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
255    
256     * Thu Jul 02 2009 Mike McGrath <mmcgrath@redhat.com> - 1.3-1
257     - Added touch for generated stats
258     - Upstream released new version
259    
260     * Tue Apr 14 2009 Mike McGrath <mmcgrath@redhat.com> - 1.2-4.2
261     - Removed fake attack
262    
263     * Fri Mar 13 2009 Mike McGrath <mmcgrath@redhat.com> - 1.2-4.1
264     - Fixed some formatting in the spec file
265     - Added note to %post
266    
267     * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-4
268     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
269    
270     * Wed Jan 21 2009 Mike McGrath <mmcgrath@redhat.com> - 1.2-3
271     - Added os_detect.py as it is now required.
272    
273     * Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2-2
274     - Rebuild for Python 2.6
275    
276     * Sun Nov 30 2008 Mike McGrath <mmcgrath@redhat.com> 1.2-1
277     - Upstream released new version
278    
279     * Fri Nov 21 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-10
280     - Fix for bug 472101
281    
282     * Wed Nov 12 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-9
283     - Fix for bug 470829
284    
285     * Tue Nov 11 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-8
286     - Added patch for fixed scanner
287    
288     * Wed Oct 1 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-7
289     - Fix for 439496
290    
291     * Sun Sep 7 2008 Mike McGrath <mmcgrath@redhat.com> 1.1.1.1-6
292     - Added turboflot to server, removed from firstboot
293    
294     * Thu Sep 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.1.1-5
295     - fix license tag
296    
297     * Thu Apr 03 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-4
298     - One revert for rawhide
299    
300     * Sat Mar 08 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-3
301     - Fixing firstboot again for 437708, 437765
302    
303     * Sat Mar 08 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-2
304     - Fix firstboot for 437708, 437765
305    
306     * Sat Mar 08 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1.1-1
307     - Upstream released new version
308    
309     * Wed Mar 05 2008 Mike McGrath <mmcgrath@redhat.com> - 1.1.1-1
310     - Upstream released new version
311     - Manfiles added
312     - Source location updated
313    
314     * Wed Feb 27 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1-3
315     - Copy instead of move cron file so that selinux contexts are set
316     properly. (BZ#435050)
317    
318     * Wed Feb 27 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1-2
319     - Create smolt user. (BZ#435136)
320    
321     * Fri Feb 01 2008 Mike McGrath <mmcgrath@redhat.com> 1.0-5
322     - Added a req for mx on smoon
323    
324     * Thu Jan 08 2008 Mike McGrath <mmcgrath@redhat.com> 1.0-4
325     - Fixed firstboot
326    
327     * Thu Jan 08 2008 Mike McGrath <mmcgrath@redhat.com> 1.0-3
328     - Added python-urlgrabber as a requires - 427969
329    
330     * Thu Nov 22 2007 Mike McGrath <mmcgrath@redhat.com> 1.0-2
331     - Installed scanner - #395901
332    
333     * Tue Nov 20 2007 Mike McGrath <mmcgrath@redhat.com> 1.0-1
334     - Upstream released new version
335    
336     * Tue Oct 25 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9.2-1
337     - Upstream released new version
338    
339     * Tue Oct 23 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9.1-4
340     - Upstream released new version
341    
342     * Thu Oct 18 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9-2
343     - Fixed /etc/smolt/ ownership issue
344    
345     * Tue Oct 16 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.9-1
346     - Upstream released new version
347    
348     * Fri Sep 28 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-8
349     - Fixed Selinux
350    
351     * Thu Sep 27 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-6
352     - Added translations
353    
354     * Fri Sep 21 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-5
355     - Fixed firstboot issues
356    
357     * Mon Aug 13 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-4
358     - Rebuild to clean up 'config.py' compilations
359    
360     * Mon Aug 13 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.4-1
361     - Upstream released new version (major changes)
362     - New config file
363     - New Makefile
364     - Added deps
365    
366     * Fri Jun 22 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.8.3
367     - Upstream released new version
368    
369     * Thu May 24 2007 Mike McGrath <mmcgrath@redhat.com> - 0.9.8.1
370     - Upstream released new version
371    
372     * Sun Apr 22 2007 Mike McGrath <mmcgrath@redhat.com> - 0.9.7.1-3
373     - Added smolt icons
374    
375     * Tue Apr 17 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.6-4
376     - Add standard scriptlets in pre & post to handle init script - fixes #236776
377     - Use the find_lang macro to find/mark translations.
378    
379     * Fri Apr 13 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.6-3
380     - Put a copy of the privacy policy where the client is expecting it.
381    
382     * Wed Apr 11 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.6-2
383     - Upstream released new version.
384     - Much better support for languages on the client
385    
386     * Fri Mar 16 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.4-1
387     - Upstream released new version
388     - Major changes
389     - Added initial i18n support (Probably doesn't work)
390    
391     * Fri Mar 01 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.2-1
392     - Fixed firstboot
393     - Upstream released new version
394    
395     * Fri Mar 01 2007 Mike McGrath <mmcgrath@redhat.com> 0.9.1-1
396     - Upstream released new version, major smoon changes.
397    
398     * Mon Feb 19 2007 Mike McGrath <mmcgrath@redhat.com> 0.9-1
399     - Upstream released new version
400    
401     * Mon Feb 12 2007 Mike McGrath <imlinux@gmail.com> 0.8-1
402     - New version released, major changes in both server and client
403    
404     * Wed Feb 07 2007 Mike McGrath <imlinux@gmail.com> 0.7-1
405     - Upstream released new version
406    
407     * Tue Jan 31 2007 Mike McGrath <imlinux@gmail.com> 0.6.2-1
408     - Upstream released new version (bug in firstboot)
409    
410     * Tue Jan 30 2007 Mike McGrath <imlinux@gmail.com> 0.6.1-3
411     - Removed LSB requirement for sparc
412    
413     * Tue Jan 30 2007 Mike McGrath <imlinux@gmail.com> 0.6.1-2
414     - Added firstboot
415     - Upstream released new version
416    
417     * Mon Jan 29 2007 Mike McGrath <imlinux@gmail.com> 0.6-1
418     - Upstream released new version
419     - Added new symlinks for smoltPrint and smoltSendProfile
420    
421     * Thu Jan 25 2007 Mike McGrath <imlinux@gmail.com> 0.5-4
422     - Forgot Requires of dbus-python
423    
424     * Wed Jan 24 2007 Mike McGrath <imlinux@gmail.com> 0.5-3
425     - Fixed silly bash syntax error
426    
427     * Thu Jan 22 2007 Mike McGrath <imlinux@gmail.com> 0.5-2
428     - s/turbogears/TurboGears/
429    
430     * Thu Jan 22 2007 Mike McGrath <imlinux@gmail.com> 0.5-1
431     - Upstream released new version
432     - Fixed small bug in post
433    
434     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.4-2
435     - Added comment about the not directly available tar-gzip file
436    
437     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.4-1
438     - New upstream version
439     - Altered post install section
440     - Added wget requires
441    
442     * Thu Jan 18 2006 Mike McGrath <imlinux@gmail.com> 0.3-1
443     - Upstream released new version
444    
445     * Tue Jan 16 2006 Mike McGrath <imlinux@gmail.com> 0.2-1
446     - Initial Packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed