1 |
# $Id$ |
2 |
|
3 |
Summary: An SSL-encrypting socket wrapper. |
4 |
Name: stunnel-tls |
5 |
Version: 3.22 |
6 |
Release: 4%{?dist} |
7 |
License: GPL |
8 |
Group: Applications/Internet |
9 |
URL: http://stunnel.mirt.net/ |
10 |
Source0: ftp://stunnel.mirt.net/stunnel/stunnel-%{version}.tar.gz |
11 |
Source1: stunnel.cnf |
12 |
Source2: Certificate-Creation |
13 |
Source3: sfinger.xinetd |
14 |
Source4: pop3-redirect.xinetd |
15 |
Source5: http://www.suspectclass.com/~sgifford/stunnel-tlsproxy/imap-tls.README |
16 |
Source6: http://www.suspectclass.com/~sgifford/stunnel-tlsproxy/smtp-tls.README |
17 |
Source7: http://www.suspectclass.com/~sgifford/stunnel-tlsproxy/pop3-tls.README |
18 |
Source8: http://www.suspectclass.com/~sgifford/stunnel-tlsproxy/makesock.c |
19 |
Patch0: stunnel-3.20-authpriv.patch |
20 |
Patch1: http://www.suspectclass.com/~sgifford/stunnel-tlsproxy/stunnel3.22-sg2.patch |
21 |
Buildroot: %{_tmppath}/stunnel-root |
22 |
BuildPrereq: openssl-devel, perl, textutils, fileutils, /usr/share/dict/words, tcp_wrappers |
23 |
Prereq: textutils, fileutils, /bin/mktemp, /sbin/ldconfig, /usr/share/dict/words, /bin/hostname, /usr/bin/id, /usr/bin/getent |
24 |
Requires: make |
25 |
Requires: stunnel >= %{version}-1 |
26 |
|
27 |
%description |
28 |
Stunnel is a socket wrapper which can provide SSL (Secure Sockets |
29 |
Layer) support to ordinary applications. For example, it can be used |
30 |
in conjunction with imapd to create an SSL secure IMAP server. |
31 |
|
32 |
This RPM contains stunnel-tls and makesock, which are created by |
33 |
Scott Gifford's patches. |
34 |
|
35 |
%prep |
36 |
# %setup -q |
37 |
%setup -q -n stunnel-%{version} |
38 |
%patch0 -p1 -b .authpriv |
39 |
%patch1 -p1 -b .sg2 |
40 |
|
41 |
%build |
42 |
%configure \ |
43 |
--with-ssl=%{_prefix} \ |
44 |
--with-pem-dir=%{_datadir}/ssl/certs \ |
45 |
--with-cert-file=%{_datadir}/ssl/cert.pem \ |
46 |
--with-cert-dir=%{_datadir}/ssl/trusted \ |
47 |
--with-tcp-wrappers |
48 |
perl -p -i -e 's:-I/usr/include:-I/usr/include -I/usr/kerberos/include:' Makefile |
49 |
|
50 |
# We have to create a certificate before the makefile asks us to. |
51 |
rm -f stunnel.pem stunnel.pem.1 stunnel.pem.2 |
52 |
(echo US |
53 |
echo . |
54 |
echo . |
55 |
echo . |
56 |
echo . |
57 |
echo . |
58 |
echo . |
59 |
echo .) | openssl req -newkey rsa:1024 -nodes -keyout stunnel.pem.1 -x509 -days 365 -out stunnel.pem.2 |
60 |
cat stunnel.pem.1 > stunnel.pem |
61 |
echo "" >> stunnel.pem |
62 |
cat stunnel.pem.2 >> stunnel.pem |
63 |
make piddir=/var/run/ |
64 |
gcc -o makesock %{SOURCE8} |
65 |
|
66 |
%install |
67 |
rm -rf $RPM_BUILD_ROOT |
68 |
mkdir -p $RPM_BUILD_ROOT/%{_sbindir} |
69 |
install -m755 stunnel $RPM_BUILD_ROOT/%{_sbindir}/stunnel-tls |
70 |
install -m755 makesock $RPM_BUILD_ROOT/%{_sbindir}/ |
71 |
mkdir -p $RPM_BUILD_ROOT/usr/share/doc |
72 |
ln -s stunnel-%{version} $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version} |
73 |
|
74 |
%post |
75 |
|
76 |
%postun |
77 |
|
78 |
%clean |
79 |
rm -rf $RPM_BUILD_ROOT |
80 |
|
81 |
%files |
82 |
%defattr(-,root,root) |
83 |
%{_sbindir}/stunnel-tls |
84 |
%{_sbindir}/makesock |
85 |
/usr/share/doc/%{name}-%{version} |
86 |
|
87 |
%changelog |
88 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
89 |
- Clean up spec so package can be built by koji/plague |
90 |
|
91 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
92 |
- Update to new release naming. No functional changes. |
93 |
- Make Packager generic |
94 |
|
95 |
* Thu Jun 23 2005 Gordon Rowell <gordonr@gormand.com.au> 3.22-3gr01 |
96 |
- Mini RPM with just stunnel-tls and makesock |
97 |
- Grr - why are RPM macros sooo broken - (percent)makeinstall |
98 |
is still executed even if # commented out in the (percent)install |
99 |
section |
100 |
|
101 |
* Fri Feb 18 2005 Charlie Brady <charlieb@e-smith.com> 3.22-2es |
102 |
- CentOS build fix and recompile |
103 |
|
104 |
* Mon Mar 10 2003 Charlie Brady <charlieb@e-smith.com> 3.22-1es |
105 |
- Add Scott Gifford's STARTTLS proxy patches and makesock program. |
106 |
|
107 |
* Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1 |
108 |
- update to 3.22, correcting a format-string vulnerability |
109 |
|
110 |
* Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1 |
111 |
- update to 3.21a |
112 |
|
113 |
* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1 |
114 |
- log using LOG_AUTHPRIV facility by default (#47289) |
115 |
- make permissions on stunnel binary 0755 |
116 |
- implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034) |
117 |
|
118 |
* Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1 |
119 |
- update to 3.19 to avoid problems with stunnel being multithreaded, but |
120 |
tcp wrappers not being thrad-safe |
121 |
|
122 |
* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com> |
123 |
- update to 3.17 |
124 |
|
125 |
* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com> |
126 |
- update to 3.16 |
127 |
|
128 |
* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com> |
129 |
- update to 3.15 |
130 |
- enable tcp-wrappers support |
131 |
|
132 |
* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com> |
133 |
- remove explicit requirement on openssl (specific version isn't enough, |
134 |
we have to depend on shared library version anyway) |
135 |
|
136 |
* Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com> |
137 |
- update to 3.14 |
138 |
|
139 |
* Mon Mar 26 2001 Preston Brown <pbrown@redhat.com> |
140 |
- depend on make (#33148) |
141 |
|
142 |
* Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com> |
143 |
- rebuild in new environment |
144 |
|
145 |
* Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com> |
146 |
- update to 3.13 to get pthread, OOB, 64-bit fixes |
147 |
- don't need sdf any more |
148 |
|
149 |
* Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com> |
150 |
- pull in sdf to build the man page (#22892) |
151 |
|
152 |
* Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com> |
153 |
- update to 3.11 |
154 |
- chuck the SIGHUP patch (went upstream) |
155 |
- chuck parts of the 64-bit clean patch (went upstream) |
156 |
|
157 |
* Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com> |
158 |
- update to 3.10 |
159 |
- more 64-bit clean changes, hopefully the last bunch |
160 |
|
161 |
* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com> |
162 |
- change piddir from the default /var/stunnel to /var/run |
163 |
- clean out pid file on SIGHUP |
164 |
|
165 |
* Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com> |
166 |
- update to 3.9 to get a security fix |
167 |
|
168 |
* Wed Oct 25 2000 Matt Wilson <msw@redhat.com> |
169 |
- change all unsigned longs to u_int32_t when dealing with network |
170 |
addresses |
171 |
|
172 |
* Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com> |
173 |
- make stunnel.pem also be (missingok) |
174 |
|
175 |
* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com> |
176 |
- move to Applications/Internet group |
177 |
- clean up %post script |
178 |
- make stunnel.pem %ghost %config(noreplace) |
179 |
- provide a sample file for use with xinetd |
180 |
|
181 |
* Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com> |
182 |
- FHS compliance fixes |
183 |
- modify defaults |
184 |
|
185 |
* Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com> |
186 |
- update to 3.8 |
187 |
- do not create certificate if one already exists |
188 |
|
189 |
* Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com> |
190 |
- update to 3.7 |
191 |
- add patch to find /usr/share/ssl |
192 |
- change some perms |
193 |
|
194 |
* Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com> |
195 |
- Modify spec file to match Red Hat standards |
196 |
|
197 |
* Fri Aug 12 1999 Damien Miller <damien@ibs.com.au> |
198 |
- Updated to 3.4a |
199 |
- Patched for OpenSSL 0.9.4 |
200 |
- Cleaned up files section |
201 |
|
202 |
* Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au> |
203 |
- Updated to 3.3 |
204 |
|
205 |
* Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au> |
206 |
- Initial RPMification |