1 |
unnilennium |
1.1 |
%define peardir /usr/share/pear |
2 |
|
|
%define xmldir /var/lib/pear |
3 |
|
|
|
4 |
|
|
Summary: PEAR: Horde timeobjects application |
5 |
|
|
Name: timeobjects |
6 |
|
|
Version: 2.1.2 |
7 |
|
|
Release: 1%{?dist} |
8 |
|
|
License: BSD-2-Clause |
9 |
|
|
Group: Development/Libraries |
10 |
|
|
Source0: http://pear.horde.org/get/timeobjects-%{version}.tgz |
11 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n) |
12 |
|
|
URL: http://pear.horde.org/package/timeobjects |
13 |
|
|
BuildRequires: php-pear(PEAR) >= 1.4.7 |
14 |
|
|
BuildRequires: php-channel(pear.horde.org) |
15 |
|
|
Requires: Horde_Role >= 1.0.0 |
16 |
|
|
Requires: Horde_Core >= 2.0.0 |
17 |
|
|
Requires: Horde_Core < 3.0.0alpha1 |
18 |
|
|
Requires: Horde_Date >= 2.0.0 |
19 |
|
|
Requires: Horde_Date < 3.0.0alpha1 |
20 |
|
|
Requires: Horde_Exception >= 2.0.0 |
21 |
|
|
Requires: Horde_Exception < 3.0.0alpha1 |
22 |
|
|
Requires: Horde_Url >= 2.0.0 |
23 |
|
|
Requires: Horde_Url < 3.0.0alpha1 |
24 |
|
|
Requires: Horde_Util >= 2.0.0 |
25 |
|
|
Requires: Horde_Util < 3.0.0alpha1 |
26 |
|
|
Requires: php-pear(PEAR) >= 1.7.0 |
27 |
|
|
Requires: php-channel(pear.horde.org) |
28 |
|
|
BuildArch: noarch |
29 |
|
|
|
30 |
|
|
Provides: %{name} = %{version} |
31 |
|
|
|
32 |
|
|
%description |
33 |
|
|
The timeobjects application doesn't have an interface but provides streams |
34 |
|
|
of events to any applications that can consume them, notably the Horde |
35 |
|
|
calendar application. It contains drivers for facebook events and weather |
36 |
|
|
forecasts and can easily be extended by custom drivers. |
37 |
|
|
|
38 |
|
|
%prep |
39 |
|
|
%setup -c -T |
40 |
|
|
pear -v -c pearrc \ |
41 |
|
|
-d php_dir=%{peardir} \ |
42 |
|
|
-d doc_dir=%{pear_docdir} \ |
43 |
|
|
-d bin_dir=%{_bindir} \ |
44 |
|
|
-d data_dir=%{peardir}/data \ |
45 |
|
|
-d test_dir=%{peardir}/tests \ |
46 |
|
|
-d ext_dir=%{_libdir} \ |
47 |
|
|
-d horde_dir=%{pear_hordedir} \ |
48 |
|
|
-s |
49 |
|
|
|
50 |
|
|
%build |
51 |
|
|
|
52 |
|
|
%install |
53 |
|
|
rm -rf %{buildroot} |
54 |
|
|
pear -c pearrc install --nodeps --packagingroot %{buildroot} %{SOURCE0} |
55 |
|
|
|
56 |
|
|
# Clean up unnecessary files |
57 |
|
|
rm pearrc |
58 |
|
|
rm %{buildroot}/%{peardir}/.filemap |
59 |
|
|
rm %{buildroot}/%{peardir}/.lock |
60 |
|
|
rm -rf %{buildroot}/%{peardir}/.registry |
61 |
|
|
rm -rf %{buildroot}%{peardir}/.channels |
62 |
|
|
rm %{buildroot}%{peardir}/.depdb |
63 |
|
|
rm %{buildroot}%{peardir}/.depdblock |
64 |
|
|
|
65 |
|
|
#mv %{buildroot}/docs . |
66 |
|
|
|
67 |
|
|
|
68 |
|
|
# Install XML package description |
69 |
|
|
mkdir -p %{buildroot}%{xmldir} |
70 |
|
|
tar -xzf %{SOURCE0} package.xml |
71 |
|
|
cp -p package.xml %{buildroot}%{xmldir}/timeobjects.xml |
72 |
|
|
|
73 |
|
|
%clean |
74 |
|
|
rm -rf %{buildroot} |
75 |
|
|
|
76 |
|
|
%post |
77 |
|
|
pear install --nodeps --soft --force --register-only %{xmldir}/timeobjects.xml >/dev/null || : |
78 |
|
|
|
79 |
|
|
%postun |
80 |
|
|
if [ "$1" -eq "0" ]; then |
81 |
|
|
pear uninstall --nodeps --ignore-errors --register-only pear.horde.org/timeobjects >/dev/null || : |
82 |
|
|
fi |
83 |
|
|
|
84 |
|
|
%files |
85 |
|
|
%defattr(-,root,root) |
86 |
|
|
#%doc docs/timeobjects/* |
87 |
|
|
%doc %{pear_hordedir} |
88 |
|
|
%{peardir}/* |
89 |
|
|
%{xmldir}/timeobjects.xml |
90 |
|
|
|
91 |
|
|
%changelog |
92 |
|
|
* Tue Apr 5 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.1.2-1 |
93 |
|
|
- Update to 2.1.2 |
94 |
|
|
|
95 |
|
|
* Sun Feb 7 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.1.1-1 |
96 |
|
|
- Update to 2.1.1 |
97 |
|
|
|
98 |
|
|
* Tue May 13 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.1.0-1 |
99 |
|
|
- Update to 2.1.0 |
100 |
|
|
|
101 |
|
|
* Fri Jun 21 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.0.4-1 |
102 |
|
|
- Update to 2.0.4 |
103 |
|
|
|
104 |
|
|
* Tue Jun 4 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.0.3-1 |
105 |
|
|
- Initial release for SME Server |
106 |
|
|
- Original build from pear make-rpm-spec |
107 |
|
|
|