1 |
slords |
1.1 |
%define apachedir /etc/httpd |
2 |
|
|
%define apacheuser www |
3 |
|
|
%define apachegroup www |
4 |
|
|
%define contentdir /home/httpd |
5 |
|
|
|
6 |
|
|
Summary: The Horde contact management application. |
7 |
|
|
Name: turba-h3 |
8 |
|
|
Version: 2.1.4 |
9 |
|
|
Release: 2%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Applications/Horde |
12 |
|
|
Source: ftp://ftp.horde.org/pub/turba/tarballs/turba-h3-%{version}.tar.gz |
13 |
|
|
Source1: turba.conf |
14 |
|
|
Patch1: turba-h3-2.1.4-2.javascript.patch |
15 |
|
|
URL: http://www.horde.org/ |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRoot: /tmp/turba-root |
18 |
|
|
AutoReq: no |
19 |
|
|
Requires: php >= 4.3.0 |
20 |
|
|
Requires: httpd >= 2.0.46 |
21 |
|
|
Requires: horde >= 3.1 |
22 |
|
|
Requires: mysql >= 3.23 |
23 |
|
|
Prereq: /usr/bin/perl |
24 |
|
|
Obsoletes: turba |
25 |
|
|
Provides: turba |
26 |
|
|
|
27 |
|
|
%description |
28 |
|
|
Turba is the Horde contact management application, which allows access |
29 |
|
|
to and storage of personal contacts (including name, email address, |
30 |
|
|
phone number, and other easily customizable fields). Turba integrates |
31 |
|
|
with IMP (Horde's webmail application) as its address book. |
32 |
|
|
|
33 |
|
|
The Horde Project writes web applications in PHP and releases them under |
34 |
|
|
Open Source licenses. For more information (including help with Turba) |
35 |
|
|
please visit http://www.horde.org/. |
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
%setup -q -n %{name}-%{version} |
39 |
|
|
|
40 |
|
|
%patch1 -p1 |
41 |
|
|
|
42 |
|
|
%build |
43 |
|
|
|
44 |
|
|
%install |
45 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
46 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
47 |
|
|
cp -p $RPM_SOURCE_DIR/turba.conf $RPM_BUILD_ROOT%{apachedir}/conf |
48 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/turba |
49 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/turba |
50 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/turba/config |
51 |
|
|
for d in *.dist; do |
52 |
|
|
d0=`basename $d .dist` |
53 |
|
|
if [ ! -f "$d0" ]; then |
54 |
|
|
cp -p $d $d0 |
55 |
|
|
fi |
56 |
|
|
done |
57 |
|
|
|
58 |
|
|
%clean |
59 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
60 |
|
|
|
61 |
|
|
%pre |
62 |
|
|
|
63 |
|
|
%post |
64 |
|
|
|
65 |
|
|
%postun |
66 |
|
|
|
67 |
|
|
%files |
68 |
|
|
%defattr(-,root,root) |
69 |
|
|
# Apache turba.conf file |
70 |
|
|
%config %{apachedir}/conf/turba.conf |
71 |
|
|
# Include top level with %dir so not all files are sucked in |
72 |
|
|
%dir %{contentdir}/html/horde/turba |
73 |
|
|
# Include top-level files by hand |
74 |
|
|
%{contentdir}/html/horde/turba/*.php |
75 |
|
|
# Include these dirs so that all files _will_ get sucked in |
76 |
|
|
%{contentdir}/html/horde/turba/lib |
77 |
|
|
%{contentdir}/html/horde/turba/locale |
78 |
|
|
%{contentdir}/html/horde/turba/po |
79 |
|
|
%{contentdir}/html/horde/turba/scripts |
80 |
|
|
%{contentdir}/html/horde/turba/templates |
81 |
|
|
%{contentdir}/html/horde/turba/themes |
82 |
|
|
# Mark documentation files with %doc and %docdir |
83 |
|
|
%doc %{contentdir}/html/horde/turba/LICENSE |
84 |
|
|
%doc %{contentdir}/html/horde/turba/README |
85 |
|
|
%docdir %{contentdir}/html/horde/turba/docs |
86 |
|
|
%{contentdir}/html/horde/turba/docs |
87 |
|
|
# Mark configuration files with %config and use secure permissions |
88 |
|
|
# (note that .dist files are considered software; don't mark %config) |
89 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/turba/config |
90 |
|
|
%defattr(640,root,%{apachegroup}) |
91 |
|
|
%{contentdir}/html/horde/turba/config/.htaccess |
92 |
|
|
%{contentdir}/html/horde/turba/config/*.dist |
93 |
|
|
%config %{contentdir}/html/horde/turba/config/*.php |
94 |
|
|
%config %{contentdir}/html/horde/turba/config/*.xml |
95 |
|
|
|
96 |
|
|
%changelog |
97 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
98 |
|
|
- Clean up spec so package can be built by koji/plague |
99 |
|
|
|
100 |
|
|
* Thu Mar 29 2007 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.4-2 |
101 |
|
|
- Patch for horde bug 5144 - http://bugs.horde.org/ticket/?id=5144, which corrects |
102 |
|
|
an issue with not being able to create or add users to contact lists. [SME: 2786] |
103 |
|
|
|
104 |
|
|
* Sat Mar 24 2007 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.4-1.el4 |
105 |
|
|
- Update to turba 2.1.4 [SME: 2786] |
106 |
|
|
|
107 |
|
|
* Sat Dec 09 2006 Shad L. Lords <slords@mail.com> |
108 |
|
|
- Update to new release naming. No functional changes. |
109 |
|
|
- Make Packager generic |
110 |
|
|
|
111 |
|
|
* Fri Nov 24 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.3-00sme01 |
112 |
|
|
- Update to turba 2.1.3 |
113 |
|
|
|
114 |
|
|
* Sat Sep 9 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.2-00sme01 |
115 |
|
|
- Update to turba 2.1.2 |
116 |
|
|
|
117 |
|
|
* Wed May 24 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.0.5-01sme01 |
118 |
|
|
- Update to turba 2.0.5 |
119 |
|
|
|
120 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 2.0.4-02sme01 |
121 |
|
|
- Adjust Release tag to our standard format [SME: 70] |
122 |
|
|
|
123 |
|
|
* Wed Nov 09 2005 Greg Swallow |
124 |
|
|
- Update to 2.0.4 |
125 |
|
|
|
126 |
|
|
* Thu Apr 21 2005 Charlie Brady <charlieb@e-smith.com> 2.0.2-7sme02 |
127 |
|
|
- Add "Provides: turba" header to satisfy "Requires: turba" packages. |
128 |
|
|
- Remove pre and post scripts, as they're not required for CDROM |
129 |
|
|
install/updates, and could be troublesome. |
130 |
|
|
|
131 |
|
|
* Thu Mar 31 2005 Greg Swallow <gregswallow@skynetonline.ca> |
132 |
|
|
- [2.0.2-7sme01] |
133 |
|
|
- renamed to turba-h3 |
134 |
|
|
- Update for turba-h3-2.0.2 on SME 7 |
135 |
|
|
|
136 |
|
|
* Tue Aug 31 2004 Shad L. Lords <slords@mail.com> |
137 |
|
|
- [1.2-2sme01] |
138 |
|
|
- Update specfile - change apache to httpd in requires |
139 |
|
|
|
140 |
|
|
* Thu May 6 2004 Michael Soulier <michael_soulier@mitel.com> |
141 |
|
|
- [1.2-1es01] |
142 |
|
|
- Patched to remove braindead String class reference. [MN00025049] |
143 |
|
|
|
144 |
|
|
* Wed Apr 23 2003 Gordon Rowell <gordon_rowell@mitel.com> |
145 |
|
|
- [1.2-1es00] |
146 |
|
|
- Rebuild [gordonr 7694] |
147 |
|
|
|
148 |
|
|
* Wed Mar 12 2003 Dan Brown <dan@familybrown.org> |
149 |
|
|
- [1.2-1es] |
150 |
|
|
- Rebuilding with Turba 1.2 |
151 |
|
|
|
152 |
|
|
* Wed May 22 2002 Charlie Brady <charlieb@e-smith.com> |
153 |
|
|
- [1.0-6es] |
154 |
|
|
- Rebuilding in-house. Change Vendor and Packager tags. no other change, |
155 |
|
|
|
156 |
|
|
* Fri Mar 8 2002 Dan Brown <dan@familybrown.org> 1.0-5es |
157 |
|
|
- changed Apache dependency to >= 1.3.19 |
158 |
|
|
|
159 |
|
|
* Tue Feb 12 2002 Dan Brown <dan@familybrown.org> |
160 |
|
|
- 1.0 release 4es |
161 |
|
|
- http://cvs.horde.org/diff.php/turba/lib/api.php?r1=1.14.2.3&r2=1.14.2.4&ty=u |
162 |
|
|
- patch to fix errors adding contacts |
163 |
|
|
|
164 |
|
|
* Mon Feb 11 2002 Dan Brown <dan@familybrown.org> |
165 |
|
|
- 1.0 release 3es |
166 |
|
|
- changed turba.sql to run CREATE TABLE IF NOT EXISTS |
167 |
|
|
|
168 |
|
|
* Sun Feb 10 2002 Dan Brown <dan@familybrown.org> |
169 |
|
|
- 1.0 release 2es |
170 |
|
|
- removed httpd restart--it's giving errors on SME 5.1.2, and |
171 |
|
|
it's handled by the e-smith-horde RPM |
172 |
|
|
|
173 |
|
|
* Sat Feb 09 2002 Dan Brown <dan@familybrown.org> |
174 |
|
|
- 1.0 release 1es |
175 |
|
|
- changed apache user, group, and content directory |
176 |
|
|
|
177 |
|
|
* Wed Jan 02 2002 Brent J. Nordquist <bjn@horde.org> |
178 |
|
|
- 1.0 release 1 |
179 |
|
|
|
180 |
|
|
* Mon Dec 24 2001 Brent J. Nordquist <bjn@horde.org> |
181 |
|
|
- 1.0-RC4 release 1 |
182 |
|
|
|
183 |
|
|
* Sun Dec 16 2001 Brent J. Nordquist <bjn@horde.org> |
184 |
|
|
- initial RPM for Turba 1.0 |
185 |
|
|
|