1 |
mrjhb3 |
1.7 |
# $Id: turba-h3.spec,v 1.6 2008/12/06 21:03:20 mrjhb3 Exp $ |
2 |
slords |
1.4 |
|
3 |
slords |
1.1 |
%define apachedir /etc/httpd |
4 |
|
|
%define apacheuser www |
5 |
|
|
%define apachegroup www |
6 |
|
|
%define contentdir /home/httpd |
7 |
|
|
|
8 |
|
|
Summary: The Horde contact management application. |
9 |
|
|
Name: turba-h3 |
10 |
mrjhb3 |
1.7 |
Version: 2.3.1 |
11 |
slords |
1.2 |
Release: 1%{?dist} |
12 |
slords |
1.1 |
License: GPL |
13 |
|
|
Group: Applications/Horde |
14 |
|
|
Source: ftp://ftp.horde.org/pub/turba/tarballs/turba-h3-%{version}.tar.gz |
15 |
|
|
URL: http://www.horde.org/ |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRoot: /tmp/turba-root |
18 |
|
|
AutoReq: no |
19 |
|
|
Requires: php >= 4.3.0 |
20 |
|
|
Requires: httpd >= 2.0.46 |
21 |
slords |
1.5 |
Requires: horde >= 3.2 |
22 |
slords |
1.1 |
Requires: mysql >= 3.23 |
23 |
|
|
Prereq: /usr/bin/perl |
24 |
|
|
Obsoletes: turba |
25 |
|
|
Provides: turba |
26 |
|
|
|
27 |
|
|
%description |
28 |
|
|
Turba is the Horde contact management application, which allows access |
29 |
|
|
to and storage of personal contacts (including name, email address, |
30 |
|
|
phone number, and other easily customizable fields). Turba integrates |
31 |
|
|
with IMP (Horde's webmail application) as its address book. |
32 |
|
|
|
33 |
|
|
The Horde Project writes web applications in PHP and releases them under |
34 |
|
|
Open Source licenses. For more information (including help with Turba) |
35 |
|
|
please visit http://www.horde.org/. |
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
%setup -q -n %{name}-%{version} |
39 |
|
|
|
40 |
|
|
%build |
41 |
|
|
|
42 |
|
|
%install |
43 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
44 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/turba |
46 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/turba |
47 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/turba/config |
48 |
|
|
for d in *.dist; do |
49 |
|
|
d0=`basename $d .dist` |
50 |
|
|
if [ ! -f "$d0" ]; then |
51 |
|
|
cp -p $d $d0 |
52 |
|
|
fi |
53 |
|
|
done |
54 |
|
|
|
55 |
|
|
%clean |
56 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
57 |
|
|
|
58 |
|
|
%files |
59 |
|
|
%defattr(-,root,root) |
60 |
|
|
# Include top level with %dir so not all files are sucked in |
61 |
|
|
%dir %{contentdir}/html/horde/turba |
62 |
|
|
# Include top-level files by hand |
63 |
|
|
%{contentdir}/html/horde/turba/*.php |
64 |
|
|
# Include these dirs so that all files _will_ get sucked in |
65 |
|
|
%{contentdir}/html/horde/turba/lib |
66 |
|
|
%{contentdir}/html/horde/turba/locale |
67 |
|
|
%{contentdir}/html/horde/turba/po |
68 |
|
|
%{contentdir}/html/horde/turba/scripts |
69 |
|
|
%{contentdir}/html/horde/turba/templates |
70 |
|
|
%{contentdir}/html/horde/turba/themes |
71 |
slords |
1.5 |
%{contentdir}/html/horde/turba/js |
72 |
|
|
%{contentdir}/html/horde/turba/addressbooks |
73 |
slords |
1.1 |
# Mark documentation files with %doc and %docdir |
74 |
|
|
%doc %{contentdir}/html/horde/turba/LICENSE |
75 |
|
|
%doc %{contentdir}/html/horde/turba/README |
76 |
|
|
%docdir %{contentdir}/html/horde/turba/docs |
77 |
|
|
%{contentdir}/html/horde/turba/docs |
78 |
|
|
# Mark configuration files with %config and use secure permissions |
79 |
|
|
# (note that .dist files are considered software; don't mark %config) |
80 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/turba/config |
81 |
|
|
%defattr(640,root,%{apachegroup}) |
82 |
|
|
%{contentdir}/html/horde/turba/config/.htaccess |
83 |
|
|
%{contentdir}/html/horde/turba/config/*.dist |
84 |
|
|
%config %{contentdir}/html/horde/turba/config/*.php |
85 |
|
|
%config %{contentdir}/html/horde/turba/config/*.xml |
86 |
|
|
|
87 |
|
|
%changelog |
88 |
mrjhb3 |
1.7 |
* Fri Jan 2 2009 John H. Bennett III <bennettj@johnbennettservices.com> 2.3.1-1 |
89 |
|
|
- Updated to Turba 2.3.1 [SME: 4833] |
90 |
|
|
|
91 |
mrjhb3 |
1.6 |
* Sat Dec 06 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.3-1 |
92 |
|
|
- Updated to Turba 2.3 [SME: 4833] |
93 |
|
|
|
94 |
slords |
1.5 |
* Wed Jun 18 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2.1-1 |
95 |
|
|
- Update to Turba 2.2.1 |
96 |
slords |
1.1 |
|
97 |
slords |
1.5 |
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2-1 |
98 |
|
|
- initial RPM roll for Turba 2.2 |
99 |
slords |
1.1 |
|