1 |
slords |
1.1 |
# |
2 |
|
|
# RPM spec file for Dan Bernstein's ucspi-tcp package |
3 |
|
|
# |
4 |
|
|
# $Id: ucspi-tcp.spec,v 1.4 2004/09/22 00:17:54 charlieb Exp $ |
5 |
|
|
# |
6 |
|
|
Summary: Command-line tools for building TCP client-server applications. |
7 |
|
|
%define name ucspi-tcp |
8 |
|
|
Name: %{name} |
9 |
|
|
%define version 0.88 |
10 |
|
|
%define release 5 |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: Daniel J. Bernstein |
14 |
|
|
Group: Networking/Daemons |
15 |
|
|
Source: http://cr.yp.to/%{name}/%{name}-%{version}.tar.gz |
16 |
|
|
URL: http://cr.yp.to/ucspi-tcp.html |
17 |
|
|
Patch0: %{name}-%{version}.patch.2001020500 |
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
|
|
Provides: ucspi-tcp |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
tcpserver and tcpclient are easy-to-use command-line tools for building |
24 |
|
|
TCP client-server applications. |
25 |
|
|
|
26 |
|
|
tcpserver waits for incoming connections and, for each connection, runs |
27 |
|
|
a program of your choice. Your program receives environment variables |
28 |
|
|
showing the local and remote host names, IP addresses, and port numbers. |
29 |
|
|
|
30 |
|
|
tcpserver offers a concurrency limit to protect you from running out of |
31 |
|
|
processes and memory. When you are handling 40 (by default) simultaneous |
32 |
|
|
connections, tcpserver smoothly defers acceptance of new connections. |
33 |
|
|
|
34 |
|
|
tcpserver also provides TCP access control features, similar to |
35 |
|
|
tcp-wrappers/tcpd's hosts.allow but much faster. Its access control rules |
36 |
|
|
are compiled into a hashed format with cdb, so it can easily deal with |
37 |
|
|
thousands of different hosts. |
38 |
|
|
|
39 |
|
|
This package includes a recordio tool that monitors all the input and |
40 |
|
|
output of a server. |
41 |
|
|
|
42 |
|
|
tcpclient makes a TCP connection and runs a program of your choice. It |
43 |
|
|
sets up the same environment variables as tcpserver. |
44 |
|
|
|
45 |
|
|
This package includes several sample clients built on top of tcpclient: |
46 |
|
|
who@, date@, finger@, http@, tcpcat, and mconnect. |
47 |
|
|
|
48 |
|
|
tcpserver and tcpclient conform to UCSPI, the UNIX Client-Server Program |
49 |
|
|
Interface, using the TCP protocol. UCSPI tools are available for several |
50 |
|
|
different networks. |
51 |
|
|
|
52 |
|
|
%changelog |
53 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
54 |
|
|
- Clean up spec so package can be built by koji/plague |
55 |
|
|
|
56 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
57 |
|
|
- Update to new release naming. No functional changes. |
58 |
|
|
- Make Packager generic |
59 |
|
|
|
60 |
|
|
* Tue Sep 21 2004 Charlie Brady <charlieb@e-smith.com> |
61 |
|
|
- [0.88-04] |
62 |
|
|
- Rebuild for CentOs 3.3 |
63 |
|
|
- Configure compiler to work around errno problem. |
64 |
|
|
|
65 |
|
|
* Mon Feb 5 2001 Peter Samuel <peters@e-smith.com> |
66 |
|
|
- [0.88-03] |
67 |
|
|
- Now installs in its own root area prior to creating binary RPM. |
68 |
|
|
- Default installation locations are restored. |
69 |
|
|
|
70 |
|
|
* Thu Aug 17 2000 Peter Samuel <peters@e-smith.com> |
71 |
|
|
- [0.88-2] |
72 |
|
|
- added patch to change default install location |
73 |
|
|
|
74 |
|
|
%prep |
75 |
|
|
%setup |
76 |
|
|
|
77 |
|
|
# This patch allows files to be installed in a relative directory prior |
78 |
|
|
# to creating the binary RPM. It does not change the files or their |
79 |
|
|
# final installed locations. |
80 |
|
|
|
81 |
|
|
%patch0 -p1 |
82 |
|
|
|
83 |
|
|
# Create the relative installation directory. |
84 |
|
|
|
85 |
|
|
mkdir -p ./root/usr |
86 |
|
|
|
87 |
|
|
%build |
88 |
|
|
echo gcc -O2 --include /usr/include/errno.h > conf-cc |
89 |
|
|
make |
90 |
|
|
|
91 |
|
|
%install |
92 |
|
|
make setup |
93 |
|
|
make check |
94 |
|
|
rm -rf $RPM_BUILD_ROOT |
95 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
96 |
|
|
|
97 |
|
|
%clean |
98 |
|
|
rm -rf $RPM_BUILD_ROOT |
99 |
|
|
|
100 |
|
|
%files |
101 |
|
|
%attr(755,root,root) /usr/local/bin/addcr |
102 |
|
|
%attr(755,root,root) /usr/local/bin/argv0 |
103 |
|
|
%attr(755,root,root) /usr/local/bin/date@ |
104 |
|
|
%attr(755,root,root) /usr/local/bin/delcr |
105 |
|
|
%attr(755,root,root) /usr/local/bin/finger@ |
106 |
|
|
%attr(755,root,root) /usr/local/bin/fixcrio |
107 |
|
|
%attr(755,root,root) /usr/local/bin/http@ |
108 |
|
|
%attr(755,root,root) /usr/local/bin/mconnect |
109 |
|
|
%attr(755,root,root) /usr/local/bin/mconnect-io |
110 |
|
|
%attr(755,root,root) /usr/local/bin/rblsmtpd |
111 |
|
|
%attr(755,root,root) /usr/local/bin/recordio |
112 |
|
|
%attr(755,root,root) /usr/local/bin/tcpcat |
113 |
|
|
%attr(755,root,root) /usr/local/bin/tcpclient |
114 |
|
|
%attr(755,root,root) /usr/local/bin/tcprules |
115 |
|
|
%attr(755,root,root) /usr/local/bin/tcprulescheck |
116 |
|
|
%attr(755,root,root) /usr/local/bin/tcpserver |
117 |
|
|
%attr(755,root,root) /usr/local/bin/who@ |