1 |
# $Id$ |
2 |
|
3 |
# |
4 |
# RPM spec file for Dan Bernstein's ucspi-tcp package |
5 |
# |
6 |
# $Id: ucspi-tcp.spec,v 1.4 2004/09/22 00:17:54 charlieb Exp $ |
7 |
# |
8 |
Summary: Command-line tools for building TCP client-server applications. |
9 |
%define name ucspi-tcp |
10 |
Name: %{name} |
11 |
%define version 0.88 |
12 |
%define release 5 |
13 |
Version: %{version} |
14 |
Release: %{release}%{?dist} |
15 |
License: Daniel J. Bernstein |
16 |
Group: Networking/Daemons |
17 |
Source: http://cr.yp.to/%{name}/%{name}-%{version}.tar.gz |
18 |
URL: http://cr.yp.to/ucspi-tcp.html |
19 |
Patch0: %{name}-%{version}.patch.2001020500 |
20 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
21 |
Provides: ucspi-tcp |
22 |
AutoReqProv: no |
23 |
|
24 |
%description |
25 |
tcpserver and tcpclient are easy-to-use command-line tools for building |
26 |
TCP client-server applications. |
27 |
|
28 |
tcpserver waits for incoming connections and, for each connection, runs |
29 |
a program of your choice. Your program receives environment variables |
30 |
showing the local and remote host names, IP addresses, and port numbers. |
31 |
|
32 |
tcpserver offers a concurrency limit to protect you from running out of |
33 |
processes and memory. When you are handling 40 (by default) simultaneous |
34 |
connections, tcpserver smoothly defers acceptance of new connections. |
35 |
|
36 |
tcpserver also provides TCP access control features, similar to |
37 |
tcp-wrappers/tcpd's hosts.allow but much faster. Its access control rules |
38 |
are compiled into a hashed format with cdb, so it can easily deal with |
39 |
thousands of different hosts. |
40 |
|
41 |
This package includes a recordio tool that monitors all the input and |
42 |
output of a server. |
43 |
|
44 |
tcpclient makes a TCP connection and runs a program of your choice. It |
45 |
sets up the same environment variables as tcpserver. |
46 |
|
47 |
This package includes several sample clients built on top of tcpclient: |
48 |
who@, date@, finger@, http@, tcpcat, and mconnect. |
49 |
|
50 |
tcpserver and tcpclient conform to UCSPI, the UNIX Client-Server Program |
51 |
Interface, using the TCP protocol. UCSPI tools are available for several |
52 |
different networks. |
53 |
|
54 |
%changelog |
55 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
56 |
- Clean up spec so package can be built by koji/plague |
57 |
|
58 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
59 |
- Update to new release naming. No functional changes. |
60 |
- Make Packager generic |
61 |
|
62 |
* Tue Sep 21 2004 Charlie Brady <charlieb@e-smith.com> |
63 |
- [0.88-04] |
64 |
- Rebuild for CentOs 3.3 |
65 |
- Configure compiler to work around errno problem. |
66 |
|
67 |
* Mon Feb 5 2001 Peter Samuel <peters@e-smith.com> |
68 |
- [0.88-03] |
69 |
- Now installs in its own root area prior to creating binary RPM. |
70 |
- Default installation locations are restored. |
71 |
|
72 |
* Thu Aug 17 2000 Peter Samuel <peters@e-smith.com> |
73 |
- [0.88-2] |
74 |
- added patch to change default install location |
75 |
|
76 |
%prep |
77 |
%setup |
78 |
|
79 |
# This patch allows files to be installed in a relative directory prior |
80 |
# to creating the binary RPM. It does not change the files or their |
81 |
# final installed locations. |
82 |
|
83 |
%patch0 -p1 |
84 |
|
85 |
# Create the relative installation directory. |
86 |
|
87 |
mkdir -p ./root/usr |
88 |
|
89 |
%build |
90 |
echo gcc -O2 --include /usr/include/errno.h > conf-cc |
91 |
make |
92 |
|
93 |
%install |
94 |
make setup |
95 |
make check |
96 |
rm -rf $RPM_BUILD_ROOT |
97 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
98 |
|
99 |
%clean |
100 |
rm -rf $RPM_BUILD_ROOT |
101 |
|
102 |
%files |
103 |
%attr(755,root,root) /usr/local/bin/addcr |
104 |
%attr(755,root,root) /usr/local/bin/argv0 |
105 |
%attr(755,root,root) /usr/local/bin/date@ |
106 |
%attr(755,root,root) /usr/local/bin/delcr |
107 |
%attr(755,root,root) /usr/local/bin/finger@ |
108 |
%attr(755,root,root) /usr/local/bin/fixcrio |
109 |
%attr(755,root,root) /usr/local/bin/http@ |
110 |
%attr(755,root,root) /usr/local/bin/mconnect |
111 |
%attr(755,root,root) /usr/local/bin/mconnect-io |
112 |
%attr(755,root,root) /usr/local/bin/rblsmtpd |
113 |
%attr(755,root,root) /usr/local/bin/recordio |
114 |
%attr(755,root,root) /usr/local/bin/tcpcat |
115 |
%attr(755,root,root) /usr/local/bin/tcpclient |
116 |
%attr(755,root,root) /usr/local/bin/tcprules |
117 |
%attr(755,root,root) /usr/local/bin/tcprulescheck |
118 |
%attr(755,root,root) /usr/local/bin/tcpserver |
119 |
%attr(755,root,root) /usr/local/bin/who@ |