/[smeserver]/rpms/ulogd/sme7/ulogd.spec
ViewVC logotype

Annotation of /rpms/ulogd/sme7/ulogd.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Wed Apr 9 13:51:58 2008 UTC (16 years, 2 months ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +2 -0 lines
Add Id to top of spec

1 slords 1.2 # $Id$
2    
3 slords 1.1 Name: ulogd
4     Version: 1.24
5     Release: 2%{?dist}
6     Summary: The userspace logging daemon for netfilter
7     License: GPL
8     Group: System Environment/Daemons
9     URL: http://gnumonks.org/projects/ulogd
10     Source0: http://ftp.netfilter.org/pub/ulogd/ulogd-%{version}.tar.bz2
11     Source1: ulogd.logrotate
12     Source2: ulogd.8
13     Patch1: ulogd-1.21-logdir.patch
14     Patch2: ulogd-1.02-init.patch
15     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16     Requires(post): initscripts, chkconfig
17     Requires(postun): initscripts, chkconfig
18     BuildRequires: mysql-devel
19     BuildRequires: mysql-devel
20     BuildRequires: postgresql-devel
21     BuildRequires: /usr/include/pcap.h
22    
23     %description
24     Ulogd is an universal logging daemon for the ULOG target of netfilter, the
25     Linux 2.4+ firewalling subsystem. Ulogd is able to log packets in various
26     formats to different targets (text files, databases, etc..). It has an
27     easy-to-use plugin interface to add new protocols and new output targets.
28    
29     %package mysql
30     Summary: MySQL output plugin for ulogd
31     Group: System Environment/Daemons
32     Requires: %{name} = %{version}
33    
34     %description mysql
35     Ulogd-mysql is a MySQL output plugin for ulogd. It enables logging of
36     firewall information into a MySQL database.
37    
38     %package pgsql
39     Summary: PostgreSQL output plugin for ulogd
40     Group: System Environment/Daemons
41     Requires: %{name} = %{version}
42    
43     %description pgsql
44     Ulogd-pgsql is a PostgreSQL output plugin for ulogd. It enables logging of
45     firewall information into a PostgreSQL database.
46    
47     %prep
48     %setup -q
49     %patch1 -p1 -b .logdir
50     %patch2 -p1 -b .fedora
51    
52     %build
53     %configure --with-mysql --with-pgsql
54     # Does not support parallel builds
55     make
56    
57     %install
58     rm -rf $RPM_BUILD_ROOT
59     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
60     mkdir -p $RPM_BUILD_ROOT%{_libdir}/ulogd
61     mkdir -p $RPM_BUILD_ROOT%{_sbindir}/sbin
62     make DESTDIR=$RPM_BUILD_ROOT install
63    
64     mkdir -p $RPM_BUILD_ROOT%{_initrddir}
65     install -m755 ulogd.init $RPM_BUILD_ROOT%{_initrddir}/ulogd
66    
67     mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/ulogd
68    
69     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
70     install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/ulogd
71    
72     mkdir -p $RPM_BUILD_ROOT%{_mandir}/man8
73     sed -e 's/@VERSION@/%{version}/g' %{SOURCE2} > $RPM_BUILD_ROOT%{_mandir}/man8/ulogd.8
74     gzip $RPM_BUILD_ROOT%{_mandir}/man8/ulogd.8
75    
76    
77     %post
78     /sbin/chkconfig --add ulogd
79    
80     %preun
81     if [ "$1" = 0 ]; then
82     /sbin/service ulogd stop > /dev/null 2>&1 ||:
83     /sbin/chkconfig --del ulogd
84     fi
85    
86     %postun
87     if [ "$1" -ge "1" ]; then
88     /sbin/service ulogd reload > /dev/null 2>&1 ||:
89     fi
90    
91    
92     %clean
93     rm -rf $RPM_BUILD_ROOT
94    
95     %files
96     %defattr(-,root,root,)
97     %doc COPYING AUTHORS README
98     %doc doc/ulogd.txt doc/ulogd.a4.ps doc/ulogd.html
99     %doc doc/mysql.table* doc/pgsql.table
100     %{_sbindir}/ulogd
101     %config(noreplace) %{_sysconfdir}/ulogd.conf
102     %config(noreplace) %{_sysconfdir}/rc.d/init.d/ulogd
103     %{_libdir}/ulogd
104     %dir %{_localstatedir}/log/ulogd
105     %config(noreplace) %{_sysconfdir}/logrotate.d/ulogd
106     %{_mandir}/man8/ulogd.8.gz
107     %exclude %{_libdir}/ulogd/ulogd_MYSQL.so
108     %exclude %{_libdir}/ulogd/ulogd_PGSQL.so
109    
110     %files mysql
111     %defattr(0644,root,root,0755)
112     %{_libdir}/ulogd/ulogd_MYSQL.so
113    
114     %files pgsql
115     %defattr(0644,root,root,0755)
116     %{_libdir}/ulogd/ulogd_PGSQL.so
117    
118     %changelog
119     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
120     - Clean up spec so package can be built by koji/plague
121    
122     * Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-2
123     - rebuild
124    
125     * Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.24-1
126     - version 1.24
127     - drop patch3 (applied upstream)
128     - drop patch4 (upstream uses mysql-config to detect libdir now)
129     - drop patch5 (applied upstream)
130    
131     * Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 1.23-3
132     - rebuild for FC5
133    
134     * Sun Jul 24 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-2
135     - compress rotated logs
136     - start after mysql in the init process
137     - use dist tag
138    
139     * Tue Apr 19 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-1.fc4
140     - version 1.23
141     - change release tag for FC4
142     - add patch for GCC4 (upstream bug #323)
143    
144     * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
145     - rebuilt
146    
147     * Wed Mar 09 2005 Aurelien Bompard <gauret[AT]free.fr> 1.22-1
148     - version 1.22
149     - add gpg signature to sources
150    
151     * Sun Feb 20 2005 Aurelien Bompard <gauret[AT]free.fr> 1.21-1
152     - version 1.21
153    
154     * Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-8
155     - revise x86_64 patch to remove more hardcoded /lib badness
156    
157     * Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-7
158     - x86_64, patch configure to look for mysql/pgsql below %%_libdir.
159     - delete undefined %%epoch in mysql/pgsql sub package dep.
160    
161     * Sun Oct 31 2004 Aurelien Bompard <gauret[AT]free.fr> 1.02-6
162     - apply Michael Schwendt's suggestions in bug 1598
163    
164     * Wed Oct 20 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.5
165     - enable MySQL and PostgreSQL in subpackages
166     - add man page from Debian
167    
168     * Wed Oct 06 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.4
169     - apply QA suggestions (bug 1598)
170    
171     * Sat Jul 10 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.3
172     - disable parallel builds
173     - add chkconfig to Requires(pre,post)
174     - set the right mode for /etc/logrotate.d/ulogd
175     - rotate weekly
176    
177     * Sun May 16 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.2
178     - Add Epoch: 0

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed