1 |
Name: ulogd |
2 |
Version: 1.24 |
3 |
Release: 13%{?dist} |
4 |
Summary: The userspace logging daemon for netfilter |
5 |
License: GPLv2 |
6 |
Group: System Environment/Daemons |
7 |
URL: http://gnumonks.org/projects |
8 |
Source0: http://ftp.netfilter.org/pub/ulogd/ulogd-%{version}.tar.bz2 |
9 |
Source1: ulogd.logrotate |
10 |
Source2: ulogd.8 |
11 |
Patch1: ulogd-1.21-logdir.patch |
12 |
Patch2: ulogd-1.02-init.patch |
13 |
# Bug 247345 |
14 |
Patch3: ulogd-1.24-fortify-source.patch |
15 |
# The code uses a deprecated way of getting its DSO initializers run, |
16 |
# build fails with rpm-build > 4.4.2.1-3 (new find-debuginfo.sh script) |
17 |
Patch4: ulogd-1.24-initializers.patch |
18 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
19 |
Requires(post): initscripts, chkconfig |
20 |
Requires(postun): initscripts, chkconfig |
21 |
BuildRequires: mysql-devel |
22 |
BuildRequires: postgresql-devel |
23 |
BuildRequires: libpcap-devel |
24 |
BuildRequires: openssl-devel |
25 |
|
26 |
%description |
27 |
Ulogd is an universal logging daemon for the ULOG target of netfilter, the |
28 |
Linux 2.4+ firewalling subsystem. Ulogd is able to log packets in various |
29 |
formats to different targets (text files, databases, etc..). It has an |
30 |
easy-to-use plugin interface to add new protocols and new output targets. |
31 |
|
32 |
%package mysql |
33 |
Summary: MySQL output plugin for ulogd |
34 |
Group: System Environment/Daemons |
35 |
Requires: %{name} = %{version} |
36 |
|
37 |
%description mysql |
38 |
Ulogd-mysql is a MySQL output plugin for ulogd. It enables logging of |
39 |
firewall information into a MySQL database. |
40 |
|
41 |
%package pgsql |
42 |
Summary: PostgreSQL output plugin for ulogd |
43 |
Group: System Environment/Daemons |
44 |
Requires: %{name} = %{version} |
45 |
|
46 |
%description pgsql |
47 |
Ulogd-pgsql is a PostgreSQL output plugin for ulogd. It enables logging of |
48 |
firewall information into a PostgreSQL database. |
49 |
|
50 |
%package pcap |
51 |
Summary: PCAP output plugin for ulogd |
52 |
Group: System Environment/Daemons |
53 |
Requires: %{name} = %{version} |
54 |
|
55 |
%description pcap |
56 |
ulogd-pcap is a output plugin for ulogd that saves packet logs as PCAP file. |
57 |
PCAP is a standard format that can be later analyzed by a lot of tools such as |
58 |
tcpdump and wireshark. |
59 |
|
60 |
|
61 |
%prep |
62 |
%setup -q |
63 |
%patch1 -p1 -b .logdir |
64 |
%patch2 -p1 -b .lsbinit |
65 |
%patch3 -p0 -b .fortify-source |
66 |
# Enable BuildID : |
67 |
# https://www.redhat.com/archives/fedora-devel-announce/2007-August/msg00007.html |
68 |
perl -pi -e 's/\(LD\) -shared/(CC) \$(CFLAGS) \$(LDFLAGS) -shared/g' */Makefile.in |
69 |
%patch4 -p1 -b .initializers |
70 |
|
71 |
|
72 |
%build |
73 |
%configure --with-mysql --with-pgsql |
74 |
# Does not support parallel builds |
75 |
make |
76 |
|
77 |
%install |
78 |
rm -rf $RPM_BUILD_ROOT |
79 |
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir} |
80 |
mkdir -p $RPM_BUILD_ROOT%{_libdir}/ulogd |
81 |
mkdir -p $RPM_BUILD_ROOT%{_sbindir}/sbin |
82 |
make DESTDIR=$RPM_BUILD_ROOT install |
83 |
|
84 |
mkdir -p $RPM_BUILD_ROOT%{_initrddir} |
85 |
install -m755 ulogd.init $RPM_BUILD_ROOT%{_initrddir}/ulogd |
86 |
|
87 |
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/ulogd |
88 |
|
89 |
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d |
90 |
install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/ulogd |
91 |
|
92 |
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man8 |
93 |
sed -e 's/@VERSION@/%{version}/g' %{SOURCE2} > $RPM_BUILD_ROOT%{_mandir}/man8/ulogd.8 |
94 |
gzip $RPM_BUILD_ROOT%{_mandir}/man8/ulogd.8 |
95 |
|
96 |
|
97 |
%post |
98 |
/sbin/chkconfig --add ulogd |
99 |
|
100 |
%preun |
101 |
if [ "$1" = 0 ]; then |
102 |
/sbin/service ulogd stop > /dev/null 2>&1 ||: |
103 |
/sbin/chkconfig --del ulogd |
104 |
fi |
105 |
|
106 |
%postun |
107 |
if [ "$1" -ge "1" ]; then |
108 |
/sbin/service ulogd reload > /dev/null 2>&1 ||: |
109 |
fi |
110 |
|
111 |
|
112 |
%clean |
113 |
rm -rf $RPM_BUILD_ROOT |
114 |
|
115 |
%files |
116 |
%defattr(-,root,root,) |
117 |
%doc COPYING AUTHORS README |
118 |
%doc doc/ulogd.txt doc/ulogd.a4.ps doc/ulogd.html |
119 |
%doc doc/mysql.table* doc/pgsql.table |
120 |
%{_sbindir}/ulogd |
121 |
%config(noreplace) %{_sysconfdir}/ulogd.conf |
122 |
%{_sysconfdir}/rc.d/init.d/ulogd |
123 |
%{_libdir}/ulogd |
124 |
%dir %{_localstatedir}/log/ulogd |
125 |
%config(noreplace) %{_sysconfdir}/logrotate.d/ulogd |
126 |
%{_mandir}/man8/ulogd.8.gz |
127 |
%exclude %{_libdir}/ulogd/ulogd_MYSQL.so |
128 |
%exclude %{_libdir}/ulogd/ulogd_PGSQL.so |
129 |
%exclude %{_libdir}/ulogd/ulogd_PCAP.so |
130 |
|
131 |
%files mysql |
132 |
%defattr(0755,root,root) |
133 |
%{_libdir}/ulogd/ulogd_MYSQL.so |
134 |
|
135 |
%files pgsql |
136 |
%defattr(0755,root,root) |
137 |
%{_libdir}/ulogd/ulogd_PGSQL.so |
138 |
|
139 |
%files pcap |
140 |
%defattr(0755,root,root) |
141 |
%{_libdir}/ulogd/ulogd_PCAP.so |
142 |
|
143 |
%changelog |
144 |
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.24-13 |
145 |
- rebuilt with new openssl |
146 |
|
147 |
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-12 |
148 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
149 |
|
150 |
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-11 |
151 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
152 |
|
153 |
* Sat Jan 24 2009 Aurelien Bompard <abompard@fedoraproject.org> 1.24-10 |
154 |
- rebuild for mysql |
155 |
|
156 |
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.24-9 |
157 |
- Autorebuild for GCC 4.3 |
158 |
|
159 |
* Wed Jan 9 2008 Leopold Aichinger <linuxtrainer@gmx.at> 1.24-8 |
160 |
- Support for libpcap added |
161 |
|
162 |
* Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.24-7 |
163 |
- Rebuild for deps |
164 |
|
165 |
* Tue Aug 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-5 |
166 |
- Fix the deprecated way of getting the DSO initializers run, causing |
167 |
builds to fails with rpm-build > 4.4.2.1-3 (new find-debuginfo.sh script) |
168 |
|
169 |
* Sat Jul 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-4 |
170 |
- add patch to fix bug 247345 |
171 |
- update URL |
172 |
- fix initscript (bug 247083) |
173 |
- unmark init script as %%config (Fedora policy) |
174 |
|
175 |
* Sat Dec 09 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-3 |
176 |
- rebuild |
177 |
|
178 |
* Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-2 |
179 |
- rebuild |
180 |
|
181 |
* Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.24-1 |
182 |
- version 1.24 |
183 |
- drop patch3 (applied upstream) |
184 |
- drop patch4 (upstream uses mysql-config to detect libdir now) |
185 |
- drop patch5 (applied upstream) |
186 |
|
187 |
* Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 1.23-3 |
188 |
- rebuild for FC5 |
189 |
|
190 |
* Sun Jul 24 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-2 |
191 |
- compress rotated logs |
192 |
- start after mysql in the init process |
193 |
- use dist tag |
194 |
|
195 |
* Tue Apr 19 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-1.fc4 |
196 |
- version 1.23 |
197 |
- change release tag for FC4 |
198 |
- add patch for GCC4 (upstream bug #323) |
199 |
|
200 |
* Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> |
201 |
- rebuilt |
202 |
|
203 |
* Wed Mar 09 2005 Aurelien Bompard <gauret[AT]free.fr> 1.22-1 |
204 |
- version 1.22 |
205 |
- add gpg signature to sources |
206 |
|
207 |
* Sun Feb 20 2005 Aurelien Bompard <gauret[AT]free.fr> 1.21-1 |
208 |
- version 1.21 |
209 |
|
210 |
* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-8 |
211 |
- revise x86_64 patch to remove more hardcoded /lib badness |
212 |
|
213 |
* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-7 |
214 |
- x86_64, patch configure to look for mysql/pgsql below %%_libdir. |
215 |
- delete undefined %%epoch in mysql/pgsql sub package dep. |
216 |
|
217 |
* Sun Oct 31 2004 Aurelien Bompard <gauret[AT]free.fr> 1.02-6 |
218 |
- apply Michael Schwendt's suggestions in bug 1598 |
219 |
|
220 |
* Wed Oct 20 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.5 |
221 |
- enable MySQL and PostgreSQL in subpackages |
222 |
- add man page from Debian |
223 |
|
224 |
* Wed Oct 06 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.4 |
225 |
- apply QA suggestions (bug 1598) |
226 |
|
227 |
* Sat Jul 10 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.3 |
228 |
- disable parallel builds |
229 |
- add chkconfig to Requires(pre,post) |
230 |
- set the right mode for /etc/logrotate.d/ulogd |
231 |
- rotate weekly |
232 |
|
233 |
* Sun May 16 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.2 |
234 |
- Add Epoch: 0 |