1 |
# $Id$ |
2 |
|
3 |
%define pythonver 2.2 |
4 |
|
5 |
Summary: A console dialog tool, for use by SME server console |
6 |
Name: whiptail |
7 |
%define version 0.51.5 |
8 |
Version: %{version} |
9 |
Release: 9%{?dist} |
10 |
License: LGPL |
11 |
Group: System Environment/Libraries |
12 |
Source: whiptail-%{version}.tar.gz |
13 |
Patch100: newt-0.51.5.patch.2004082000 |
14 |
Patch101: newt-0.51.5.patch.2006100300 |
15 |
Patch102: newt-0.51.5.patch.2006100301 |
16 |
BuildRequires: newt-devel |
17 |
Requires: newt |
18 |
BuildRoot: %{_tmppath}/%{name}-%{version}-root |
19 |
|
20 |
%Description |
21 |
whiptail is a /usr/bin/dialog replacement. This version contains |
22 |
modifications for use by the SME server console program. |
23 |
|
24 |
%prep |
25 |
%setup -q |
26 |
|
27 |
%build |
28 |
D= |
29 |
cc -O2 -Wall -I/usr/include/slang -D_GNU_SOURCE \ |
30 |
-c -o whiptail.o whiptail.c |
31 |
cc -O2 -Wall -I/usr/include/slang -D_GNU_SOURCE \ |
32 |
$(if grep -q _newt_wstr %_libdir/libnewt.so; then echo -Dwstrlen=_newt_wstrlen; fi) \ |
33 |
-c -o dialogboxes.o dialogboxes.c |
34 |
gcc -g -o whiptail whiptail.o dialogboxes.o \ |
35 |
-lnewt -lslang -lm -lpopt |
36 |
|
37 |
%install |
38 |
rm -rf $RPM_BUILD_ROOT |
39 |
mkdir -p $RPM_BUILD_ROOT/sbin/e-smith |
40 |
install -m 755 whiptail $RPM_BUILD_ROOT/sbin/e-smith |
41 |
|
42 |
%clean |
43 |
rm -rf $RPM_BUILD_ROOT |
44 |
|
45 |
%files |
46 |
%defattr (-,root,root) |
47 |
%doc COPYING |
48 |
/sbin/e-smith/whiptail |
49 |
|
50 |
%changelog |
51 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
52 |
- Clean up spec so package can be built by koji/plague |
53 |
|
54 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> 0.51.5-9 |
55 |
- Better fix for finding correct libdir |
56 |
|
57 |
* Sat Apr 28 2007 Shad L. Lords <slords@mail.com> 0.51.5-8 |
58 |
- Change to dist for tagging release |
59 |
- Use correct lib for 32/64 bit |
60 |
|
61 |
* Thu Feb 1 2007 Charlie Brady <charlieb@e-smith.com> 0.51.5-7 |
62 |
- Autodetect need for -Dwstrlen=_newt_wstrlen. |
63 |
|
64 |
* Thu Feb 1 2007 Charlie Brady <charlieb@e-smith.com> 0.51.5-6 |
65 |
- Fix for building under FC6/RHEL5 |
66 |
|
67 |
* Thu Feb 1 2007 Charlie Brady <charlieb@e-smith.com> 0.51.5-5 |
68 |
- Repackage so that build is done against the installed newt library. |
69 |
(Patches are left included in SRPM for informational reasons). |
70 |
|
71 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
72 |
- Update to new release naming. No functional changes. |
73 |
- Make Packager generic |
74 |
|
75 |
* Tue Oct 03 2006 Charlie Brady <charlie_brady@mitel.com> 0.51.5-3es1 |
76 |
- Add --{ok,yes,cancel,no}-label aliases for --left and --right, for |
77 |
compatibility with 'dialog'. |
78 |
|
79 |
* Tue Oct 03 2006 Charlie Brady <charlie_brady@mitel.com> 0.51.5-2es1 |
80 |
- Add --default-item option for use in listBox. [SME: 1959] |
81 |
|
82 |
* Wed Feb 16 2005 Charlie Brady <charlieb@e-smith.com> 0.51.5-1es1 |
83 |
- Initial - forked from newt-0.51.5-1es1 |