1 |
slords |
1.1 |
# $Id: whiptail.spec,v 1.2 2008/04/09 13:51:58 slords Exp $ |
2 |
|
|
|
3 |
|
|
%define pythonver 2.2 |
4 |
|
|
|
5 |
|
|
Summary: A console dialog tool, for use by SME server console |
6 |
|
|
Name: whiptail |
7 |
|
|
%define version 0.51.5 |
8 |
|
|
Version: %{version} |
9 |
|
|
Release: 9%{?dist} |
10 |
|
|
License: LGPL |
11 |
|
|
Group: System Environment/Libraries |
12 |
|
|
Source: whiptail-%{version}.tar.gz |
13 |
|
|
Patch100: newt-0.51.5.patch.2004082000 |
14 |
|
|
Patch101: newt-0.51.5.patch.2006100300 |
15 |
|
|
Patch102: newt-0.51.5.patch.2006100301 |
16 |
|
|
BuildRequires: newt-devel |
17 |
|
|
BuildRequires: popt-devel |
18 |
|
|
Requires: newt |
19 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root |
20 |
|
|
|
21 |
|
|
%Description |
22 |
|
|
whiptail is a /usr/bin/dialog replacement. This version contains |
23 |
|
|
modifications for use by the SME server console program. |
24 |
|
|
|
25 |
|
|
%prep |
26 |
|
|
%setup -q |
27 |
|
|
|
28 |
|
|
%build |
29 |
|
|
D= |
30 |
|
|
cc -O2 -Wall -I/usr/include/slang -D_GNU_SOURCE \ |
31 |
|
|
-c -o whiptail.o whiptail.c |
32 |
|
|
cc -O2 -Wall -I/usr/include/slang -D_GNU_SOURCE \ |
33 |
|
|
$(if grep -q _newt_wstr %_libdir/libnewt.so; then echo -Dwstrlen=_newt_wstrlen; fi) \ |
34 |
|
|
-c -o dialogboxes.o dialogboxes.c |
35 |
|
|
gcc -g -o whiptail whiptail.o dialogboxes.o \ |
36 |
|
|
-lnewt -lslang -lm -lpopt |
37 |
|
|
|
38 |
|
|
%install |
39 |
|
|
rm -rf $RPM_BUILD_ROOT |
40 |
|
|
mkdir -p $RPM_BUILD_ROOT/sbin/e-smith |
41 |
|
|
install -m 755 whiptail $RPM_BUILD_ROOT/sbin/e-smith |
42 |
|
|
|
43 |
|
|
%clean |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
|
46 |
|
|
%files |
47 |
|
|
%defattr (-,root,root) |
48 |
|
|
%doc COPYING |
49 |
|
|
/sbin/e-smith/whiptail |
50 |
|
|
|
51 |
|
|
%changelog |
52 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
53 |
|
|
- Clean up spec so package can be built by koji/plague |
54 |
|
|
|
55 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> 0.51.5-9 |
56 |
|
|
- Better fix for finding correct libdir |
57 |
|
|
|
58 |
|
|
* Sat Apr 28 2007 Shad L. Lords <slords@mail.com> 0.51.5-8 |
59 |
|
|
- Change to dist for tagging release |
60 |
|
|
- Use correct lib for 32/64 bit |
61 |
|
|
|
62 |
|
|
* Thu Feb 1 2007 Charlie Brady <charlieb@e-smith.com> 0.51.5-7 |
63 |
|
|
- Autodetect need for -Dwstrlen=_newt_wstrlen. |
64 |
|
|
|
65 |
|
|
* Thu Feb 1 2007 Charlie Brady <charlieb@e-smith.com> 0.51.5-6 |
66 |
|
|
- Fix for building under FC6/RHEL5 |
67 |
|
|
|
68 |
|
|
* Thu Feb 1 2007 Charlie Brady <charlieb@e-smith.com> 0.51.5-5 |
69 |
|
|
- Repackage so that build is done against the installed newt library. |
70 |
|
|
(Patches are left included in SRPM for informational reasons). |
71 |
|
|
|
72 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
73 |
|
|
- Update to new release naming. No functional changes. |
74 |
|
|
- Make Packager generic |
75 |
|
|
|
76 |
|
|
* Tue Oct 03 2006 Charlie Brady <charlie_brady@mitel.com> 0.51.5-3es1 |
77 |
|
|
- Add --{ok,yes,cancel,no}-label aliases for --left and --right, for |
78 |
|
|
compatibility with 'dialog'. |
79 |
|
|
|
80 |
|
|
* Tue Oct 03 2006 Charlie Brady <charlie_brady@mitel.com> 0.51.5-2es1 |
81 |
|
|
- Add --default-item option for use in listBox. [SME: 1959] |
82 |
|
|
|
83 |
|
|
* Wed Feb 16 2005 Charlie Brady <charlieb@e-smith.com> 0.51.5-1es1 |
84 |
|
|
- Initial - forked from newt-0.51.5-1es1 |