1 |
Summary: SME server module to configure pdns_recursor |
2 |
%define name smeserver-pdns_recursor |
3 |
Name: %{name} |
4 |
%define version 0.0.1 |
5 |
%define release 4 |
6 |
Version: %{version} |
7 |
Release: %{release}%{?dist} |
8 |
License: GPL |
9 |
Group: System Environment/Base |
10 |
Source: %{name}-%{version}.tar.gz |
11 |
Patch0: smeserver-pdns_recursor-0.0.1.configuration.patch |
12 |
Patch1: smeserver-pdns_recursor-0.0.1.configuration.patch2 |
13 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
BuildArchitectures: noarch |
15 |
Requires: e-smith-lib >= 1.15.1-19 |
16 |
Requires: pdns-recursor |
17 |
Obsoletes: e-smith-dnscache |
18 |
Conflicts: e-smith-dnscache |
19 |
BuildRequires: e-smith-devtools |
20 |
AutoReqProv: no |
21 |
|
22 |
%description |
23 |
SME server enhancement to configure and run PowerDNS recursor as a |
24 |
caching nameserver |
25 |
|
26 |
%changelog |
27 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
28 |
- Clean up spec so package can be built by koji/plague |
29 |
|
30 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
31 |
- Update to new release naming. No functional changes. |
32 |
- Make Packager generic |
33 |
|
34 |
* Thu Aug 24 2006 Charlie Brady <charlieb@e-smith.com> 0.0.1-03 |
35 |
- Various configuration fixes. Functional in basic configuration now. |
36 |
- TODO: Handle forwarding configurations correctly. |
37 |
|
38 |
* Thu Aug 24 2006 Charlie Brady <charlieb@e-smith.com> 0.0.1-02 |
39 |
- Add configuration scripts and templates |
40 |
|
41 |
* Wed Aug 23 2006 Charlie Brady <charlieb@e-smith.com> 0.0.1-01 |
42 |
- Initial |
43 |
|
44 |
%prep |
45 |
%setup |
46 |
%patch0 -p1 |
47 |
%patch1 -p1 |
48 |
|
49 |
%build |
50 |
perl createlinks |
51 |
rm -f %{name}-%{version}-%{release}-filelist |
52 |
mkdir -p root/var/log/pdns_recursor |
53 |
touch root/var/service/pdns_recursor/down |
54 |
|
55 |
%pre |
56 |
/sbin/e-smith/create-system-user dnscache 410 \ |
57 |
"DNScache user" /var/service/dnscache /bin/false |
58 |
/sbin/e-smith/create-system-user dnslog 411 \ |
59 |
"DNS log user" /var/log /bin/false |
60 |
|
61 |
%install |
62 |
rm -rf $RPM_BUILD_ROOT |
63 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
64 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
65 |
--dir /var/service/pdns_recursor 'attr(0755,root,root)' \ |
66 |
--dir /var/service/pdns_recursor/log 'attr(0755,root,root)' \ |
67 |
--file /var/service/pdns_recursor/run 'attr(0750,root,root)' \ |
68 |
--file /var/service/pdns_recursor/log/run 'attr(0750,root,root)' \ |
69 |
--dir /var/log/pdns_recursor 'attr(02755,dnslog,dnslog)' \ |
70 |
> %{name}-%{version}-%{release}-filelist |
71 |
#echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist |
72 |
|
73 |
%clean |
74 |
rm -rf $RPM_BUILD_ROOT |
75 |
|
76 |
%files -f %{name}-%{version}-%{release}-filelist |
77 |
%defattr(-,root,root) |