1 |
slords |
1.1 |
Summary: smeserver module to control squid cache |
2 |
|
|
%define name smeserver-squid_cache_mgt |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.0 |
5 |
|
|
%define release 2 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: Freely distributable |
9 |
|
|
Group: Backup/Daemons |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
12 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
13 |
|
|
BuildRequires: e-smith-devtools |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: smeserver-release >= 6 |
16 |
|
|
AutoReqProv: no |
17 |
|
|
|
18 |
|
|
%changelog |
19 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
20 |
|
|
- Clean up spec so package can be built by koji/plague |
21 |
|
|
|
22 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
23 |
|
|
- Update to new release naming. No functional changes. |
24 |
|
|
- Make Packager generic |
25 |
|
|
|
26 |
|
|
* Mon Sep 25 2006 Michel Van hees <michel@vanhees.cc> |
27 |
|
|
- Bug correctoion in SPEC file |
28 |
|
|
|
29 |
|
|
* Mon Aug 28 2006 Michel Van hees <michel@vanhees.cc> |
30 |
|
|
- RePackage to fit smeserver 7 notation |
31 |
|
|
|
32 |
|
|
* Sat Dec 18 2003 Michel Van hees <mvanhees@vanhees.homeip.net> |
33 |
|
|
- initial release |
34 |
|
|
|
35 |
|
|
%description |
36 |
|
|
smeserver module to control size of cache for squid |
37 |
|
|
|
38 |
|
|
%prep |
39 |
|
|
%setup |
40 |
|
|
#%patch0 -p1 |
41 |
|
|
#%patch1 -p1 |
42 |
|
|
|
43 |
|
|
%build |
44 |
|
|
perl createlinks |
45 |
|
|
|
46 |
|
|
%install |
47 |
|
|
rm -rf $RPM_BUILD_ROOT |
48 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
49 |
|
|
rm -f %{name}-%{version}-filelist |
50 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
51 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
52 |
|
|
|
53 |
|
|
%clean |
54 |
|
|
rm -rf $RPM_BUILD_ROOT |
55 |
|
|
|
56 |
|
|
%pre |
57 |
|
|
%preun |
58 |
|
|
%post |
59 |
|
|
/sbin/e-smith/db configuration set squidCache configuration |
60 |
|
|
/sbin/e-smith/db configuration setprop squidCache squidSize 100 |
61 |
|
|
/sbin/e-smith/db configuration setprop squidCache squidPath /var/spool/squid |
62 |
|
|
/sbin/e-smith/db configuration setprop squidCache squidType ufs |
63 |
|
|
/sbin/e-smith/db configuration setprop squidCache squidMaxObj 3 |
64 |
|
|
/sbin/e-smith/db configuration setprop squidCache squidMaxType KB |
65 |
|
|
/sbin/e-smith/db configuration setprop squidCache squidFirstLevel 16 |
66 |
|
|
/sbin/e-smith/db configuration setprop squidCache squidSecondLevel 256 |
67 |
|
|
/etc/e-smith/events/actions/navigation-conf > /dev/null 2>&1 |
68 |
|
|
echo Install completed |
69 |
|
|
|
70 |
|
|
%postun |
71 |
|
|
/sbin/e-smith/db configuration delete squidCache |
72 |
|
|
/sbin/e-smith/expand-template /etc/squid/squid.conf |
73 |
|
|
/etc/e-smith/events/actions/navigation-conf > /dev/null 2>&1 |
74 |
|
|
/etc/rc.d/rc7.d/S90squid restart |
75 |
|
|
|
76 |
|
|
%files -f %{name}-%{version}-filelist |
77 |
|
|
%defattr(-,root,root) |