/[smecontribs]/rpms/seafile/contribs9/seafile.spec
ViewVC logotype

Annotation of /rpms/seafile/contribs9/seafile.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Wed Feb 28 06:56:56 2018 UTC (6 years, 2 months ago) by jpp
Branch: MAIN
Changes since 1.1: +2 -15 lines
* Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 5.1.3-1.sme
- First import to SME Server
- test with vala < 0.26 : vala-0.10.4-1.el6

1 jpp 1.1 %define major 0
2     %define libname %{name}-lib
3     %define develname %{name}-devel
4     %define release 1
5     Name: seafile
6     Version: 5.1.3
7     Release: %{release}
8     Summary: Open source cloud storage system with features on privacy protection and teamwork
9     License: GPLv3+
10     Group: Networking/File transfer
11     URL: https://github.com/haiwen/seafile
12     Source0: https://github.com/haiwen/seafile/archive/v%{version}/%{name}-%{version}.tar.gz
13     #Source0: https://github.com/haiwen/seafile-server/archive/v%{version}-server.tar.gz
14     Patch0: seafile-5.1.1-evhtp.patch
15     Patch1: seafile-5.1.3.libarchive.patch
16     #seafile-server-6.1.1-server.libarchive.patch
17     BuildRequires: intltool
18     BuildRequires: pkgconfig(glib-2.0)
19     BuildRequires: pkgconfig(jansson)
20     #BuildRequires: pkgconfig(sqlite3)
21     BuildRequires: sqlite-devel >= 3.7.17
22     BuildRequires: pkgconfig(openssl)
23     BuildRequires: pkgconfig(libevent)
24     BuildRequires: pkgconfig(uuid) >= 2.0
25     BuildRequires: pkgconfig(libcurl)
26     BuildRequires: pkgconfig(libsearpc)
27     #BuildRequires: pkgconfig(libccnet)
28     BuildRequires: ccnet-devel
29     ##BuildRequires: pkgconfig(python)
30     BuildRequires: python-devel
31     #BuildRequires: vala >= 0.26
32     BuildRequires: vala
33     # server requirements
34     BuildRequires: pkgconfig(zdb)
35     BuildRequires: pkgconfig(evhtp)
36     BuildRequires: pkgconfig(libarchive)
37     #add jpp epel
38     BuildRequires: libedit
39     BuildRequires: libtool
40     BuildRequires: fuse-devel fuse
41     Requires: fuse
42     Requires: sqlite >= 3.7.17
43     #fin add jpp
44    
45     Requires: ccnet >= %{version}
46     Requires: pythonegg(2)(seafile) = %{version}-%{release}
47     %description
48     Seafile is an open source cloud storage system with features on privacy
49     protection and teamwork. Collections of files are called libraries, and
50     each library can be synced separately. A library can also be encrypted
51     with a user chosen password. Seafile also allows users to create groups
52     and easily sharing files into groups.
53    
54     #----------------------------------------------------
55    
56     %package server
57     Summary: Seafile server
58     Group: Networking/File transfer
59     Requires: ccnet-server
60     #>= %{version}
61     #Requires: ccnet >= %{version}
62     Requires: pythonegg(2)(seaserv) = %{version}-%{release}
63    
64     %description server
65     Seafile is an open source cloud storage system with features on privacy
66     protection and teamwork. Collections of files are called libraries, and
67     each library can be synced separately. A library can also be encrypted
68     with a user chosen password. Seafile also allows users to create groups
69     and easily sharing files into groups.
70     This package contains the server part for %{name}.
71    
72     #----------------------------------------------------
73    
74     %package -n %{libname}
75     Summary: Library for %{name}
76     Group: System/Libraries
77    
78     %description -n %{libname}
79     Seafile is an open source cloud storage system with features on privacy
80     protection and teamwork. Collections of files are called libraries, and
81     each library can be synced separately. A library can also be encrypted
82     with a user chosen password. Seafile also allows users to create groups
83     and easily sharing files into groups.
84     This package contains library files for %{name}.
85    
86     #----------------------------------------------------
87    
88     %package -n %{develname}
89     Summary: Development files for %{name}
90     Group: Development/C
91     Requires: %{libname} = %{version}-%{release}
92     Provides: %{name}-devel = %{version}-%{release}
93     Provides: lib%{name}-devel = %{version}-%{release}
94    
95     %description -n %{develname}
96     The %{develname} package contains libraries and header files for
97     developing applications that use %{name}.
98    
99     #----------------------------------------------------
100    
101     %package -n python-%{name}
102     Summary: Python 2 bindings for %{name}
103     Group: Development/Python
104     BuildArch: noarch
105     Provides: pythonegg(2)(seafile) = %{version}-%{release}
106     Provides: pythonegg(2)(seaserv) = %{version}-%{release}
107    
108     %description -n python-%{name}
109     Seafile is an open source cloud storage system with features on privacy
110     protection and teamwork. Collections of files are called libraries, and
111     each library can be synced separately. A library can also be encrypted
112     with a user chosen password. Seafile also allows users to create groups
113     and easily sharing files into groups.
114     This package contains the python 2 bindings for %{name}.
115    
116     #----------------------------------------------------
117    
118     %prep
119     %setup -q
120     %patch0 -p1
121     %patch1 -p1
122    
123     sed -i -e /\(DESTDIR\)/d lib/libseafile.pc.in
124    
125     NOCONFIGURE=1 ./autogen.sh
126    
127     %build
128     %configure \
129     --disable-static \
130     --with-mysql \
131     --enable-server \
132     --enable-client \
133     make
134 jpp 1.2
135 jpp 1.1 %install
136     make install DESTDIR=%{buildroot}
137    
138     # we don't want these
139     find %{buildroot} -name '*.la' -delete
140    
141     %files
142     %doc README.markdown
143     %doc LICENSE.txt
144     %{_bindir}/seaf-cli
145     %{_bindir}/seaf-daemon
146     %{_mandir}/man1/*.1.*
147    
148     %files server
149     %doc README.markdown
150     %doc LICENSE.txt
151     %{_bindir}/seaf-fsck
152     %{_bindir}/seaf-fuse
153     %{_bindir}/seaf-migrate
154     %{_bindir}/seaf-server
155     %{_bindir}/seaf-server-init
156     %{_bindir}/seafserv-gc
157     %{_bindir}/%{name}-admin
158     %{_bindir}/%{name}-controller
159    
160     %files -n %{libname}
161     %{_libdir}/lib%{name}.so.%{major}
162     %{_libdir}/lib%{name}.so.%{major}.*
163    
164     %files -n %{develname}
165     %doc README.markdown
166     %{_includedir}/*
167     %{_libdir}/lib%{name}.so
168     %{_libdir}/pkgconfig/lib%{name}.pc
169    
170     %files -n python-%{name}
171     %doc README.markdown
172     %{python_sitearch}/%{name}/
173     %{python_sitearch}/seaserv/
174    
175    
176     %changelog
177 jpp 1.2 * Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 5.1.3-1.sme
178 jpp 1.1 - First import to SME Server
179     - test with vala < 0.26 : vala-0.10.4-1.el6
180    
181     * Tue Nov 01 2016 daviddavid <daviddavid> 5.1.3-1.mga5
182     + Revision: 1064503
183     - new version: 5.1.3
184    
185     + neoclust <neoclust>
186     - Use version 5.1.2 on backports
187     - Add to backports
188    
189     * Thu Jun 30 2016 daviddavid <daviddavid> 5.1.3-1.mga6
190     + Revision: 1038172
191     - new version: 5.1.3
192    
193     * Thu May 12 2016 daviddavid <daviddavid> 5.1.1-4.mga6
194     + Revision: 1014279
195     - add the server part of seafile
196    
197     * Sat May 07 2016 daviddavid <daviddavid> 5.1.1-3.mga6
198     + Revision: 1010167
199     - add another missing requires on ccnet
200    
201     * Sat May 07 2016 daviddavid <daviddavid> 5.1.1-2.mga6
202     + Revision: 1010149
203     - add missing requires on python-seafile
204    
205     * Fri May 06 2016 daviddavid <daviddavid> 5.1.1-1.mga6
206     + Revision: 1009890
207     - initial package seafile
208    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed